Find the answer to your Linux question:
Results 1 to 6 of 6
Two years ago I installed Fedora 7 with Compatible SATA mode in BIOS because the system didn't support DVD if set SATA mode in BIOS to Enhanced in Native IDE ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    8

    [SOLVED] GRUB error after SATA port set as Native IDE


    Two years ago I installed Fedora 7 with Compatible SATA mode in BIOS because
    the system didn't support DVD if set SATA mode in BIOS to Enhanced in Native IDE mode.

    The version of kernel is 2.6.23.17-88, intsalled 4 sata hdds with 250GB/each.
    Grub 0.97 is installed in the MBR of /dev/sda.
    /etc/modprobe.conf:
    alias scsi_hostadapter ata_piix
    alias snd-card-0 snd-hda-intel

    Now I will set SATA mode in BIOS to Enhanced(AHCI) /Native IDE mode
    for install more sata hdds, but I will keep fedora 7 and will not upgrade this system because lots of program and libs.

    I tested the system can not boot if set SATA mode in BIOS to Enhanced(AHCI) /Native IDE mode.

    Is any way to fix this problem?
    Thanks for help.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Which Motherboard/chipset do you have?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    8
    Thanks for the reply.
    motherboard: Tyan S5382
    chipset:Intel 5000P + ESB2

    Like I said the problem caused by installation of Fedora 7, because the DVD drive
    didn't work in Enhanced /Native IDE mode. I have to set Compatible SATA mode
    to install fedora 7...

  4. #4
    Linux Newbie
    Join Date
    Sep 2004
    Location
    UK
    Posts
    161
    Do you get a grub menu up and does the kernel boot up to a point?? if yes then:

    while booted in "Compatible SATA mode" rebuild the initrd (mkinitrd) and make sure the AHCI/SATA drivers are included (can't remember the command line option). The original initrd will not have the SATA/AHCI drivers in it.
    In a world without walls and fences, who needs Windows and Gates?

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    A few workarounds are here. You have to compile kernel with proper support for your chipset.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined!
    Join Date
    Mar 2010
    Posts
    8
    Thank you all. I have already solved this problem through updating the system from network, not using DVD drive. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •