Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
Hi all, I'm having trouble booting windows after putting ubuntu on one of my disks. Here is what I did: I had two windows installations on this box, one on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164

    [SOLVED] dual boot windows problem


    Hi all,
    I'm having trouble booting windows after putting ubuntu on one of my disks.

    Here is what I did: I had two windows installations on this box, one on each
    of the two hard disks. The "first" was the OEM that came bundled with the box.
    I kept having trouble with that windows, so I put another on the 2nd disk.
    Both are/were windows xp.

    My new install of ubuntu replaces the first windows installation, and
    now I can only boot ubuntu, and not windows.
    In fact, the ubuntu installed stated that there was "no operating system" on
    the 2nd hard disk.

    This is what fdisk -l says:
    Code:
    Disk /dev/sda: 163.9 GB, 163928604672 bytes
    255 heads, 63 sectors/track, 19929 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xccd3ccd3
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1       19178   154047253+  83  Linux
    /dev/sda2           19179       19929     6032407+   5  Extended
    /dev/sda5           19179       19929     6032376   82  Linux swap / Solaris
    
    Disk /dev/sdb: 200.0 GB, 200049647616 bytes
    255 heads, 63 sectors/track, 24321 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x21cd21cc
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1               1       24321   195358401    7  HPFS/NTFS
    I'm suspecting that the problem is the missing "boot" flag for sdb,
    but I want to be sure before I mess things up.

    So: should I "activate" the sdb?
    I would use the Supergrub Disk for this purpose, right?

    thanks! kai

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    There is no need to use SuperGRUB CD because you haven't installed Linux Boot Loader in Hard disk having Windows OS and Ubuntu is booting up fine. Its not a GRUB problem.

    Did you setup dual boot in both Windows OSes earlier?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164
    hi casper, thanks for the prompt reply!

    yes, when I still had two windows xp installs, those were dual boot.
    I suppose there was a windows boot manager on the first hdd (the disk that
    now has ubuntu on it).

    i'm not sure what you mean when you're saying "setup dual boot in both
    Windows OSes". how would i have done this?

    initially, ubuntu came without grub (understandably, since the ubuntu installer
    thought there was no other operating system). during my attempts to create
    a dual boot system, i did install the grub package, and i did call "update-grub"
    or something similar -- so the first hdd now has grub installed.

    i have tried the supergrub menu item "boot windows from 2nd hdd" but to
    no avail.

    kai

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    yes, when I still had two windows xp installs, those were dual boot. I suppose there was a windows boot manager on the first hdd.
    That means, Windows Boot Loader was configured to boot up both OSes, e.g. XP1 and XP2.

    Here is a problem now. You have removed XP1 and Windows Boot Loader was configured through XP1 only. Its not possible to boot up other XP2 now.

    XP1 -> Windows Boot Loader used its boot.ini file to boot it up.
    Installed XP2 -> Windows Boot Loader of XP1 took control, merged its boot.ini file with XP1.

    You have removed XP1. There isn't any Windows Boot Loader now. XP2 don't have any boot.ini file. Its not possible to boot up now.

    Try creating new boot.ini file in its C:\ Drive. It might work.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164
    OK, sound like I need to learn the basics of how booting windows is done.
    I've found a sample boot.ini here:
    Code:
    [boot loader]
    timeout=30
    default=multi(0)rdisk(0)disk(0)partition(1)\WINNT
    [operating systems]
    multi(0)rdisk(0)disk(0)partition(1)
            \WINNT="Windows NT Workstation 4.00"
    multi(0)rdisk(0)disk(0)partition(1)
            \WINNT="Windows NT Workstation 4.00 [VGA mode]"
                    /basevideo /sos
    C:\="DOS"
    ...but I don't understand enough to make sense of it.
    Well, some reading for me to do.

    thanks, I will be back!
    kai

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    That is a boot.ini of Windows NT.

    Try this file :
    Code:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer
    Its default boot.ini file. XP has been installed in first partition of Hard disk.

    Boot up from LiveCD of any Linux distro, mount Windows partition and copy attached boot.txt file. Rename it to boot.ini.
    Attached Files Attached Files
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164
    Great, thanks!

    I'm not in front of my box, but I will try it as soon as I get a chance.

    kai

  8. #8
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    164
    hm, so far no luck.

    I've created a new boot.ini following your instructions.
    It seems to be in the right place, because the boot_info script (from sourceforge)
    picks it up correctly:
    Code:
                    Boot Info Script 0.55    dated February 15th, 2010                    
    
    ============================= Boot Info Summary: ==============================
    
     => Grub 0.97 is installed in the MBR of /dev/sda and looks on the same drive 
        in partition #1 for /boot/grub/stage2 and /boot/grub/menu.lst.
     => Windows is installed in the MBR of /dev/sdb
    
    sda1: _________________________________________________________________________
    
        File system:       ext3
        Boot sector type:  -
        Boot sector info:  
        Operating System:  Ubuntu 9.10
        Boot files/dirs:   /boot/grub/menu.lst /etc/fstab
    
    sda2: _________________________________________________________________________
    
        File system:       Extended Partition
        Boot sector type:  -
        Boot sector info:  
    
    sda5: _________________________________________________________________________
    
        File system:       swap
        Boot sector type:  -
        Boot sector info:  
    
    sdb1: _________________________________________________________________________
    
        File system:       ntfs
        Boot sector type:  Windows XP
        Boot sector info:  No errors found in the Boot Parameter Block.
        Operating System:  Windows XP
        Boot files/dirs:   /boot.ini
    
    =========================== Drive/Partition Info: =============================
    ================================ sdb1/boot.ini: ================================
    
    [boot loader]
    
    timeout=30
    
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    
    [operating systems]
    
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer
    I've cut some lines, but I'm attaching the whole output from boot_info

    kai
    Attached Files Attached Files

  9. #9
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    hm, so far no luck
    What does that mean? What happens? Do you have the windows hard drive set to first boot priority in the BIOS? If you have the Ubuntu disk set to first boot priority, it won't boot windows because you have no entry for windows in your /boot/grub/menu.lst file.

    After creating the boot.ini file, did you check to see if you have NTLDR and NTDETECT files in the root of your C:\ partition?

    If you have the needed files, you should be able to boot if you set the windows drive to first boot ;priority.

    You should also be able to boot it if you have your Ubuntu drive set to first boot priority if you have the correrct entry in menu.lst. Which do you want to do?

  10. #10
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    360
    in reference to post by yancek
    If you notice on the boot info scrip for sdb1 does not list all needed boot files, it should show:
    Boot files/dirs: /boot.ini /NTLDR /NTDETECT.COM

    Due to sda,x was the boot drive for XP , the second copy of XP did not contain the above files. They must be added to sdb1 root.. You will need the XP cd and use recovery console to copy or use linux.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •