Find the answer to your Linux question:
Results 1 to 9 of 9
hello! i got a dual-boot. both are debian. yesterday i upgraded one of them to debian-squeeze and to grub2. that installations boots just fine. but for the second i get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    79

    render error detected


    hello!
    i got a dual-boot. both are debian. yesterday i upgraded one of them to debian-squeeze and to grub2.
    that installations boots just fine.
    but for the second i get the error message from the thread title:
    "render error detected"
    after the grub-menu.
    if i choose single user mode it boots and hangs waiting for the root file system.

    i found this results at google (which i am not allowed to post yet) but i don't understand them.
    search term is like the thread title.

    is it related to grub2 or is something else wrong? someone knows that error message?
    thanks

  2. #2
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Looks related to the i915 chipset. Straight debian from debian.org, or another debian distro? Fix is in the works for Ubuntu.
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/404064

    One poster on that bug says:
    Disabling KMS with "i915.modeset=0" solves the problem.

    That's for his specific manifestation, but you might give it a try.

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    79
    its "straight" debian. i will check for the boot-parameter (but ain't got much experience with that).
    i was able to boot (grub2 made a wrong entry in the disk-by-UUID line), so the problem is not that "hot" anymore. thanks for the link.

  4. #4
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Put the modeset at the end of the kernel line in /boot/grub/grub.conf (or menu.lst, I'm a Red Hat guy, not sure about debian), for the current kernel.

    I was wondering about the hang, it wasn't called out in the bug report. Looks like the bug is innocuous in many cases. Glad you found the uuid problem.

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    79
    thanks for the further info. i have assumed it that way, but if you never do it... questions arise.
    will try now and post back.

    i'm not sure if the problem with UUID is related at all. grub2 doesn't always seem to run that smooth (for me usually it does, this time it didn't ).

  6. #6
    Just Joined!
    Join Date
    Mar 2010
    Posts
    79
    that did work. of course. during boot i am getting informed that "i915.modeset=0" is set.
    time to understand the why now.
    thanks a lot.

  7. #7
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Have a look at these for more understanding:
    KernelModesetting - Debian Wiki
    https://wiki.ubuntu.com/X/KernelModeSetting

    Be sure to see the Fedora and Gentoo links under Resources at bottom of the first one.

  8. #8
    Just Joined!
    Join Date
    Mar 2010
    Posts
    79
    aha.
    i had a short read of the debian-wiki article, and i suffer from some of the bugs mentioned there
    (i have assumed the PC would be old, and that's it).
    If i understood correct editing /etc/modprobe.d/i915-kms.conf is the same like adding the line in grub.cfg. I did that and will examine it during the next days.

    i also had a short look at the other links, and think i will be able to understand a bit more. that will take some time.

    thanks a lot.

  9. #9
    Linux Enthusiast Mudgen's Avatar
    Join Date
    Feb 2007
    Location
    Virginia
    Posts
    664
    Actually, I saw a post in which it was said that the modeprobe.d method did NOT work for this, although it should have, as you say. The kernel boot modeset parameter was said to be reliable.

    It's always fun to help those who will do some reading and experimenting to help themselves. Good luck, post back if you need more help. Lots of good minds around here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •