Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Sorry I had to paste the whole output. Maybe it can explain what's went wrong Code: [root@localhost ~]# yum install crypto-utils fuse-cryptofs m2crypto python-crypto gcc gcc-c++ Loaded plugins: fastestmirror, priorities ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272

    Sorry I had to paste the whole output. Maybe it can explain what's went wrong

    Code:
    [root@localhost ~]# yum install crypto-utils fuse-cryptofs m2crypto python-crypto gcc gcc-c++
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
     * addons: mirror.averse.net
     * base: mirror.averse.net
     * extras: mirror.averse.net
     * rpmforge: apt.sw.be
     * updates: mirror.averse.net
    Setting up Install Process
    Package m2crypto-0.16-6.el5.6.i386 already installed and latest version
    Package gcc-4.1.2-46.el5_4.2.i386 already installed and latest version
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
    The program yum-complete-transaction is found in the yum-utils package.
    --> Running transaction check
    ---> Package crypto-utils.i386 0:2.3-2.el5 set to be updated
    --> Processing Dependency: newt-perl for package: crypto-utils
    ---> Package fuse-cryptofs.i386 0:0.6.0-1.el5.rf set to be updated
    --> Processing Dependency: fuse >= 2.2 for package: fuse-cryptofs
    --> Processing Dependency: libfuse.so.2(FUSE_2.6) for package: fuse-cryptofs
    --> Processing Dependency: libfuse.so.2 for package: fuse-cryptofs
    ---> Package gcc-c++.i386 0:4.1.2-46.el5_4.2 set to be updated
    --> Processing Dependency: libstdc++-devel = 4.1.2-46.el5_4.2 for package: gcc-c++
    ---> Package python-crypto.i386 0:2.0.1-1.el5.rf set to be updated
    --> Running transaction check
    ---> Package fuse.i386 0:2.7.4-8.el5 set to be updated
    ---> Package fuse-libs.i386 0:2.7.4-8.el5 set to be updated
    ---> Package libstdc++-devel.i386 0:4.1.2-46.el5_4.2 set to be updated
    GoOo/filelists                                           | 819 kB     00:23
    rpmforge/filelists                                       | 4.1 MB     01:21
    ---> Package newt-perl.i386 0:1.08-9.2.2 set to be updated
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ================================================================================
     Package               Arch       Version                  Repository      Size
    ================================================================================
    Installing:
     crypto-utils          i386       2.3-2.el5                base            35 k
     fuse-cryptofs         i386       0.6.0-1.el5.rf           rpmforge        32 k
     gcc-c++               i386       4.1.2-46.el5_4.2         updates        3.4 M
     python-crypto         i386       2.0.1-1.el5.rf           rpmforge       335 k
    Installing for dependencies:
     fuse                  i386       2.7.4-8.el5              base            83 k
     fuse-libs             i386       2.7.4-8.el5              base            72 k
     libstdc++-devel       i386       4.1.2-46.el5_4.2         updates        2.8 M
     newt-perl             i386       1.08-9.2.2               base            78 k
    
    Transaction Summary
    ================================================================================
    Install      8 Package(s)
    Update       0 Package(s)
    Remove       0 Package(s)
    
    Total download size: 6.8 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/8): fuse-cryptofs-0.6.0-1.el5.rf.i386.rpm             |  32 kB     00:01
    (2/8): crypto-utils-2.3-2.el5.i386.rpm                   |  35 kB     00:00
    (3/8): fuse-libs-2.7.4-8.el5.i386.rpm                    |  72 kB     00:01
    (4/8): newt-perl-1.08-9.2.2.i386.rpm                     |  78 kB     00:01
    (5/8): fuse-2.7.4-8.el5.i386.rpm                         |  83 kB     00:04
    (6/8): python-crypto-2.0.1-1.el5.rf.i386.rpm             | 335 kB     00:07
    (7/8): libstdc++-devel-4.1.2-46.el5_4.2.i386.rpm         | 2.8 MB     02:10
    (8/8): gcc-c++-4.1.2-46.el5_4.2.i386.rpm                 | 2.1 MB     02:03
    http://mirror.averse.net/centos/5.4/updates/i386/RPMS/gcc-c%2B%2B-4.1.2-46.el5_4.2.i386.rpm: [Errno 4] Socket Error: timed out
    Trying other mirror.
    (8/8): gcc-c++-4.1.2-46.el5_4.2.i386.rpm                 | 3.4 MB     00:30
    --------------------------------------------------------------------------------
    Total                                            22 kB/s | 6.8 MB     05:21
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
      Installing     : fuse                                                     1/8
      Installing     : fuse-libs                                                2/8
      Installing     : newt-perl                                                3/8
      Installing     : crypto-utils                                             4/8
      Installing     : fuse-cryptofs                                            5/8
      Installing     : python-crypto                                            6/8
      Installing     : libstdc++-devel                                          7/8
      Installing     : gcc-c++                                                  8/8
    
    Installed:
      crypto-utils.i386 0:2.3-2.el5        fuse-cryptofs.i386 0:0.6.0-1.el5.rf
      gcc-c++.i386 0:4.1.2-46.el5_4.2      python-crypto.i386 0:2.0.1-1.el5.rf
    
    Dependency Installed:
      fuse.i386 0:2.7.4-8.el5                      fuse-libs.i386 0:2.7.4-8.el5
      libstdc++-devel.i386 0:4.1.2-46.el5_4.2      newt-perl.i386 0:1.08-9.2.2
    
    Complete!

    Code:
    [root@localhost Desktop]# ls
    Home.desktop    VirtualBox-3.1-3.1.6_59338_fedora9-1.i386.rpm
    System.desktop  VirtualBox-3.1.6-59338-Linux_amd64.run
    trash.desktop
    [root@localhost Desktop]# yum install VirtualBox-3.1-3.1.6_59338_fedora9-1.i386.rpm
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
     * addons: mirror.averse.net
     * base: mirror.averse.net
     * extras: mirror.averse.net
     * rpmforge: apt.sw.be
     * updates: mirror.averse.net
    Setting up Install Process
    Examining VirtualBox-3.1-3.1.6_59338_fedora9-1.i386.rpm: VirtualBox-3.1-3.1.6_59338_fedora9-1.i386
    Marking VirtualBox-3.1-3.1.6_59338_fedora9-1.i386.rpm to be installed
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
    The program yum-complete-transaction is found in the yum-utils package.
    --> Running transaction check
    ---> Package VirtualBox-3.1.i386 0:3.1.6_59338_fedora9-1 set to be updated
    --> Processing Dependency: python(abi) = 2.5 for package: VirtualBox-3.1
    --> Processing Dependency: libcrypto.so.7 for package: VirtualBox-3.1
    --> Processing Dependency: libcurl.so.4 for package: VirtualBox-3.1
    --> Processing Dependency: libpython2.5.so.1.0 for package: VirtualBox-3.1
    --> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: VirtualBox-3.1
    --> Finished Dependency Resolution
    VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 from /VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 has depsolving problems
      --> Missing Dependency: libpython2.5.so.1.0 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 from /VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 has depsolving problems
      --> Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 from /VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 has depsolving problems
      --> Missing Dependency: python(abi) = 2.5 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 from /VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 has depsolving problems
      --> Missing Dependency: libcrypto.so.7 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 from /VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 has depsolving problems
      --> Missing Dependency: libcurl.so.4 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    Error: Missing Dependency: libpython2.5.so.1.0 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    Error: Missing Dependency: python(abi) = 2.5 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    Error: Missing Dependency: libcrypto.so.7 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
    Error: Missing Dependency: libcurl.so.4 is needed by package VirtualBox-3.1-3.1.6_59338_fedora9-1.i386 (/VirtualBox-3.1-3.1.6_59338_fedora9-1.i386)
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package.
    [root@localhost Desktop]#
    nujinini
    Linux User #489667

  2. #12
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    Ok. I see what's wrong. You are trying to install the fedora VBox on CentOS. You need to install the rhel version. The file you need to download is VirtualBox-3.1-3.1.6_59338_rhel5-1.x86_64.rpm, not the one you are trying to use.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #13
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by nujinini View Post
    Dapper Dan, I downloaded the link and got a .run file. Am not familiar how to install
    As su do:
    Code:
    sh VirtualBox-3.1.6-59338-Linux_amd64.run
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #14
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Hello!

    I tried both approaches...
    Code:
    [root@localhost ~]# cd /home/jun/Desktop
    [root@localhost Desktop]# ls
    Home.desktop    VirtualBox-3.1-3.1.6_59338_rhel5-1.x86_64.rpm
    System.desktop  VirtualBox-3.1.6-59338-Linux_amd64.run
    trash.desktop
    [root@localhost Desktop]# yum install VirtualBox-3.1-3.1.6_59338_rhel5-1.x86_64.rpm
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
     * addons: mirror.averse.net
     * base: mirror.averse.net
     * extras: mirror.averse.net
     * rpmforge: apt.sw.be
     * updates: mirror.averse.net
    Setting up Install Process
    Examining VirtualBox-3.1-3.1.6_59338_rhel5-1.x86_64.rpm: VirtualBox-3.1-3.1.6_59338_rhel5-1.x86_64
    Cannot add package VirtualBox-3.1-3.1.6_59338_rhel5-1.x86_64.rpm to transaction. Not a compatible architecture: x86_64
    Nothing to do
    Code:
    [root@localhost Desktop]# cd /
    [root@localhost /]# sh '/home/jun/Desktop/VirtualBox-3.1.6-59338-Linux_amd64.run'
    Verifying archive integrity... All good.
    Uncompressing VirtualBox for Linux installation.........
    VirtualBox Version 3.1.6 r59338 (2010-03-25T19:09:55Z) installer
    Detected unsupported x86 environment.
    [root@localhost /]#
    Downloading i386 arch and repeat whole process again.

    EDIT:
    Code:
    [root@localhost /]# yum install '/home/jun/Desktop/VirtualBox-3.1-3.1.6_59338_rhel5-1.i386.rpm'
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
     * addons: mirror.averse.net
     * base: mirror.averse.net
     * extras: mirror.averse.net
     * rpmforge: apt.sw.be
     * updates: mirror.averse.net
    Setting up Install Process
    Examining /home/jun/Desktop/VirtualBox-3.1-3.1.6_59338_rhel5-1.i386.rpm: VirtualBox-3.1-3.1.6_59338_rhel5-1.i386
    Marking /home/jun/Desktop/VirtualBox-3.1-3.1.6_59338_rhel5-1.i386.rpm to be installed
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
    The program yum-complete-transaction is found in the yum-utils package.
    --> Running transaction check
    ---> Package VirtualBox-3.1.i386 0:3.1.6_59338_rhel5-1 set to be updated
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ================================================================================
     Package
        Arch  Version               Repository                                 Size
    ================================================================================
    Installing:
     VirtualBox-3.1
        i386  3.1.6_59338_rhel5-1   /VirtualBox-3.1-3.1.6_59338_rhel5-1.i386   98 M
    
    Transaction Summary
    ================================================================================
    Install      1 Package(s)
    Update       0 Package(s)
    Remove       0 Package(s)
    
    Total size: 98 M
    Is this ok [y/N]: y
    Downloading Packages:
    warning: rpmts_HdrFromFdno: Header V4 DSA signature: NOKEY, key ID 6dfbcbae
    
    
    Public key for VirtualBox-3.1-3.1.6_59338_rhel5-1.i386.rpm is not installed
    Last edited by nujinini; 04-10-2010 at 09:41 AM.
    nujinini
    Linux User #489667

  5. #15
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    Ah! Success at last! From one of your earlier posts I thought you were running the 64bit version of the operating system. Apparently not. That's why you had to get the i386 version of VirtualBox. I don't know what the business about the public key is unless it has something to do with getting the non-free version. I've never encountered that problem and I've been installing/removing/installing/updating VirtualBox for at least 2 years.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #16
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Ah! Success at last! From one of your earlier posts I thought you were running the 64bit version of the operating system.
    Yeah! All the while I thought I had a 64 bit

    That's why you had to get the i386 version of VirtualBox. I don't know what the business about the public key is unless it has something to do with getting the non-free version.
    I tried the rpm instead of yum and got it working.
    [root@localhost ~]# rpm -Uvh '/home/jun/Desktop/VirtualBox-3.1-3.1.6_59338_rhel5-1.i386.rpm'
    warning: /home/jun/Desktop/VirtualBox-3.1-3.1.6_59338_rhel5-1.i386.rpm: Header V4 DSA signature: NOKEY, key ID 6dfbcbae
    Preparing... ########################################### [100%]
    1:VirtualBox-3.1 ########################################### [100%]

    Creating group 'vboxusers'. VM users must be member of that group!

    No precompiled module for this kernel found -- trying to build one. Messages
    emitted during module compilation will be logged to /var/log/vbox-install.log.

    Success!

    [root@localhost ~]#
    I have to install XP in virtualbox first and then, play around with samba (not the dance ).

    I read that its going to be needed for the file server I am trying to learn make. Thank you all!
    nujinini
    Linux User #489667

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •