Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    Create /boot/grub/grub.conf file manually.
    Ok, and so I did. If I let the PC reboot normally from HDD, then I get the same old behaviour:
    Code:
    GRUB Loading stage1.5.
    GRUB loading, please wait...
    Error 15
    And indeed why should it be different - the MBR is still loaded with that failed LILO bootloader.

    If I boot with the GRUB boot disk (0.97-os.1), then I can choose the menu entry
    Code:
    !LINUX! (1)    AUTO
    ..and then I am presented with fresh GRUB menu with one entry, "Linux". I guess, this comes from the loaded /boot/grub/grub.conf file. When I click Enter, PC engages in boot sequence. It ends with some complaints that "the /dev/hda1 was was not cleanly unmounted, check forced". And launches fsck. fsck, in turn, fails with message
    Code:
    fsck failed. Please repair manually and reboot.  Please note that the root file system is mounted read-only.  To remount it read-write:
    # mount -n -o remount,rw /
    Then I did the rebooting, booted from GRUB CD once again, did the same thing as the previous time, and now it booted nicely to the end. So, hooray, I am finally in the native Linux that's installed on this PC. So the further questions are:
    1) How to install now GRUB in the MBR, so that I don't have to use that GRUB boot CD?
    2) Why does that kernel line in grub.conf is "ro"? Should it be left so, once everything seems to be fine?

  2. #12
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,746
    And indeed why should it be different - the MBR is still loaded with that failed LILO bootloader.
    There isn't any trace of Lilo boot loader because its throwing GRUB error message only. Something is wrong with grub installation only and you have to re-install it.

    You are using GRUB Legacy and its really easy to re-install it.
    Execute this in Terminal
    Code:
    grub-install /dev/hda
    You must have root privileges to execute above command.
    2) Why does that kernel line in grub.conf is "ro"? Should it be left so, once everything seems to be fine?
    ro is default read only option passed to the kernel and it should be kept as it is.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #13
    Well, finally, I could get it start up normally. Million thanks!

    It was quite a pain to do it in Luit Linux tho. It's quite challenging for novice like me to do the app installs there, etc. And the Xcfe, with all its compactness, is quite slow, comparing with the native DLS fluxbox. Sorry, DSL, I called you ugly, now I come back ashamed for my behaviour. DSL also seems to receive some decent support, still. Luit Linux is severely discontinued and has many issues.

    However, I learned so many things, by being stubborn and do the install till end. Especially about the bootloaders

  4. $spacer_open
    $spacer_close
  5. #14
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,746
    Boot Loader configuration is same in all Linux distros. New version of most of distros are switching to GRUB2 now and its much easier to configure it. Unlike GRUB where one has to create Menu file ( grub.conf ) manually, GRUB2 generates Menu file ( grub.cfg ) through its scripts.

    Best way to learn is, keep experimenting. Anyways, glad to help you !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •