Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I tried to install fedora13-beta x86-64 for dual booting with the pre-installed Windows7 on Toshiba Satellite U505 with 4G Ram and 500G of HD. Re-booting after the installation, the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    9

    Dual Boot Fedora13 beta-Windows7 on Toshiba Satellite x-64


    Hi,

    I tried to install fedora13-beta x86-64 for dual booting with the
    pre-installed Windows7 on Toshiba Satellite U505 with 4G Ram and 500G
    of HD.

    Re-booting after the installation, the machine only booted the
    fedora13, directly.
    Failure, I thought and therefore I wanted to recover the windows7.
    Press 0 while switching on the box (recovery procedure), the dual
    boot option came out.
    So, the dual boot of fedore13-beta and windows7 is OK, but why should
    we press 0 for the dual booting. This also means I could no longer do
    recovery from the HD.
    Any clue?
    Thanks,
    TS

  2. #2
    xps
    xps is offline
    Just Joined!
    Join Date
    May 2009
    Location
    Western USA
    Posts
    2
    Hi Tasrief..
    Could you post your /boot/grub/grub.conf file for us?
    Could be you just need to edit the "timeout" line;.. and "comment out" (with a "#" symbol) the "hiddenmenu" line...Like this:
    timeout=50
    (and)
    #hiddenmenu

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Are you sure that Boot Options appear on pressing zero only?
    Boot up Fedora and open /boot/grub/grub.conf file with root privileges. Put # sign before hiddenmenu line. Save file and reboot machine.
    Code:
    su -
    nano /boot/grub/grub.conf
    Press Ctrl+X, Y and hit Enter key to save file.

    In case it doesn't work, post contents of grub.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2007
    Posts
    9
    HI,

    Yes, I forgot to mention that after the installation, I edited the /boot/grub/grub.conf,
    rootnoverify (hd0,0) ----> rootnoverify (hd0,1)
    This enables dual booting but you have to press 0 while swthing on.

    With the respons from GURU (XPS), the dual booting is now OK, no need to
    press 0 anymore. Thanks a lot.

    Well one more thing, the embeded mouse can not be activated, so I have to use the external one. Hope someone can provide help.
    Below is the edited grub.conf
    Thanks,
    TS
    -------------

    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,4)
    # kernel /vmlinuz-version ro root=/dev/mapper/VolGroup-lv_root
    # initrd /initrd-[generic-]version.img
    #boot=/dev/sda
    default=0
    timeout=50
    splashimage=(hd0,4)/grub/splash.xpm.gz
    #hiddenmenu
    title Fedora (2.6.33.1-24.fc13.x86_64)
    root (hd0,4)
    kernel /vmlinuz-2.6.33.1-24.fc13.x86_64 ro root=/dev/mapper/VolGroup-lv_root rd_LVM_LV=VolGroup/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
    initrd /initramfs-2.6.33.1-24.fc13.x86_64.img
    title Other
    rootnoverify (hd0,1)
    chainloader +1

  6. #5
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Quote Originally Posted by tasrief View Post
    Well one more thing, the embeded mouse can not be activated, so I have to use the external one. Hope someone can provide help.
    Please try to press Fn and hit F8 twice.
    nujinini
    Linux User #489667

  7. #6
    Just Joined!
    Join Date
    Jul 2007
    Posts
    9
    Hi Nujinini,
    Thnaks for responding, but still does not work. I tried to install synaptics by the line command as a root
    > yum install synaptic
    After the packages sucessfully installed and re-start the x-server, still the touchpad does not work.
    Any other clue?
    Thanks,
    TS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •