Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I have a system with no DVD/CD ROM Drive and would like to install RHEL5 using a USB Pen Drive. Is this possible for RHEL5?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5

    [SOLVED] Installing RHEL5 from USB


    Hello,

    I have a system with no DVD/CD ROM Drive and would like to install RHEL5 using a USB Pen Drive. Is this possible for RHEL5?

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome!

    You might be able to do it with UNetbootin:

    UNetbootin - Homepage and Downloads
    oz

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5
    Thanks, I did tryu Unetbootin and no luck. I am getting the same error as a previous post, but don't think anyone replied with a solution.

    Here is the post I was referring to:

    I am trying to create a USB install stick which will contain some extra files to copy care of the ks.cfg.

    But I run into 2 problems, depending on which help guide I follow!

    1a. Copy USB diskboot
    As stated on the RHEL-5 Installation Guide ch02s04s01, the following code should do the trick :-

    Code:
    dd if=diskboot.img of=/dev/sda
    And yes, it does actually work/boot, but it obliterates the MBR!


    Code:
    # fdisk -l

    Disk /dev/hdc: 4096 MB, 4096253952 bytes
    255 heads, 63 sectors/track, 498 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hdc1 * 1 498 4000153+ 83 Linux

    Disk /dev/sda: 4009 MB, 4009754624 bytes
    124 heads, 62 sectors/track, 1018 cylinders
    Units = cylinders of 7688 * 512 = 3936256 bytes

    This doesn't look like a partition table
    Probably you selected the wrong device.

    Device Boot Start End Blocks Id System
    /dev/sda1 ? 392888 392954 253319 e4 SpeedStor
    Partition 1 has different physical/logical beginnings (non-Linux?):
    phys=(190, 120, 0) logical=(392887, 53, 51)
    Partition 1 has different physical/logical endings:
    phys=(544, 125, 44) logical=(392953, 41, 24)
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 ? 130927 389508 993984023 98 Unknown
    Partition 2 has different physical/logical beginnings (non-Linux?):
    phys=(1010, 16, 43) logical=(130926, 48, 10)
    Partition 2 has different physical/logical endings:
    phys=(205, 205, 22) logical=(389507, 4, 55)
    Partition 2 does not end on cylinder boundary.
    /dev/sda3 ? 220685 470413 959953209 7d Unknown
    Partition 3 has different physical/logical beginnings (non-Linux?):
    phys=(252, 139, 46) logical=(220684, 115, 54)
    Partition 3 has different physical/logical endings:
    phys=(367, 195, 2) logical=(470412, 76, 25)
    Partition 3 does not end on cylinder boundary.
    /dev/sda4 ? 691 1774 4161536 0 Empty
    Partition 4 has different physical/logical beginnings (non-Linux?):
    phys=(0, 10, 0) logical=(690, 59, 39)
    Partition 4 has different physical/logical endings:
    phys=(0, 0, 0) logical=(1773, 10, 44)
    Partition 4 does not end on cylinder boundary.

    Partition table entries are not in disk order
    Surely the command should be?? (i.e. give it a partition number?)

    Code:
    dd if=diskboot.img of=/dev/sda1

    In anycase, this gives me a 12Mb partition that about 30% is used.
    So I cant fit a lot in there!


    1b. Create own image file, but Larger!
    I can do that, and again it boots, but it then brings me to my second problem



    2. Do it the long (prober) way
    I read these steps, and the like around places :-
    1. make 2 partition of usb drive, first 500mb and another more then 3gb
    2. In first partition install bootable image (diskboot.img)
    3. In second partition (sdb2) copy ISO image of RHEL 5
    4. first step will take you up to install from
    5. cdrom/harddrive/nfs/ftp/http srceen. select harddisk, sdb2 and follow the steps to complete you installation

    >2. as above.
    >3. Does that mean the files or the ISO as a file?
    >5. I cannot get to choose the sda1/2!?


    Code:
    Installation Method
    What type of media contains the packages to be installed?
    Select : Hard drive

    Select Partition -
    What partition and directory on that partition hold the CD (iso9660) images for Red Hat Enterprise Linux Server?
    If you don't see the disk drive you're using listed here, press F2 to configure additional devices.
    dev/hdc1
    Directory holding images: ______________

    Select:F2


    Driver Disk Source
    You have multiple devices which could serve as sources for a driver disk. Which would you like to use?
    hdc
    sda

    Select:sda


    Insert Driver Disk
    Insert your driver disk into /dev/sda and press "OK" to continue.


    Error - Driver disk is invalid for this release of Red Hat Enterprise Linux Server.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2010
    Posts
    5
    I got this to WORK using unetbootin. Bascialy I had to use the following procedure:

    I tried unetbootin with OEL5. It does create a USB flash drive that you can boot, but then you have to use a network install. It looks like unetbootin copies the contents of the iso to the USB flash drive, but the OEL installer doesn't look for those files, it wants the entire iso file. So you could delete the directories with .rpm files that unetbootin copied to the flash drive, and copy the .iso file to the flash drive. Then you can do a "hard disk" install, and point the installer to the usb flash drive.

    Only thing to remember is that the install process wants to install the bootloader on the usb drive, and this will mess up the usb installation. You would need to select the correct drive to install the bootloader, and do not use the usb drive.. ex /dev/sda1) Works good, unetbootin is a slick program!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •