Find the answer to your Linux question:
Results 1 to 3 of 3
My partitions changed after re-installation from /data and /var to /media/#BunchOfNumbers-1 and media/#BunchOfNumbers-2 respectively. But this is much more involved. I decided to do some server and development testing on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Location
    USA
    Posts
    7

    Partitions switched on me


    My partitions changed after re-installation from /data and /var to /media/#BunchOfNumbers-1 and media/#BunchOfNumbers-2 respectively.

    But this is much more involved.

    I decided to do some server and development testing on my laptop behind a NAT router on my Lubuntu OS. I downloaded firestarter (probably unnecessarily). I also began changing file permissions and ended up crapping my whole /usr file permissions when I did:

    Code:
    chown user:user /*
    chown -R user:user /*
    So when I began doing sudo commands, they didn't work. Something like not proper 'pid'.
    And when I tried without sudo, i needed permissions.

    So I found instructions online to use my live CD (My Lubuntu cd in my case) and do the following commands:

    Code:
    sudo mkdir /mnt/ubuntu
    sudo mount /dev/sda8 /mnt/ubuntu
    sudo chown -R root /mnt/ubuntu/usr
    sudo umount /mnt/ubuntu
    Then I rebooted Lubuntu without the live cd.
    Didn't work. I tried these also but can't remember if I did before or after the previous commands:

    Code:
    chown root:root /usr/bin/sudo
    
    then
    
    chmod 4755 /usr/bin/sudo
    But getting permission denied or not proper pid.

    So I just decided to reinstall Lubuntu. This is where things got wierd.
    Here's setup before reinstalling attempt:

    Code:
    /dev/sda1: fat 16 ------------ 15 gigs
    /dev/sda2: extension
    /dev/sda5: swap -------------  3 gigs
    /dev/sda6: /data ------------ 100 gigs
    /dev/sda7: /var --------------- 20 gigs
    /dev/sda8: / [lubuntu] ------- 20 gigs
    freespace
    During install, I deleted /dev/sda8 and re-installed lubuntu without importing settings.

    Result was that in the "new" Lubuntu the mouse was frozen. And keyboarding to the folders I learned that my /data directory switched to /media/#BunchOfNumbers#, and so did my /var; Both with their correct gigabytes.

    However, I found my /data directory was still there, but empty. And the /var/www was no longer there.

    In system profiler I found that the only partition showing, contrary to before (before this mess started) was the /dev/sda8 root mount point.

    So I tried re-installing Lubuntu again.

    This time the mouse works, same directory setup as the last, but networking is disabled and would not work.

    Also, some of my files (excluding /data and /var) were there from before all this began as if I never re-installed.

    So I installed a linux mint 9 (fluxbox) next to Lubuntu.

    In Mint's grub this is what I found.

    Code:
    Linux Mint 9, 2.6.32-22-generic - - /dev/sda9
    Linux Mint 9 Recovery
    Memory test
    Memory Test serial console 115200
    Ubuntu [Lubuntu] 2.5.32-25 - - /dev/sda8 - - (1st re-install)
    " " Recovery
    Ubuntu [Lubuntu] 2.5.32-21 - - /dev/sda8 - - (2nd re-install)
    " " Recovery
    So both the re-installs of Lubuntu didn't delete each other.

    In Mint's disk utility, just one partition is showing for /dev/sda8 at 20gb which contain both of the Lubuntu installations.

    In Lubuntu, the 2 /media partitions don't show up in disk utility. However, in Mint they do.

    My question to get me started is why did the partitions move to /media?

    If this is permanent, it might be OK as long as they are safe and I can just change my data to /media/data. But having my var files in /media seems kind of pointless.

    If the first question doesn't answer this already, how do I keep a /var partition?
    Last edited by aretudeetu; 11-15-2010 at 10:41 PM.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The bunch of numbers presumably means it's being identified by the UUID. This is something you can easily change in /etc/fstab.

    My guess as to why it's under /media is that you didn't set a mount point for the affected partitions during your re-installation process. So the partitions were detected and mounted as any other temporary/removable disk, ie, a mount point was dynamically created under /media.

    Regardless of why exactly, again, this is something you would change in /etc/fstab.

  3. #3
    Just Joined!
    Join Date
    Nov 2010
    Location
    USA
    Posts
    7
    Thanks for the links.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •