Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
For some reason when I tried installing ubuntu 10.10 on my laptop it gave me error messages that said something about corruption and couldn't wipe my hard drive to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    5

    Unhappy Can't install any operating system on my laptop!


    For some reason when I tried installing ubuntu 10.10 on my laptop it gave me error messages that said something about corruption and couldn't wipe my hard drive to install the os. This happens when I tried installing two different versions of ubuntu, windows xp pro, and when I just tried to wipe my hard drive with boot and nuke, they all give error messages that say stuff about corruption while trying to wipe the hard drive. Whats wrong with my hard drive and how do I fix it?

    and Sorry for not being specific with the error messages but I don't have enough time to try again and right them down, I'll do that tomorrow and update I guess.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,037
    Depends on who made your Hardrive I guess . If it has bad blocks or sectors. You could try using Ultimate Boot CD - Overview to stress test and use the repair tools in it to fix sectors maybe.

    Another thing you could try is booting a Puppy 4.31 iso which will run in ram. Not Hardrive. You can use Gparted in Puppy 4.31 to do a check of hardrive also. Then use Gparted in Puppy to delete,format,label,Flag for Ubuntu install even.
    Below is a direct download of Puppy 4.31 Iso.
    http://distro.ibiblio.org/pub/linux/....1/pup-431.iso
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by earlybird665 View Post
    Whats wrong with my hard drive and how do I fix it?
    Welcome to the forums!

    You can also check your drive with the diagnostics utilities distributed by your hard disk maker intended for that purpose and/or try checking it with smartctl. You can use the Parted Magic LiveCD or some other utility disk for that purpose. If those tools say the drive is failing, I'd believe it and try to recover all that you can while you can, and go with a new drive. Also, keep in mind that your current drive might still be under warranty. Check with the drive maker.

    Let us know how it goes.
    oz

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    5
    thanks, ill try these and update later.

  5. #5
    Linux User Manko10's Avatar
    Join Date
    Sep 2010
    Posts
    250
    If your harddive shows an abnormal high number of bad sectors you should consider replacing it with a new one. Harddrives can mark a few bad sectors as corrupt, so that they are not used anymore. But if there are too many, it's very likely that your disk is dying completely.
    Refining Linux Advent calendar: 24 Outstanding ZSH Gems

  6. #6
    Linux Newbie Charles4809's Avatar
    Join Date
    Nov 2008
    Location
    Utrecht, NL
    Posts
    138
    If your harddrive is hardware encrypted it's possible that the physical sectorsize differs from the logical sectorsize. That would cause the "corruption".
    Charles
    ASUS EEE Box B202, Atom 270 1,6GHz, 1 GB, HDD 80GB, XP-SP3 / PinguyOS
    Asus EEE PC 901 with Bodhi-Linux

  7. #7
    Just Joined!
    Join Date
    Dec 2010
    Posts
    5

    Exclamation

    Thanks for your help everyone but I'm afraid my laptop might be bricked. Every time I try to boot it the logo comes up first, and then it just goes to a black screen with a blinking underscore at the top left corner. I can enter the bios and that's it. It wont boot from a cd or usb stick anymore, there's no floppy drive, and there's no os on the hard drive for it to boot from. It seems all my options are gone. If any one has any idea of what I should try please post it.

    The rest of this is just details if you want to learn more about what happened.

    When I got the laptop, it had windows vista on it. I dual booted it with ubuntu (8.04 I think). Then one day I couldn't boot into windows anymore, I didn't bother fixing it because it was barely used anyways. Ever since then there were issues with the hard drive whenever I tried to install another operating system or change my partitions. One day I was fed up with it and decided to wipe the entire hard drive with boot and nuke. Part ways through it stopped and said it couldn't finish wiping the drive. Then I was left with no os, so I started this thread. After I made this thread the only time I used the laptop was with a live cd, and i didn't mess around with anything all I did was make sure the cd was working and then powered down the laptop for the night, and that brings up until now, my laptop seems completely bricked.

  8. #8
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Try resetting the system BIOS to the defaults and reboot to see if things might start working again.
    oz

  9. #9
    Just Joined!
    Join Date
    Dec 2010
    Posts
    5

    Question

    I reset the BIOS to defaults and a few things changed but it still doesn't look promising. When I turn on the laptop after the logo it prints out this:

    Yukon PXE v6.22.2.3 (20070827)
    (C)Copyright 2003-2007 Marvell(R). All rights reserved.
    Pre-boot eXecution Environment (PXE) v2.1
    (C)Copyright 1997-2000 Intel Corporation.
    PXE-E61: Media test failure, check cable
    PXE-M0F: Exiting PXE ROM.
    _

    If I try to boot from a ubuntu usb stick (which was working last night) I get this:

    SYSLINUX 4.02 2010-07-21 EDD Copyright (C) 1994-2010 H. Peter Anvin et al
    ERROR: No configuration file found
    No DEFAULT or UI configuration directive found!
    boot: _

    I also tried booting from a few cd's and the laptop just ignored them and gave me what it gave me without any cd's. Any thoughts?

  10. #10
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Maybe try re-seating and removing some memory and/or moving some memory sticks around to see what happens if you have multiple sticks and haven't tried it already.

    Otherwise, if the laptop is still under warranty, I'd recommend contacting the manufacturer before going further. If not, you could try upgrading or re-flashing the current BIOS in case it has become corrupted somehow. Of course BIOS flashes are always somewhat risky, so do so only if you feel comfortable doing it.

    I'm not sure what else to suggest at the moment, but will post back should anything come to mind.
    oz

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •