Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I just installed Unbuntu Linux 10.10 alongside with Windows 7. However, when I start my laptop, it just run straight to Linux without asking me to choose Windows or Linux. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    6

    Can't start Windows after install Linux


    I just installed Unbuntu Linux 10.10 alongside with Windows 7. However, when I start my laptop, it just run straight to Linux without asking me to choose Windows or Linux. I already checked my hard drive, the Windows 7 partition is still there. How can I fix it? Thanks.

  2. #2
    Just Joined! hunter_thom's Avatar
    Join Date
    Apr 2010
    Posts
    89
    Your master boot record was overwritten and points to linux. If you have GRUB installed (most likely this is true) then you can navigate to /boot/grub/menu.lst and edit the file to point to the Windows partition by default, or give a longer time-out before booting the default OS, etc.

    For your reference....
    Editing /boot/grub/menu.lst to change the GRUB boot menu | boff

  3. #3
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    Welcome to the forums z7nz ... try here

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    6
    @hunter: I couldn't find file menu.lst. What should I do?

    @Jonathan: I read your link, but I still don't get what I have to do here. I'm really new with Linux. Can you explain it clearer?

  5. #5
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    @Jonathan: I read your link, but I still don't get what I have to do here. I'm really new with Linux. Can you explain it clearer?
    From linked page under editing menus during boot ...
    If the menu is not normally displayed during boot, hold down the SHIFT key as the computer attempts to boot to display the GRUB 2 menu.

    Try this and see if Windows is shown as a menu entry ... if it is try selecting it and see if Windows will boot. If it does all you need to do is get the menu to display ...

    post the output of
    Code:
    cat /etc/default/grub
    and let us know if you get Windows to boot following above ...

    Ed: if Windows does not boot then also post the output of
    Code:
    ls /etc/grub.d/ -l
    sudo blkid
    Last edited by Jonathan183; 12-20-2010 at 11:44 PM. Reason: correct command

  6. #6
    Just Joined! hunter_thom's Avatar
    Join Date
    Apr 2010
    Posts
    89
    Looks like Ubuntu puts the grub config elsewhere (/etc). My mistake, use the document Jonathan provided.

    Basically, you need to edit the GRUB config file to recognize your Windows partition, and use it as the default (if that is what you want). The document shows the GRUB config file that you need to edit. If the Windows partition is already in the config file but is not set to the default, you set the directive in the file to point to the Windows partition as opposed to the linux partition.

  7. #7
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    Quote Originally Posted by hunter_thom View Post
    Looks like Ubuntu puts the grub config elsewhere (/etc).
    Ubuntu now uses grub2 ... menu.lst has been replaced by grub.cfg but this should not normally be edited manually ... I moved to grub2 when I converted my ext3 partitions to ext4 because grub legacy was unable to boot from an ext4 partition.

  8. #8
    Just Joined!
    Join Date
    Dec 2010
    Posts
    6
    There's no Windows option in the menu entry

    cat /etc/default/grub
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    ls /ect/grub.d/ -l
    total 52
    -rwxr-xr-x 1 root root 6831 2010-10-06 08:22 00_header
    -rwxr-xr-x 1 root root 1481 2010-10-06 08:04 05_debian_theme
    -rwxr-xr-x 1 root root 4757 2010-10-06 08:22 10_linux
    -rwxr-xr-x 1 root root 5028 2010-10-06 08:22 20_linux_xen
    -rwxr-xr-x 1 root root 1588 2010-09-24 14:16 20_memtest86+
    -rwxr-xr-x 1 root root 6933 2010-10-06 08:22 30_os-prober
    -rwxr-xr-x 1 root root 214 2010-10-06 08:22 40_custom
    -rwxr-xr-x 1 root root 95 2010-10-06 08:22 41_custom
    -rw-r--r-- 1 root root 483 2010-10-06 08:22 README
    sudo blkid
    [sudo] password for nguyent:
    (I tried my password but it's incorrect)

  9. #9
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    You need to get sudo to work and post the output of either
    Code:
    sudo fdisk -l
    or
    Code:
    sudo blkid
    so we can see partition information. When you installed ubuntu by default you setup a user and enter a password, default is this user to be the system administrator and is put in relevant groups. Are you logged in with the user name and password you entered at installation? did you change any option to enable a root user account?

  10. #10
    Just Joined!
    Join Date
    Dec 2010
    Posts
    6
    I didn't make any changes to the password. I'm logged in with my username and password at installation. I don't know why it didn't accept the password. Is there any way else to see partition information?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •