Find the answer to your Linux question:
Results 1 to 5 of 5
Hi everyone. I've searched for a while now but can't seem to find anything about my problem. Hope someone here has a clue. The thing is I had to re-install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    6

    Problem re-installing partition / [SOLVED]


    Hi everyone.

    I've searched for a while now but can't seem to find anything about my problem. Hope someone here has a clue.

    The thing is I had to re-install LMDE, but only the / partition because I didn't want to loose some configuration files and other info I had on /home. But after re-installing I went to /home/my_user only to find out it was empty, well not empty, but only with the usual default folders and settings, as if it had been re-installed as well. After a short moment of panicking I noticed a new 6G partition, mounted it and saw all the info I thought I had lost. So, where did the "new" /home came from? and how do I restore my original /home so I don't have to mount it every time?
    I'd never re-installed like this so an additional question would be: is it normal or did I mess up during the process?

    Hope I was clear, I thought this was pretty weird so I hope someone can help. Thanks!
    Last edited by brunn; 01-21-2011 at 04:05 AM. Reason: problem solved

  2. #2
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Hi!

    I'm afraid you might have overwritten your data when you reinstalled.

    Can you please post the output of

    Code:
    # fdisk -l
    # df -h
    nujinini
    Linux User #489667

  3. #3
    Just Joined!
    Join Date
    Jan 2011
    Posts
    6
    # fdisk -l shows (sda5 is / and sda6 is /home):

    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x23182317

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 2350 18875360+ 7 HPFS/NTFS
    /dev/sda2 2350 19458 137414656 f W95 Ext'd (LBA)
    /dev/sda5 2351 3656 10485760 83 Linux
    /dev/sda6 3656 4439 6291456 83 Linux
    /dev/sda7 4439 5484 8388608 83 Linux
    /dev/sda8 5484 6528 8388608 83 Linux
    /dev/sda9 19327 19458 1048576 82 Linux swap / Solaris
    /dev/sda10 6528 17238 86028288 83 Linux

    and # df -h:

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda5 9.9G 8.5G 870M 91% /
    tmpfs 505M 0 505M 0% /lib/init/rw
    udev 502M 232K 502M 1% /dev
    tmpfs 505M 92K 505M 1% /dev/shm
    /dev/sda10 81G 1.4G 76G 2% /media/data
    /dev/sda6 6.0G 1.7G 4.0G 31% /media/7c7d6966-fa64-4386-9a46-9a583

    By the way, when I set the partition sizes I gave "/" only 8G because I thought it to be enough, but earlier today I reached the limit (after having LMD installed for less than a week) and I it didn't make sense since I haven't installed that many programs, could this be related?

    Thanks for your help!

  4. #4
    Just Joined!
    Join Date
    Jan 2011
    Posts
    6
    It's taken care of. Here's what I did in case someone else makes the same mistake :P

    # gedit /etc/fstab

    add

    /dev/sdaX /home filetype defaults 0 0

    then mount, restart and that's it.

    Thanks for your reply nujinini!

  5. #5
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Whew! I pretty glad you've got it working already! Your welcome.
    nujinini
    Linux User #489667

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •