Find the answer to your Linux question:
Results 1 to 5 of 5
I was installing mandrake 9.1. The installation went fine, asking for all the cds, all good. But when i got to the part were the system asks you for the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342

    Keyboard unrecognized


    I was installing mandrake 9.1. The installation went fine, asking for all the cds, all good. But when i got to the part were the system asks you for the root password, my usb keyboard stopped working, all it's lights went out and the only thing working was the mouse. But the interesting part is that the mouse, plugged into the keyboard, still works perfectly. What can this be? Last time, i also had problems like that but i worked i don't know what out, and i got it running. Last time also, after having this problem, the system found the keyboard and worked fine. Plz, help!!!!

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Try plugging the keyboard into a different USB slot, if its detecting the mouse then that means mandrake is loading the proper USB modules during the install. If all else fails, do you have a usb to ps/2 converter?

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    i once had a similar problem, try pluging the usb keyboard into the usb ports closest to PS/2 ports, i don't why, but it fixed all my keyboard problems.
    Emotions are the key to the soul.
    Registered Linux User #375050

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    13
    Try this command (using mouse to cut paste letters/ difficult to try out i can say)

    $ lspci

    check whether you have USB controller installed on your machine
    you should get some output as below.
    Code:
    0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
    0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
    0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
    0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 01)
    good luck

  6. #5
    Linux User
    Join Date
    Jul 2004
    Location
    USA, Michigan, Detroit
    Posts
    329
    The easiest way around this that I have found is to just plug an old PS2 keyboard in for the install then after installation switch to the USB keyboard it will usually work and if not you will then a fully working system with which to work on the problem.
    Long live the revolution!
    Have a nice day.
    If you want real change vote Libertarian!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •