Find the answer to your Linux question:
Results 1 to 2 of 2
Hi everybody! I just started installing a LFS.... some problems appeard... First of all a brief info about my knowledge: Im swiss so english is not my mother tongue -> ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2011
    Posts
    1

    LFS System Installation


    Hi everybody!

    I just started installing a LFS.... some problems appeard...

    First of all a brief info about my knowledge:
    Im swiss so english is not my mother tongue -> please excuse bad formulations!
    I have based knowledge of C, Java and Assembler.
    I am intrested in linux so i tried to create my own lfs.
    Linux from the Scratch 6.4 / Linux on VM
    After creating an empty partition i defined the datasystem ext3 and set the mountpoint. Creating a link like /mnt/lfs on $LFS was no problem. Also creating an user worked fine (username = lfs).

    At this point the confusion started. Do i have to copy the binutils packege to the new ext3 partition and install it there by using th user lfs. I guess so, so i tried it. It worked.

    Next i copied the gmp and the mpfr, unpacked into the folder source on the ext3. Then i tried to compile the gcc package on the ext3 using the user lfs.... -> error

    gmp and mpfr are needed, but i cant install them.

    At which point of my progress did i make the mistake or am i completly wrong?

    For the case that this is a perfectly dum question i am sorry for asking!

    Thx for your feedback!

    Greez Crimson

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,158
    All this stuff is covered in detail in the LFS book. In any case, LFS is now at version 6.8 for the latest stable version, which is very improved from 6.4. Please download and try that, from scratch.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •