Find the answer to your Linux question:
Results 1 to 8 of 8
I've had a Dell Optiplex SX270 that has been giving me problems since I got it. It works fine with Windows XP and with older Linux distributions, but once I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Chao06's Avatar
    Join Date
    Aug 2008
    Location
    College Station, Texas, United States
    Posts
    40

    Graphics Problem on Dell Optiplex SX270


    I've had a Dell Optiplex SX270 that has been giving me problems since I got it. It works fine with Windows XP and with older Linux distributions, but once I upgrade, the monitor shuts off on boot.

    What I did and how things worked the most recent time was:
    • Installed Debian Lenny with no desktop environment. It worked fine after that
    • I upgraded the kernel to the Sqeeze kernel (2.6.32). It still worked after that.
    • I installed LXDE (plus all the X dependencies) and that's where it started messing up. I could still use single user mode, but in trying to boot into the gui, it shut off the monitor.
    • I upgraded xserver-xorg (plus its dependencies) to Squeeze, and now I can't even get to single user mode. It shuts off the monitor halfway through boot.


    I went through system and xorg logs, but as far as I can tell, they couldn't tell there was anything wrong.

    I'm just about out of ideas, could anyone help?

    Thanks,
    David

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    It works fine with Windows XP and with older Linux distributions, but once I upgrade, the monitor shuts off on boot.
    'Shuts off' as in powered off (like someone unplugged it), or as in a powered on monitor with a black screen (no text, no graphics)?

    Does the monitor work when booting a Squeeze/LXDE liveCD? Have you tried any other distro's recent liveCD?

    Which GPU (brand/model)?

    Which video driver is installed, open source or proprietary?

    Is Debian's "firmware-linux" package installed?

  3. #3
    Linux Newbie arespi's Avatar
    Join Date
    May 2011
    Location
    Monterrey , Mexico
    Posts
    132
    It may not help a lot, but i have installed Mandriva Linux (Mandriva One 2010) on a Optiplex 270SFF without problems.

    Good luck

  4. #4
    rrl
    rrl is offline
    Just Joined!
    Join Date
    May 2011
    Location
    NJ
    Posts
    56
    sounds like a graphics mode issue? What kind of monitor? Connection, and video ?

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Location
    localhost
    Posts
    30
    Sounds a lot like a KMS issue to me, try booting with nomodeset on the kernel command line.

    In GRUB, you highlight the kernel you usually boot but you press the edit key (printed at bottom of the screen), append nomodeset to the end of the boot line (contains things like ro and quiet), then press the boot key (also printed at bottom of the screen) and see if that helps.

    For more info, see the Debian WiKi on KMS.

  6. #6
    whu
    whu is offline
    Just Joined!
    Join Date
    Jul 2011
    Posts
    1
    I have the same issue using Ubuntu 11.04 on a Dell Easynote LJ65.
    I tried with USB-stick boot and WUBI.
    Description :
    - During startup : text mode - everything fine
    - once entering graphic mode : light shuts off
    - dual screen = switching to an external monitor : same issue
    - when lighting the screen with an external lightsource I can see the icons and the mouse movements, but of course this is no solution
    - when I start the pre-installed VISTA everything works fine ...

    I tried the same on my Fujitsu Esprimo mobile with the same chipset : everything works as expected.

    Chipset : mobile Intel 4 express

    Seems to be a Dell issue to me.

    Anyone ???

    regards,

    Walter.

  7. #7
    Just Joined!
    Join Date
    Sep 2011
    Posts
    1

    same thing, tried over ten distros

    Tried newest distros

    only one works which is pclinux os

    no other works slax, mandriva, ubuntu, xubuntu, and many other doesnt just black screen

    seems like every is booting up cause when i push power button its turning itself off and i can see that is killing processes

    beside that black screen

    while booting pc linux os monitor shuts down for 10 seconds and after its ok

    optiplex sx 270

    i tried everything, nomodeset and etc.

    checked other forums and theres no solution so far, too bad cause sx is very compact pc for a nice server

  8. #8
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    928
    You might try legacyos, or rolling back to a kernal that works with your hardware.
    Registered Linux user #526930

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •