Find the answer to your Linux question:
Results 1 to 8 of 8
Hey guys, I have two computers. I put windows 7 on both of them and wanted to have linux on both as well dual booted. I put Ubuntu one one ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    4

    issues with dual boot


    Hey guys,

    I have two computers. I put windows 7 on both of them and wanted to have linux on both as well dual booted. I put Ubuntu one one and MoonOS on the other. We partitioned the drives and isntalled the CD's with the Linux on the respective systems. It gave us a few options to select from. On Ubuntu we choose to run beside windows, but it said it would ask you what you wanted to run. On moon a similiar option was selected i dont recall exactly what it said though. Anyway, I can only run ubuntu on the one computer and cant find a way to run windos 7 and just the opposite on the other computer. I can't find MoonOS. During boot up it goes straight to that OS. Any help on what I can do to help with this?

    I am severely unhappy with windows as it seems they don't last long before they slow down or whatever else. I have windows 7 on them for the wife and kids mainly and what little gaming I do and I want to try the 2 different linux's and see which one I like and learn it before I swithc thwe computer over entirely or maybe just stop using windows.

    Thanks for any help
    Phil

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    To start, it would be useful for you to post partition information for both computers. Since you can boot Ubuntu, do that by clicking the Applications tab at the upper left of the Desktop and look for Terminal. Open a terminal and type: sudo fdisk -l(lower case Letter L in the command) and post this partition information here. It would also be useful if you could post the contents of the /boot/grub/grub.cfg file to see if there is an entry for windows 7.

    You will need to do the same for the second computer which only boots windows. Use the Ubuntu CD and post the same information for it. I'm not familiar with MoonOS so I don't know which Grub bootloader it uses. You may need to find the /boot/grub/menu.lst file instead.

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    4
    Quote Originally Posted by yancek View Post
    To start, it would be useful for you to post partition information for both computers. Since you can boot Ubuntu, do that by clicking the Applications tab at the upper left of the Desktop and look for Terminal. Open a terminal and type: sudo fdisk -l(lower case Letter L in the command) and post this partition information here. It would also be useful if you could post the contents of the /boot/grub/grub.cfg file to see if there is an entry for windows 7.

    You will need to do the same for the second computer which only boots windows. Use the Ubuntu CD and post the same information for it. I'm not familiar with MoonOS so I don't know which Grub bootloader it uses. You may need to find the /boot/grub/menu.lst file instead.
    The fdsik -l info:

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x14cb14cb

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 13 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 13 12749 102297600 7 HPFS/NTFS
    /dev/sda3 12749 60802 385983489 5 Extended
    /dev/sda5 12749 60688 385068032 83 Linux
    /dev/sda6 60688 60802 914432 82 Linux swap / Solaris

    The /boot/grub/grub.cfg told me permission denied. I put that into the terminal also. I assume that is where to find what you asked for?

    I ahve yet to make it to the Moon Os...

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Your output shows sda1 as the active partition so that is your boot partitions. Your system files are on sda2 for windows. In order to access the grub.cfg file, you need to be root user. You can gain root user permissions to read the grub.cfg by doing in a terminal:

    sudo cat /boot/grub/grub.cfg
    That should output should show an entry for windows "similar" to the one below:

    menuentry "Windows 7 (loader) (on /dev/sda1)" {
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set a0a03a5ca03a395c
    chainloader +1
    If you have an entry for windows, post it so someone can view it to see what the problem is. If you don't have an entry, in the Ubuntu terminal run the command: sudo os-prober, after that completes run: sudo update-grub. These command should find your windows boot files and put an entry in the grub.cfg file.

  5. #5
    Just Joined!
    Join Date
    May 2011
    Posts
    4
    This was from the sudo cat /boot/grub/brub.cfg I put the windows part in bold below I also noticed it said os prober right above the windows entry


    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #

    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
    set have_grubenv=true
    load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
    set saved_entry="${prev_saved_entry}"
    save_env saved_entry
    set prev_saved_entry=
    save_env prev_saved_entry
    set boot_once=true
    fi

    function savedefault {
    if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
    fi
    }

    function recordfail {
    set recordfail=1
    if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
    }

    function load_video {
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
    }

    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos5)'
    search --no-floppy --fs-uuid --set=root cafa7650-71ee-4b57-bea2-19c75fbd9210
    if loadfont /usr/share/grub/unicode.pf2 ; then
    set gfxmode=auto
    load_video
    insmod gfxterm
    fi
    terminal_output gfxterm
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos5)'
    search --no-floppy --fs-uuid --set=root cafa7650-71ee-4b57-bea2-19c75fbd9210
    set locale_dir=($root)/boot/grub/locale
    set lang=en_US
    insmod gettext
    if [ "${recordfail}" = 1 ]; then
    set timeout=-1
    else
    set timeout=10
    fi
    ### END /etc/grub.d/00_header ###

    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    if background_color 44,0,30; then
    clear
    fi
    ### END /etc/grub.d/05_debian_theme ###

    ### BEGIN /etc/grub.d/10_linux ###
    if [ ${recordfail} != 1 ]; then
    if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
    if [ ${match} = 0 ]; then
    set linux_gfx_mode=keep
    else
    set linux_gfx_mode=text
    fi
    else
    set linux_gfx_mode=text
    fi
    else
    set linux_gfx_mode=keep
    fi
    else
    set linux_gfx_mode=text
    fi
    export linux_gfx_mode
    if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
    menuentry 'Ubuntu, with Linux 2.6.38-8-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos5)'
    search --no-floppy --fs-uuid --set=root cafa7650-71ee-4b57-bea2-19c75fbd9210
    linux /boot/vmlinuz-2.6.38-8-generic root=UUID=cafa7650-71ee-4b57-bea2-19c75fbd9210 ro quiet splash vt.handoff=7
    initrd /boot/initrd.img-2.6.38-8-generic
    }
    menuentry 'Ubuntu, with Linux 2.6.38-8-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos5)'
    search --no-floppy --fs-uuid --set=root cafa7650-71ee-4b57-bea2-19c75fbd9210
    echo 'Loading Linux 2.6.38-8-generic ...'
    linux /boot/vmlinuz-2.6.38-8-generic root=UUID=cafa7650-71ee-4b57-bea2-19c75fbd9210 ro single
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-2.6.38-8-generic
    }
    ### END /etc/grub.d/10_linux ###

    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###

    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos5)'
    search --no-floppy --fs-uuid --set=root cafa7650-71ee-4b57-bea2-19c75fbd9210
    linux16 /boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos5)'
    search --no-floppy --fs-uuid --set=root cafa7650-71ee-4b57-bea2-19c75fbd9210
    linux16 /boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###

    ### BEGIN /etc/grub.d/30_os-prober ###
    menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
    insmod part_msdos
    insmod ntfs
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root 18E856D7E856B32C
    chainloader +1
    }

    ### END /etc/grub.d/30_os-prober ###

    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries. Simply type the
    # menu entries you want to add after this comment. Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###

    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f $prefix/custom.cfg ]; then
    source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Which Ubuntu version do you have, 11.04 the most recent?
    I have an Ubuntu 10.10 installation as well as windows 7. My grub.cfg entry for windows 7 is below:

    menuentry "Windows 7 (loader) (on /dev/sda1)" {
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set a0a03a5ca03a395c
    chainloader +1
    }
    The only differences I see is in the set root line where mine has (hd0...) and yours has /dev/sda for that entry. Since your Ubuntu set root has the same /dev/sda entry and boots, that probably isn't the problem. I haven't used Ubuntu 11.04 if that is what you are using so that may be a change.

    The other differenc is the "search" line where yours has set=root and then the UUID number. Don't know why it would have "root" there or if that is part of the problem.

    You indicated in your first post that you installed windows 7, is that correct? If so, did you create a separate boot partition or do you remember if that was done during the installation.

    Check the UUID for sda1 and sda2. Open the terminal and type: blkid and compare the output for sda1 and sda2 to the number on the search line for windows.

    I hesitate to make any more detailed recommendations as I've not used 11.04, if that's what you have?

  7. #7
    Just Joined!
    Join Date
    May 2011
    Posts
    4
    Sorry, I've been away and I'll be leaving again tomorrow. I appreciate the help though!!

    How do I tell which ubuntu I have? I just downloaded it with in 2 weeks ago.... I remember we made the partition before we installed either windows or unbuntu

    when I type the blkid, nothing happens, at all. This is what it showed me:

    phil@phil-RX895AA-ABA-SR5023WM:~$ blkid
    phil@phil-RX895AA-ABA-SR5023WM:~$ BLkid
    BLkid: command not found
    phil@phil-RX895AA-ABA-SR5023WM:~$ blkid
    phil@phil-RX895AA-ABA-SR5023WM:~$ bl kid
    The program 'bl' is currently not installed. You can install it by typing:
    sudo apt-get install gpe-conf
    phil@phil-RX895AA-ABA-SR5023WM:~$

  8. #8
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    If you just downloaded it, probably it is 11.04. You can look in /etc/issue or /etc/release file.
    To get the id in Ubuntu try: sudo blkid or if that fails, ls -l /dev/disk/by-uuid/
    You could try changing your windows 7 menuentry set root line from this:
    set root='(/dev/sda,msdos1)'
    to this: set root='/dev/sda, msdos2)' as your boot files may be on sda2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •