Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I tried installing Ubuntu 11.04 on an old laptop. The installation crashed every time if I selected 'install third party software' and 'download updates' during the install. I tried installing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    12

    Unable to find boot file after Ubuntu install


    I tried installing Ubuntu 11.04 on an old laptop. The installation crashed every time if I selected 'install third party software' and 'download updates' during the install. I tried installing without downloading any of the extra software and it completed the installation but when I try to boot into it it tells me it cant find a boot file.

    After that i tried installing windows xp and the installation failed, it told me that it stopped to avoid damaging my system and that i should run the check disk operation.

    Right now I am using the live cd on the same laptop. I'm a newb when it comes to this so I have know idea what to do.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,116
    What are your computer specs?
    CPU
    Ram
    Computer make and model number
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Jul 2011
    Posts
    12
    It doesn't really say much on the laptop, I know it's a gateway. Its got a dual core somewhere between 2 and 3GHz, 4 gigs of ddr2 ram. I think there's a way to get it to tell me all of the hardware but i don't know how.

    Since I made the first post i ran apt-get grub (something like that) so now when I boot up the laptop it gives me a menu with Ubuntu, the Ubuntu recovery, and two memory test things. Right now its running a memory test, not sure if that will change anything but figured i might as well try.

    Apparently Ubuntu comes with a program that scans the disk and isolates bad blocks of it. Would this fix my problem?

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The installation crashed every time if I selected 'install third party software' and 'download updates' during the instal
    That might be because your internet connection wasn't setup. Did you test it from the install CD?

    You have an option just before the actual installation begins to select where to install the bootloader. It should have defaulted to the mbr of the primary drive. Apparently that did not happen. Did you have only one drive during the installation?

    What is the status now? Can you boot Ubuntu? Did you install xp? Do you have any other operating system on your laptop?

  5. #5
    Just Joined!
    Join Date
    Jul 2011
    Posts
    12
    Quote Originally Posted by yancek View Post
    That might be because your internet connection wasn't setup. Did you test it from the install CD?
    Yes the internet connection works when i run Ubuntu from the live cd.

    Quote Originally Posted by yancek View Post
    You have an option just before the actual installation begins to select where to install the bootloader. It should have defaulted to the mbr of the primary drive. Apparently that did not happen. Did you have only one drive during the installation?
    There's only one drive on this laptop, it's 320Gb.

    Quote Originally Posted by yancek View Post
    What is the status now? Can you boot Ubuntu? Did you install xp? Do you have any other operating system on your laptop?
    The laptop originally had vista on it, after having it for a while i dual booted it with ubuntu (9.04 i think). One day it crashed, I tried fixing it but it wouldn't even boot from a cd so i gave up.

    Yesterday I put in my 11.04 cd just for the heck of it and it was actually able to boot into a live session. As I said, i tried installing a few times and it didn't finish until i tried without the extra downloads. But, even after that it still wouldn't boot from the hard drive. I also tried installng windows and that just crashed right away. After I ran apt-get grub from a live session I was able to get a grub menu, but if I try to boot into Ubuntu from there it still wont work.

    From the grub menu I did the memory check and it came back fine, so I guess my ram is ok. I also ran the Ubuntu recovery, not really sure what that does but as it was running there were a lot of error messages, at the end of it I told it to try and fix the errors, it did some stuff and restarted. Ubuntu still wont work. Is it possible that it successfully isolated the bad blocks and I can reinstall?

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Have you tried other CDs to see if your CD drive works? I guess they would have to be Live CDs as you don't have any operating system installed.

    After I ran apt-get grub from a live session I was able to get a grub menu
    That was only for the Live session and would not be retained upon reboot.

    Try booting your Ubuntu Live CD so we can see what is on the computer, if anything. Open a terminal and run the command: sudo fdisk -l (lower case Letter L in the command)
    Post info here.

    You didn't answer my question about the bootloader. Do you remember where you selected to install Grub? Accepted default? If you see any Linux filesystem partitions in the output from fdisk, you should be able to mount the partition and check to see what files you have. If you don't know how to do that, post back.

  7. #7
    Just Joined!
    Join Date
    Jul 2011
    Posts
    12
    Quote Originally Posted by yancek View Post
    Try booting your Ubuntu Live CD so we can see what is on the computer, if anything. Open a terminal and run the command: sudo fdisk -l (lower case Letter L in the command)
    Post info here.
    The computer works perfectly with the live cd, so I'm thinking all the hardware in it is working fine except for the hard drive. Here's that info you requested:

    sudo fdisk -l

    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x000b0ed0

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 38401 308448256 83 Linux
    /dev/sda2 38401 38914 4120577 5 Extended
    /dev/sda5 38401 38914 4120576 82 Linux swap / Solaris

    I forgot about your bootloader question, as far as I remember I just used the defaults. I don't know how to check whats in each partition.

    edit: wont be able to post again for another 3 or 4 hours.
    Last edited by wawnahbEE; 07-06-2011 at 09:18 PM.

  8. #8
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    You have a Linux filesystem on sda1 which should be your Ubuntu installation. You also have a swap partition on sda5. To determine whether you have the necessary files, boot your Ubuntu Live CD. Open a terminal and create a mount point for your hard drive filesystem:

    sudo mkdir /mnt/sda1

    Then mount that partition:

    sudo mount -t ext4 /dev/sda1 /mnt/sda1

    Then check to see what is in the /boot/grub directory.

    ls /mnt/sda1/boot/grub/

    You should see a grub.cfg file there. If it exists, post the output. If not, let us know.

    It would probably be useful to post the output of the bootinfo script which you can access at this site which also has an explanation on how to use it:

    SourceForge.net: Boot Info Script - Project Web Hosting - Open Source Software

    This script should tell if you have Grub in the master boot record.

  9. #9
    Just Joined!
    Join Date
    Jul 2011
    Posts
    12
    I did what you said and it said the file did not exist. Here's the whole thing:

    ubuntu@ubuntu:~$ sudo mkdir /mnt/sda1
    ubuntu@ubuntu:~$ sudo mount -t ext4 /dev/sda1/mnt/sda1
    Usage: mount -V : print version
    mount -h : print this help
    mount : list mounted filesystems
    mount -l : idem, including volume labels
    So far the informational part. Next the mounting.
    The command is `mount [-t fstype] something somewhere'.
    Details found in /etc/fstab may be omitted.
    mount -a [-t|-O] ... : mount all stuff from /etc/fstab
    mount device : mount device at the known place
    mount directory : mount known device here
    mount -t type dev dir : ordinary mount command
    Note that one does not really mount a device, one mounts
    a filesystem (of the given type) found on the device.
    One can also mount an already visible directory tree elsewhere:
    mount --bind olddir newdir
    or move a subtree:
    mount --move olddir newdir
    One can change the type of mount containing the directory dir:
    mount --make-shared dir
    mount --make-slave dir
    mount --make-private dir
    mount --make-unbindable dir
    One can change the type of all the mounts in a mount subtree
    containing the directory dir:
    mount --make-rshared dir
    mount --make-rslave dir
    mount --make-rprivate dir
    mount --make-runbindable dir
    A device can be given by name, say /dev/hda1 or /dev/cdrom,
    or by label, using -L label or by uuid, using -U uuid .
    Other options: [-nfFrsvw] [-o options] [-p passwdfd].
    For many more details, say man 8 mount .
    ubuntu@ubuntu:~$ ls /mnt/sda1/boot/grub/
    ls: cannot access /mnt/sda1/boot/grub/: No such file or directory
    ubuntu@ubuntu:~$

    I also did that boot info script thing, heres the entire results.txt:

    Boot Info Script 0.60 from 17 May 2011


    ============================= Boot Info Summary: ===============================

    => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of
    the same hard drive for core.img. core.img is at this location and looks
    for (,msdos1)/boot/grub on this drive.

    sda1: __________________________________________________ ________________________

    File system: ext4
    Boot sector type: -
    Boot sector info:
    Operating System: Ubuntu 11.04
    Boot files: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

    sda2: __________________________________________________ ________________________

    File system: Extended Partition
    Boot sector type: -
    Boot sector info:

    sda5: __________________________________________________ ________________________

    File system: swap
    Boot sector type: -
    Boot sector info:

    ============================ Drive/Partition Info: =============================

    Drive: sda __________________________________________________ ___________________

    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes

    Partition Boot Start Sector End Sector # of Sectors Id System

    /dev/sda1 * 2,048 616,898,559 616,896,512 83 Linux
    /dev/sda2 616,900,606 625,141,759 8,241,154 5 Extended
    /dev/sda5 616,900,608 625,141,759 8,241,152 82 Linux swap / Solaris


    "blkid" output: __________________________________________________ ______________

    Device UUID TYPE LABEL

    /dev/loop0 squashfs
    /dev/sda1 df40df35-7305-4c43-823b-0842b39d1bb6 ext4
    /dev/sda5 be92c75a-35cc-42e0-aa04-6d3b05ea2376 swap

    ================================ Mount points: =================================

    Device Mount_Point Type Options

    /dev/loop0 /rofs squashfs (ro,noatime)
    /dev/sr0 /cdrom iso9660 (ro,noatime)


    =========================== sda1/boot/grub/grub.cfg: ===========================

    --------------------------------------------------------------------------------
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #

    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
    set have_grubenv=true
    load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
    set saved_entry="${prev_saved_entry}"
    save_env saved_entry
    set prev_saved_entry=
    save_env prev_saved_entry
    set boot_once=true
    fi

    function savedefault {
    if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
    fi
    }

    function recordfail {
    set recordfail=1
    if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
    }

    function load_video {
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
    }

    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root df40df35-7305-4c43-823b-0842b39d1bb6
    if loadfont /usr/share/grub/unicode.pf2 ; then
    set gfxmode=auto
    load_video
    insmod gfxterm
    fi
    terminal_output gfxterm
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root df40df35-7305-4c43-823b-0842b39d1bb6
    set locale_dir=($root)/boot/grub/locale
    set lang=en_CA
    insmod gettext
    if [ "${recordfail}" = 1 ]; then
    set timeout=-1
    else
    set timeout=10
    fi
    ### END /etc/grub.d/00_header ###

    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    if background_color 44,0,30; then
    clear
    fi
    ### END /etc/grub.d/05_debian_theme ###

    ### BEGIN /etc/grub.d/10_linux ###
    if [ ${recordfail} != 1 ]; then
    if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
    if [ ${match} = 0 ]; then
    set linux_gfx_mode=keep
    else
    set linux_gfx_mode=text
    fi
    else
    set linux_gfx_mode=text
    fi
    else
    set linux_gfx_mode=keep
    fi
    else
    set linux_gfx_mode=text
    fi
    export linux_gfx_mode
    if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
    menuentry 'Ubuntu, with Linux 2.6.38-8-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root df40df35-7305-4c43-823b-0842b39d1bb6
    linux /boot/vmlinuz-2.6.38-8-generic-pae root=UUID=df40df35-7305-4c43-823b-0842b39d1bb6 ro quiet splash vt.handoff=7
    initrd /boot/initrd.img-2.6.38-8-generic-pae
    }
    menuentry 'Ubuntu, with Linux 2.6.38-8-generic-pae (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root df40df35-7305-4c43-823b-0842b39d1bb6
    echo 'Loading Linux 2.6.38-8-generic-pae ...'
    linux /boot/vmlinuz-2.6.38-8-generic-pae root=UUID=df40df35-7305-4c43-823b-0842b39d1bb6 ro single
    echo 'Loading initial ramdisk ...'
    initrd /boot/initrd.img-2.6.38-8-generic-pae
    }
    ### END /etc/grub.d/10_linux ###

    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###

    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root df40df35-7305-4c43-823b-0842b39d1bb6
    linux16 /boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
    insmod part_msdos
    insmod ext2
    set root='(/dev/sda,msdos1)'
    search --no-floppy --fs-uuid --set=root df40df35-7305-4c43-823b-0842b39d1bb6
    linux16 /boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###

    ### BEGIN /etc/grub.d/30_os-prober ###
    if [ "x${timeout}" != "x-1" ]; then
    if keystatus; then
    if keystatus --shift; then
    set timeout=-1
    else
    set timeout=0
    fi
    else
    if sleep --interruptible 3 ; then
    set timeout=0
    fi
    fi
    fi
    ### END /etc/grub.d/30_os-prober ###

    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries. Simply type the
    # menu entries you want to add after this comment. Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###

    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f $prefix/custom.cfg ]; then
    source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###
    --------------------------------------------------------------------------------

    =============================== sda1/etc/fstab: ================================

    --------------------------------------------------------------------------------
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda1 during installation
    UUID=df40df35-7305-4c43-823b-0842b39d1bb6 / ext4 errors=remount-ro 0 1
    # swap was on /dev/sda5 during installation
    UUID=be92c75a-35cc-42e0-aa04-6d3b05ea2376 none swap sw 0 0
    --------------------------------------------------------------------------------

    =================== sda1: Location of files loaded by Grub: ====================

    GiB - GB File Fragment(s)

    276.135009766 = 296.497709056 boot/grub/core.img 1
    56.231040955 = 60.377620480 boot/grub/grub.cfg 1
    0.884002686 = 0.949190656 boot/initrd.img-2.6.38-8-generic-pae 2
    0.610778809 = 0.655818752 boot/vmlinuz-2.6.38-8-generic-pae 2
    0.884002686 = 0.949190656 initrd.img 2
    0.610778809 = 0.655818752 vmlinuz 2

    =============================== StdErr Messages: ===============================

    unlzma: Decoder error

    Not sure what any of this means or what to do next.

  10. #10
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    sudo mount -t ext4 /dev/sda1/mnt/sda1
    FYI,the above command didn't generate any output for you because you entered it incorrectly. There must be a space between the first sda1 and /mnt.

    I don't see any problems viewing that information. You have Grub in the mbr pointing to its files on sda1 and they exist. The grub.cfg entries look correct as they are pointing to the correct partition with Grub files and have the correct UUID. Don't know what else to suggest.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •