Find the answer to your Linux question:
Results 1 to 3 of 3
Hi guys, having problems booting using syslinux on a virtual machine, i have the kernel on a virtual hard drive and the syslinux boot loader. The kernel happens to load ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    12

    Syslinux on a virtual machine - need help


    Hi guys, having problems booting using syslinux on a virtual machine, i have the kernel on a virtual hard drive and the syslinux boot loader. The kernel happens to load but for some reason I cannot set the virtual hdd as root. Hoping someone can help me with this problem

  2. #2
    Just Joined!
    Join Date
    Jan 2011
    Location
    Fairfax, Virginia, USA
    Posts
    94
    Hi Pizarro,
    Usually (but not always) a cpio'd gzip'd filesystem called an initrd or initramfs is loaded to help the kernel get ready to load the main filesystem. Are you using an initrd and do you suspect its being loaded correctly?

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    12
    Hi there BrianMeck,

    Thanks for the reply, I tried to use microcore's kernel and initramfs file but it still cannot load the hard drive as root. I also tried to use my Installed ubuntu's kernl and still cannot load the hard drive as root.

    Anyway the last message I got was the system implied that it cannot load the file system and mentioned ext2 ext3 etc. I was suspecting the fat32 file system that I set-up the disk with is the culprit. Problem is, I really need to make it run on fat32. Do I need to recompile a kernel with fat32 support?

    Also, I am not realy knowledgeable in making these initrd's or initramfs's and their significance, maybe you can point me to a good article about that topic. Thanks for your time!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •