Find the answer to your Linux question:
Results 1 to 7 of 7
Good Day! I am having troubles on making a partition boot with Linux using syslinux as my bootloader. I always get this message: Photo0025.jpg I have already applied rdev on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    12

    "Kernel Panic: No Init found" on syslinux


    Good Day! I am having troubles on making a partition boot with Linux using syslinux as my bootloader. I always get this message:
    Photo0025.jpg

    I have already applied rdev on the kernel to specify /dev/hdb1 as root and even set bit14 to zero but to no avail.

    Hoping someone could help me with this situation.

  2. #2
    Just Joined!
    Join Date
    May 2011
    Posts
    12
    To supplement my question, could it be possible that the culprit is my boot loader? Thanks in advance..

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    More than likely you are pointing the bootloader at the wrong partition or something. Did you compile this kernel yourself?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Are you using syslinux or extlinux? Just curious, why are you not using grub, or even lilo?

  6. #5
    Just Joined!
    Join Date
    May 2011
    Posts
    12
    @MikeTbob: Yes I did compile this kernel myself, I am using a FAT32 partition and also enabled FAT32 support at kernel configuration. I also applied necessary rdev parameters on the kernel that I compiled..

    @atryu: Yes I am using syslinux. I prefer to use syslinux since the procedure to copy the boot code can be done with a single command with parameters. I need to append that command in a shell script since I am trying to automate transfer of boot code and kernel to a partition, something like an installer. Haven't tried LILO tho..

  7. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Well make sure that you compiled support for your Linux filesystem, EXT3 or 4 into the kernel and not as modules.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #7
    Just Joined!
    Join Date
    May 2011
    Posts
    12
    Yes sir the kernel has built-in support for the required file systems including FAT and NTFS. I also used rdev on the kernel and changed the root drive to /dev/sdb1 but I still get that message. I even tried modifying the fstab by including an entry for /dev/sdb1
    Last edited by pizarro84; 08-02-2011 at 10:43 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •