Find the answer to your Linux question:
Results 1 to 8 of 8
I have been spending the past week trying to install nvidia drivers on my computer. Amd xp1700+ Soltek motherboard Triplex Ti4200 The computer works fine after a clean install. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9

    RH9 nvidia installation prints garbage on logo screen.


    I have been spending the past week trying to install nvidia drivers on my computer.

    Amd xp1700+
    Soltek motherboard
    Triplex Ti4200

    The computer works fine after a clean install. The 2d part of my card is all good. It does 3d in windows really well too.

    ____

    I do everything absolutely by the book. I have tried everything from bios changes to recompiling my kernal.

    My XF86 config is perfect. When I startx It prints garbage where the nvidia logo should be. Then it feezes and I have to switch it off.

    The garbage is like dollar signs and other strange characters.

    There are no conflicts in the XF86 log either.

    I'm just wondering if anybdy has seen anything like this? Can anybody help me?

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    are you overclocking?
    have you tried doing all of this in text mode?
    have you tried setting your res down a bit to say 16bit?
    are you sure your sync and refresh rates are correct?

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Especially, are you sure that the modules work properly? How did you install them?

  4. #4
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9
    I got a little further to discovering what is happening here last night.

    The problem is something to do with ACPI?

    http://www.mcdownloads.com/do_q.php?q_id=5

    I have tried turning ACPI off in Bios and Grub... but nothing seems to resolve the problem.

    I think I'm going to have to recompile the kernal to exclude ACPI support.
    Then build the nvidia drivers from my new kernal.

    I tried to do this last night but got a whole bunch of errors.

    Can anybody give me easy step by step instructions for compiling the kernal with RH9?

    Also - on a side note: What is the difference between a zImage and a bzImage? and how do I go about creating each.

    Last night I tried the bzImage by typing make bzImage.

    Sorry for being so fague. I just don't have the words to explain what is going on, or what I've done. I'm usually working on this at 10pm-2am at night.

  5. #5
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9
    I have tried to compile the kernel a few times now. I would say I'm getting good at it. However, I've been disabling acpi within the menuconfig. For some reason this has been disabling USB support?? I have checked all the usb options and they should be working fine. I have a usb keyboard, so this is a real problem.

    Can anyone out there help me with getting my graphics card working??



    My system is:

    Soltek SL-75DRV5 (via kt333)
    Triplex Ti4200 Geforce 4 64mb

  6. #6
    Just Joined!
    Join Date
    Jun 2003
    Location
    Helsinki, Finland
    Posts
    78
    Ok hate to ask the obvious question but you've inserted the module into the kernel with modprobe or insmod?

    Does lsmod show a "nvidia" module?

    Does your XF86Config include
    Quote Originally Posted by /etc/X11/XF86Config
    Driver "nvidia"

  7. #7
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9
    Yes insmod shows nvidia.
    And, yes, I have edited XF86config correctly.

  8. #8
    Just Joined!
    Join Date
    Jun 2003
    Posts
    9
    Okay. If anybody has a problem with their nvidia stuff that sounds like mine.

    Add the line:

    option"NvAgp" "0"

    under the Screen Section.

    I'm sorted.

    Thanks... me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •