Find the answer to your Linux question:
Results 1 to 3 of 3
I've been having trouble with several linux installs that have failed for the same reason. That being that it acts like grub doesn't exist, it just goes straight to windows. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2011
    Posts
    16

    Grub bootloader not working on any distro I use..


    I've been having trouble with several linux installs that have failed for the same reason. That being that it acts like grub doesn't exist, it just goes straight to windows. It did it on Ubuntu, Linux Mint and Debian.
    Right now I just want to install mint, too much going on in my life to spend hours configuring anything more complex then that.

  2. #2
    Just Joined!
    Join Date
    Oct 2011
    Posts
    1
    I have the same problem, do you have a z68 motherboard with Marvell 6 Gb/s controller? I cannot post a link Google marvell controller z68 grub, there is a page on the Ubuntu launchpad Bug #880143, I think this is my problem maybe the same for you?

    Update
    When I leave the USB pen drive I installed from the system will boot. For days I have tried to install from CD's, DVD's, and now USB, I still think something is wrong with GRUB but this works for now. Once in the real OS (it is not the installer, it has my account I create with password during install) I tried ran:
    sudo grub-install /dev/sda
    Installation finished. No error reported.
    but I still cannot boot without the USB.
    Last edited by ttocsNroc; 10-27-2011 at 04:59 AM.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,530
    If you had a USB device loaded on the system, then the boot loader was probably installed on that, per ttocsNroc's response. If so, then you need to reinstall one of the Linux systems with the USB device detached from the system. Ubuntu and Mint use the newer (not necessarily better) grub2 boot loader. I'm not sure about current versions of Debian, but since Ubuntu and Mint are based on it, that is probably the case.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •