Find the answer to your Linux question:
Results 1 to 3 of 3
Ok, so some background. I've used gnu/linux for a couple years now, since Ubuntu 9.10. Recently, i've come to love Fedora, however with non-oss, proprietary software. Anyway, that's not to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    2

    Linux Kernel Issues (Maybe, cannot install)


    Ok, so some background. I've used gnu/linux for a couple years now, since Ubuntu 9.10. Recently, i've come to love Fedora, however with non-oss, proprietary software. Anyway, that's not to be discussed here. I'm having some issues A) botting into installation environments, and B) installing from said environment. I've got three downloaded ISOs, one being Fedora 16 64-bit DVD, one being Linux Mint latest 64-bit DVD, and the other being the latest openSUSE DVD, 64-bit. Firstly, each of these three ISOs pass the hashing tests, being MD5 and SHA tests, usually SHA1.

    The first two, Fedora and Linux Mint, work fine in Virtualbox and on a laptop. They also will install just fine. However, with Fedora, I have issues with the nouveau driver, and especially replacing it (which is impossible). Anyway, these won't install, let alone boot, on my main computer (specs to follow). The third distro, openSUSE latest, will boot into the installer just fine, and stops when installing when it tries to install the package

    desktop-kernel

    or something like that, i know it was something-kernel, but I'm pretty sure it was desktop-kernel. So this leads me to think that somehow, the kernel won't work on my computer any more. I'm guessing it's since it's kernel 3.x. The last versions of these distros all work fine, the only real change is the jump from kernel versions, from 2.6.x to 3.x. If you need more info, I can gladly add it.

    So my question is, does this sound like a kernel issue? I somehow doubt it, but it could be. If it is a kernel issue, what can I do? Should I go back to a 2.6.x release? And how and where, if this is the issue, could I report a bug if necessary? Thank you so much for any help you could give me. This has been frustrating me since the day Fedora 16 came out!

    My specs:

    Motherboard: Gigabyte GA-870A-UD3
    Memory: 12GB DDR3 1333 unbufferred (of course), not overclocked
    processor: AMD (again, of course) Phenom II X6 1055T (unfortunately, not overclocked atm)
    Video card: I can't remember the model number, but it's an nVidia GTS 450 /w 1GB memory, driving two displays, one DVI, one DVI -> VGA
    CD/DVD drive (SATA)
    500GB disk drive (I've tried using this with a SATA to USB 3.0 adapter, which is what I'll be using, but it didn't work so I also tried with regular SATA)
    *note, all SATA devices are connected through the native AMD 870 chipset SATA III controller

    If you need more stuff, I again can gladly put more in.

    Thanks again so much!!

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,557
    Re. Nouveau driver. You can remove it, or rebuild the kernel without it, but to simply remove it, since it is hard-wired into the kernel by default, you have to blacklist it as well before you install the proprietary nVidia driver. Go to /etc/modprobe.d and edit the file blacklist.conf, adding the line: blacklist nouveau

    Next, boot into runlevel 3 (edit /etc/inittab to do that), login as root, install the proprietary nVidia driver, change /etc/inittab back to runlevel 5, and reboot.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Dec 2011
    Posts
    2
    Thanks for the quick response. I'll try this. I never knew about the blacklisting, since when I did it in Fedora 15, it worked just fine, I didn't even need to boot into runlevel 3. Just worked. But thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •