Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Sorry if it's a lot of text, I tried to be to the point and descriptive to. The Problem: No matter how or what I do the built in partition ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    9

    Ubuntu 11.10, 10.04, and Linux Mint refuse to install


    Sorry if it's a lot of text, I tried to be to the point and descriptive to.

    The Problem: No matter how or what I do the built in partition manager that allows you to setup your partitions during installation does not work at all. It doesn't show any partitions and doesn't allow me to change anything. It shows the dba thing so I believe it is recognizing the drive. I even went so far as to try and install Linux as the only OS and it still won't budge. I can't seem to get past the root folder. It keeps saying need root folder or root folder not defined.

    How do I get a correctly working partition to install linux on. I have a 1.5TB hard drive. I want about 250gb dedicated for linux. I am currently using Windows 7 and just in case...

    Intel Core I3 3.785ghz (overclocked)
    4gb of ram
    1gb asus radeon 7660 (i think)
    Seagate Barricuda LP 1.5TB 5400 rpm hard drive

    I am taking the first couple classes towards a Computer Science associates. Next semester I will be taking a linux class so I want to familiarize myself. I have installed a successful boot of an old version of Ubuntu on a different pc with Vista. I am following all instructions and have searched relentlessly for two day and just can't get it to install.

    If necessary for better understanding of my problem I can and will record and post a video to youtube of how I am trying to install. Also I am self taught and don't have extensive background in the technical stuff.
    Last edited by jvangeystel; 02-02-2012 at 11:48 PM.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,120
    It keeps saying need root folder or root folder not defined.
    You need to label the partition you are going to install Linux into as

    Code:
    /
    /=root folder

    http://linuxtidbits.files.wordpress....rted-label.png

    and flag it as boot

    http://2.bp.blogspot.com/-AzkbrPYPw8...flags_boot.png

    Then proceed with install
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Feb 2012
    Posts
    9
    Ok I will attempt this as soon as I get home from school. I've done this before, (I think) but I will attempt it again. So I will run linux from the disc, use gparted to create a new partition and name it "/" without the quotes. What type of partition is it supposed to be? NTSC, Ext 1,2,3,4? What about the swap memory partition do I have to create a seperate partition for this. I remember that in my last install of Ubuntu I could take care of all of this during the installation. Any clue on why this isn't possible anymore? Sorry for all of the questions. I have already wrecked my Windows 7 installation once. I want to make sure I get this right this time. Thanks a lot for your help "rokytnji" and anyone else who comes along.

  4. #4
    Linux Newbie
    Join Date
    Dec 2006
    Posts
    153
    Use ext4 and I would recommend a swap partition of 2gb.

  5. #5
    Linux Newbie
    Join Date
    Dec 2006
    Posts
    153
    Or your other option would be to allocate the entire drive to windows and then tell the Ubuntu installer disc to simply install along side windows, (the installer will handle the resizing and partitioning).

  6. #6
    Just Joined!
    Join Date
    Feb 2012
    Posts
    9
    Update:
    Created these partitions using gparted:
    / 30GB Ext4 Primary Partition
    /boot 1GB Ext4 Primary Partition
    /Home 200GB Extended Partition (Ran out of room for primary partitions)
    Swap 4GB Ext4 Logical Partition
    Still says: No root file system is defined. Please correct this from the partitioning menu.
    Flag "/" Partition as Boot
    Same results
    Change /boot to extended
    Swap 1gb logical under /boot
    /Home changed to primary partition.
    Partition menu shows /dev/sda but shows no partitions
    Same results when trying to install
    Going to dedicate the whole drive to windows and retry. (redbook)

  7. #7
    Just Joined!
    Join Date
    Feb 2012
    Posts
    9
    Update:
    Current partitions
    Unallocated 279.04 GiB
    Ntfs system reserved 1.04 TiB (Windows 7)
    Unallocated 48.04 (No clue why these are seperated) Having trouble adding either of these to windows 7 partition.

    The option to use Ubuntu as sole OS or along side windows or other doesn't come up. Goes straight to the partition menu from
    the screen that shows you should be connected to internet and have 5gb free space (still not showing any partitions or allowing me to push any buttons).
    Still stumped, appreciate the suggestions.

    Attempted install still says no root

  8. #8
    Just Joined!
    Join Date
    Feb 2012
    Location
    The Netherlands
    Posts
    10
    I install Linux Mint a lot, and I never have to do things with / and root etc.

    What you could try is in Windows7 install EASEUS Partition Master 9.1.0 Home Edition (freeware). Try to get the partitions right (it's very strange that there's one unused before and after the win7 partition). And try Linux mint again

    Cheers,

    LibraOne

  9. #9
    Just Joined!
    Join Date
    Jan 2006
    Location
    Lancashire, England
    Posts
    32
    1. question? Have you destroyed the small 100MB partition at beginning of hard disc after MBR, which is vital to Windows 7 on windows "C" drive. This is normally hidden in Windows partitioner but should show up in a Linux partitioner?

  10. #10
    Just Joined!
    Join Date
    Oct 2010
    Posts
    5
    1st of all you need to make your Windows 7 partition smaller. You already have 3 primary partitions, [due to pre-install OS], 1 is your system backup 2nd is a hidden drive and a huge "C" drive. So you'll need to make your C drive smaller. Then create an extended partition with the rest. But 1st.... is this a 64bit computer??? I find that installing linux on a extended partition saves a lot of headaches.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •