Find the answer to your Linux question:
Results 1 to 4 of 4
Hi I'm stuck! I have an eeepc 901 (Windows version originally). Since then I have deleted WIndows and installed several different flavours of Linux over time, mostly failrly successfully until ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    sim
    sim is offline
    Just Joined!
    Join Date
    Oct 2006
    Posts
    17

    multi-boot problems on eeepc 901


    Hi

    I'm stuck! I have an eeepc 901 (Windows version originally). Since then I have deleted WIndows and installed several different flavours of Linux over time, mostly failrly successfully until now. I have Peppermint installed on the 8GB SSD drive and that works fine. I have tried to install Leenux on the 4GB drive and was expecting Grub to pick this up and let me boot into whichever one I wanted. Alas although Leenux appears to have installed Grub can't seem to find it. Peppermint still boots up fine and from Peppermint I can see that the 4GB drive has lots of files on it that look like the Leenux install (could I check this though).

    On the menu that Grub gives me I cannot see Leenux - instead it offers me peppermint or some generic Linux. If I select the generic linux it hangs during installation after setting up the Winbind demon or something. If I go into the command line entry for grub and ask it to ls it gives me five devices: (hd0), (hdo,msdos1) (hd1) and (hd1,msdos5) (hd1,msdos1). If I ask it to ls (hd0) it gives me "Not a known filesystem - Total size 7880544 sectors".

    Any suggestions for what might be going on and how I might fix it would be greatly appreciated.

    Thanks
    Sim

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Have you tried to update GRUB2 in Peppermint?
    Code:
    sudo update-grub
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,003
    Is this a dual ssd drive eeepc 901.

    If so. The escape key is needed at power on to access grub on 4 gig ssd drive if grub was installed to mbr on 4 gig ssd drive.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    sim
    sim is offline
    Just Joined!
    Join Date
    Oct 2006
    Posts
    17
    Hi both

    THanks for the suggestions.

    Jay - I did update-grub in Peppermint (this morning before coming to work). It seemed to work and successfully found leenux, but alas when I re-booted it didn't appear in the Grub menu. I think it must be starting up an old grub. My new plan therefore is to try grub-install from peppermint - both into sda and sdb and then see if I have a new grub loading at boot which can give me access to both peppermint and leenux. Once in Leenux I will do grub-install to sda (hopefully the 4GB drive that leenux is on). In that way I am hoping I may have peppermint-grub (if you see what I mean) on the MBR of the 8GB drive, and Leenux-grub on the 4GB drive and whichever drive I select as boot device should start up a well functioning grub?

    Rokytnji - yes that is the eeepc I have. When I hit Escape I can choose the 4GB drive and I get the same as the default behaviour described in my first post. When I chose the other device nothing happened I think. But I will have a better play this evening when I get back home and report on findings.

    Thanks
    Sim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •