Find the answer to your Linux question:
Results 1 to 8 of 8
Im Dual booting ubuntu with xp... i already have everything else setup, and previously had it dual booting on an extended partition. Nutshell-I have to remove the extended partition but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19

    Ubuntu 11.10 how to install without seperate swap partition?


    Im Dual booting ubuntu with xp... i already have everything else setup, and previously had it dual booting on an extended partition. Nutshell-I have to remove the extended partition but that only leaves me with 1 primary left for ubuntu. which i dont mind... But how do i Install ubuntu so it doesnt try to automatically create an extended swap partition? Not sure if it will i just no last time i didn't manually creat the mount points for the partitions it created its own swap part.

    1. what should i label the mount point for the primary partition i want to do this? ( / )? or (/root)?

    2. will ubuntu automatically try creating a extended swap? if so how do i stop it from doing so and modifying any of my other primary partitions? I found links for properly creating a swap file which is more then adequit for my needs, however the tutorial assumes ubuntus already installed instead of starting from scratch.

    3. setup info, Xp is on first primary, and other primarys also contain data, ubuntu will be installed on 4th primary(last).

    I know linux can easily install on extended partitions, i had it there befor but just fyi for my current needs i have to have no extended partition.
    Need any other info feel free to ask. Thx

  2. #2
    Linux Newbie
    Join Date
    Aug 2010
    Posts
    232
    you have to manually prepare the hard drive. " / " is root . So assign / to root then proceed with the installation.
    Root is the only partition you need. When you manually prepare hard drives Ubuntu will not create it's own partitions. You can label your partition "/" or "root" . I tend to use root to make it easier to read, but Ubuntu doesn't look at volume labels when mounting; it's for your reference.

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    14
    I wonder if this can be of any help: When I get the grub screen to chose which OS I want to load, I have the option to press 'e' to edit the commands before loading or 'c' for command prompt, so I selected the Windows XP option and pressed 'e'. Here's what came up:
    Code:
    setparams 'Microsoft Windows XP Professional (on /dev/sda3)'
    
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos3)'
    search --no-floppy --fs-uuid --set=root 022D2F8676290F21
    drivemap -s (hd0) ${root}
    chainloader +1
    Now, when I do to Disk Utility in Linux Mint, I can select the WinXP partition and it states this to be
    Code:
    Device: /dev/sda5
    yet, the grub code above says
    Code:
    setparams 'Microsoft Windows XP Professional (on /dev/sda3)'
    would it help if I changed the /dev/sda3 in the grub to /dev/sda5

    Another thing I see in the Disk Utility is an option of "Check Filesystem". Could I repair the WinXP bootup issue from this?

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    36
    The string 'Microsoft Windows XP Professional (on /dev/sda3)' is just a label. Changing it to /dev/sda5 will not do any help. If your windows is booting without a problem you should ignore this difference. Since grub2, things have changed and the above syntax is beyond my understanding. I hope someone with in depth knowledge of grub2 might help.

  5. #5
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    @ fkasmani - I dont think so, not yet anyway.. if that were the case i dont think it would give you any error at all and just fail completely without any message. in any linux OS/bootable app, Open 'Terminal' and type "fdisk -l" ...and then post back on witch /dev/sd? the xp partition reads as

    or to save the partition table info to file for backup but can also be viewed by txt editor "sfdisk -d /dev/sda > /dir/file.txt"

    I wouldnt use a linux utilty to check ntfs filesystem integrity. There are good ntfs tools out there for linux, but with my limited experince and nowledge so far there isnt as high a reliablility or compatability with all ntfs functions.

    I would use microsofts Recovery Console to check NTFS. Boot from XP cd and hit watever button it says to boot to recovery console and then select the apropriate drive/partition if it doesnt do so already (sorry i never had 2 use recovery console on dualboot yet) if doesnt default to correct partition maybeable to find drive letter with "diskpart" enter "list volume" ss64.com/nt/diskpart.html

    use "chkdsk [drive:] /p /r" from recovery console

    to check for any corrupt sectors of the harddrive itself i used MHDD which is bundled with sysresccd.org , real-world-systems.com/docs/MHDD_en_manual.html

    using MHDDs scan function only is completely safe, you can just scann it first then rescan fixing errors if you choose to do so.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,509
    You can create a swap file instead of a partition if, as one of the other posters noted, you manually configure the system partitions. You would create the root (/) file system, create the /boot directory on that, a /swap directory, and then use the mkswap and swapon commands to create/mount a swap file instead of a partition. See the man pages for mkswap and swapon for more information.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    Feb 2010
    Posts
    14
    I have done the chkdsk from the recovery console and it didn't help - all it did was mess up grub which made me have to reinstall grub2.
    As for the blkid, it shows 022D2F8676290F21 as the UUID for SDA3 while SDA5 is the WinXP partition. Would it help if I did one of the following:
    Either replace 022D2F8676290F21 with the sda5 UUID in the grub, or, format my ntfs data partition to (maybe) ext3 and then update grub with 'sudo update-grub' - this way grub would see only one ntfs partition and correctly assign it to WinXP (just a thought).

  8. #8
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    you probably specified the wrong partition in recovery console. unless sumthing changed xp cant be on sda5 because it can only boot from a primary partition. so till u fdisk it you can only assume sda3 is correct. Something was prolly just installed incorrectly. might be easyest to just reformat xp and use grub legacy as the chainloader, unless you know what your doing with grub2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •