Find the answer to your Linux question:
Results 1 to 10 of 10
Hello all, i'm setup a server and I have 4 hard disc drives, i one there's a Win partition and RedHat 8 partition. The othes hdd's are FAT32 partitions. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2002
    Location
    Catalonia
    Posts
    5

    I can't mount IDE hsrd disc, please help!!


    Hello all, i'm setup a server and I have 4 hard disc drives, i one there's a Win partition and RedHat 8 partition. The othes hdd's are FAT32 partitions. I don't have any RAID system or wherever strange thing

    when kernel starts booting shows this:

    VP_IDE: VIA vt8231 (rev 10) IDE UDMA100 controller on pci00:11.1
    ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hdaMA, hdbMA
    ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdcMA, hddMA
    hda: ST320011A, ATA DISK drive
    hdb: ST340810A, ATA DISK drive
    hdc: ST340810A, ATA DISK drive
    hdd: ST340810A, ATA DISK drive

    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(100)
    hdb: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63, UDMA(100)
    hdd: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=77545/16/63, UDMA(100)

    ide-floppy driver 0.99.newide
    Partition check:
    hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 hda8 >
    hdb: hdb1
    hdd: [PTBL] [4865/255/63] hdd1

    Floppy drive(s): fd0 is unknown type 15 (usb?), fd1 is unknown type 12 (usb?)
    floppy0: no floppy controllers found
    NET4: Frame Diverter 0.46
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    ide-floppy driver 0.99.newide
    md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    md: Autodetecting RAID arrays.
    md: autorun ...
    md: ... autorun DONE.

    and down...

    SCSI subsystem driver Revision: 1.00
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices

    ---------------------
    Kernel detect me an SCSI disc?? it's strange, I have 4 IDE's....only detects 3 as IDE.....

    Also in the grub boot:

    title Red Hat Linux (2.4.18-14)
    root (hd0,1)
    kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdc=ide-scsi
    initrd /initrd-2.4.18-14.img
    title DOS
    rootnoverify (hd0,0)
    chainloader +1

    --------

    HELP!! i'm vety annoying!!

    PC it's an VIA C3 Epia 800MHz.

    Sorry for my poor english.

    Thanks!!

  2. #2
    Just Joined!
    Join Date
    Dec 2002
    Location
    Boston
    Posts
    8
    I will take a stab at it but this is just what I THINK migth be the problem

    kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdc=ide-scsi

    The system is not seeing hdc becuase i think the above line it telling it is a scsi drive when it is a IDE. try this line instead

    kernel /vmlinuz-2.4.18-14 ro root=LABEL=/

    Again this is just my quess.

    Hartman

  3. #3
    Just Joined!
    Join Date
    Dec 2002
    Location
    Catalonia
    Posts
    5
    hello hartman I deleted this line but after reboot i'm still have the same problem.

    When I installed RedHat I installed with 2 hdd's in the ide1 port and a cd-rom drive in "hdc" (primary of IDE2 port). Maybe this is the problem, now I only have 4 hhd's and no cd-rom drives.

    I'm very confused....any suggestion?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2002
    Location
    Boston
    Posts
    8
    marcalj,

    I believe that each IDE channell can have only 2 devices each. So if you have IDEa and IDEb you can only have 4 total devices. Thus you can have only 4 drive and no CD-ROM or 3 drives and a CD-ROM

    Hartman

  6. #5
    Just Joined!
    Join Date
    Dec 2002
    Location
    Catalonia
    Posts
    5
    yeah....I agree

    but its confusing....why I can't mount "hdc" in fact? you can see kernel recognised all my 4 hdd's but in disc manager only I view 3...

    Jesus!!

  7. #6
    Just Joined!
    Join Date
    Dec 2002
    Location
    Boston
    Posts
    8
    I'm not sure either, sorry

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The CD-ROM was a CD writer, right?
    It is necessary to use it as a SCSI disk, since the IDE drivers have no support for CD writing, and there are only CD writing applications for SCSI, too. I don't know which is the reason for the other.
    Therefore, IDE CD writers are emulated as SCSI drives by the kernel if that kernel option is present, and installation scripts usually add it for CD writers. Actually, if your device is emulated as SCSI, it should be available via /dev/scd0. Try mounting it and see if it's there.
    Deleting that option should, however, have corrected the problem. Check if it is in your /etc/modules.conf, too. That might be the problem. It must not be specified in either place if you wish to use hdc as an IDE drive.

  9. #8
    Just Joined!
    Join Date
    Dec 2002
    Location
    Catalonia
    Posts
    5
    Hi Dolda2000, was no possible, it's a wrong device too....and in modules.conf there's no information about it....I will re-install entire OS but in a CDrom drive mode...I will have the same problem??

    I hope don't....

    See you and thanks to all !!

  10. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Hey, don't reinstall just yet!
    Check some things first.
    Could you give me the contents of your /proc/ide dir, /proc/scsi (if it exists), /proc/devices and /proc/modules?
    You might not have to reinstall.

  11. #10
    Just Joined!
    Join Date
    Dec 2002
    Location
    Catalonia
    Posts
    5


    doesn't matter, I reinstalled entire OS...now works fine....I only had the OS, nothing else, so, doesn't matter... xDD

    LINUX IS THE BEST OS I HAVE TRIED!!!!! LINUX r000000lz, jejeje, i'm very happy

    Thanks for all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •