Find the answer to your Linux question:
Results 1 to 5 of 5
Hey people I've had this problem for a while, and I've never been able to fix it. I have 2 SATA drives. 74GB Raptor, and a 250GB WD. 74GB has ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! finchwizard's Avatar
    Join Date
    Dec 2004
    Posts
    9

    GRUB - Stuck at Stage 2 loading.


    Hey people

    I've had this problem for a while, and I've never been able to fix it.
    I have 2 SATA drives.

    74GB Raptor, and a 250GB WD.

    74GB has Windows XP installed on it.

    The 250GB has 1 partition on it with Data etc, there is about 20GB free for me to install Linux etc on it.

    Well, I've tried installing Fedora Core 3 on the free space, Ubuntu Linux, and my favorite so far, SimplyMEPIS.
    The problem is, no matter where or how I try to get these Dual booting, it just will not happen.

    I've installed it to the MBR, no luck, tried installing to Root of drive and getting the computer to boot of that drive, no luck, I've even tried the dd if=/dev/blah of=/mnt/floppy/linux.bin thingo where you put that into your C:\ in Windows and edit boot.ini

    All of which have no luck, I'm assuming it's a problem with GRUB and the SATA controller or something, I'm not sure.

    Can anyone please help me, or tell me a fix for the problem.

    MEPIS picks up the drives like this, my Plextor burner is /dev/hda

    74GB Raptor is /dev/hde1

    200GB is /dev/hdg1 with my Linux drive as /dev/hdg2 and /dev/hdg3.

    So yeah, if anyone could help, would be good, otherwise what can I do?

    I'd really like to have Dual booting on this machine and have my reliance on Windows as little as possible.

    The only thing I was thinking before was if I bought a 20 or 40GB IDE drive, and install Linux on that and try and get GRUB to boot the SATA drives then.

    Thanks for any help you may give.

    Regards,
    ~Finchwizard~

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Are you installing it to the MBR on /dev/hda1?

  3. #3
    Just Joined! finchwizard's Avatar
    Join Date
    Dec 2004
    Posts
    9
    My DVD Burner is /dev/hda

    My 74GB Raptor is my main drive, and I installed the MBR to that drive.
    Thats what BIOS boots first, and that's when I get the GRUB loading Stage 2 or 1.5 or something.

    And it just sits there, it doesn't even get to the option of picking what OS to boot.

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Can you post your GRUB configuration file (probably not)? It's kind of a GRUB problem in that it's not going to the right place for the grub.conf file which has the menu and pointers to your OS's. But then, maybe GRUB can't handle your rig. Your thought about a smaller IDE drive for booting from is a good one. Maybe you could just use that drive for its MBR, or maybe you will need to put your /boot directory on it. That /boot directory could be shared by your various distros, with their individual kernel and initrd files, as long and the .conf file points to the right root (as in / ).
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1
    I had this same problem as well when trying to dual-boot SuSE and FC 3. After reinstalling grub a few times and messing around with the grub.conf file, I just about gave up, until I ran into this resolution. In your BIOS, try changing your hard drive setting from "Auto" to "LBA". This worked perfectly for me...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •