Find the answer to your Linux question:
Results 1 to 4 of 4
Since upgrading to a Palit GTX 560 Ti 2GB graphics card I have been unable to install any flavour of Linux based on the version 3 kernel. The moment it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2012
    Posts
    2

    Exclamation Linux installs freeze every time.


    Since upgrading to a Palit GTX 560 Ti 2GB graphics card I have been unable to install any flavour of Linux based on the version 3 kernel. The moment it tries to change into graphics mode it either sits there indefinitely or locks up the PC. It has even gone as far as corrupting the CMOS so I had to clear it to get the PC to boot on 2 occasions.


    The PC works fine as far as I can tell. It has Windows 7 64 and Windows 8 64 beta installed and running. I managed to get Ubuntu 12.04 64 installed by using the alternate text mode image, then from the command prompt installing the cuurent Nvidia graphics driver. Once installed it works fine also.

    I would really like to try Linux Mint but can not get it to boot at all.

    Anyone had similar issues here?

    Thanks.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    The problem is likely due to the fact that current kernels use the Nouveau driver for nVidia gear by default and there is probably a fault in how they work with this board. I did read that the latest Nouveau driver has been enhanced to handle these newer nVidia parts, but you'll have to boot into text mode first so you can install that, just like you did to install the proprietary driver on your Ubuntu distribution. Since Mint is based on Ubuntu/Debian, you should be able to find a text-mode installation image.

    Here is a link to a tutorial that will help you create your own Linux Mint ISO - you could do that to blacklist the Nouveau driver and boot into text mode. How to remaster/respin Linux Mint ISO images - Linux Mint Community
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Posts
    2
    Thanks for the informative answer.

    I do think it is taking a long time for the Linux community to address this problem. It must be affecting a lot of potential Linux users. Unless you know what is going on behind the scenes you are stuck.

    I asked the same question on the Linux Mint forums and got a reply which works. Basically it involves using the safe mode option, editing the command line by adding "nomodeset" before the final "--". I then booted into safe mode again and installed the current Nvidia driver from the root shell. After running "nvidia-xconfig" and rebooting it worked.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Glad you solved this problem. Your post and methods will be helpful to others, I am sure! Anyway, please mark this thread as "closed".
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •