Find the answer to your Linux question:
Results 1 to 7 of 7
I'm trying to install a package on Redhat 5. When I try to install this package (unixODBC-devel-2.2.11-7.1.x86_64.rpm), rpm complains that its already installed. However, when I query for this package ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7

    RPM is buggy


    I'm trying to install a package on Redhat 5. When I try to install this package (unixODBC-devel-2.2.11-7.1.x86_64.rpm), rpm complains that its already installed. However, when I query for this package or even try to uninstall it, its not there. Any ideas?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    Are you on a 32-bit system?
    Code:
    uname -a
    If so, you don't want a 64-bit package.

    If that's not it, try using yum to install the package. It is a package manager that uses rpm behind the scenes, and handles dependencies for you (Sometimes it helps, sometimes it is worse than rpm...)

    e.g.:
    Code:
    yum install unixODBC-devel-2.2.11-7.1.x86_64.rpm
    If it fails, show your exact command, and the exact error.

    Also, run this command, to show what is in the RPM database:

    Code:
    rpm -qa|grep unixODBC

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7
    Yes i'm on 64 bit system. I tried installing the package using yum and got the following message.
    does not update installed package.
    Nothing to do


    [root@localhost packages]# uname -a
    Linux localhost.localdomain 2.6.18-274.el5 #1 SMP Fri Jul 8 17:36:59 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

    [root@localhost packages]# rpm -qa | grep unixODBC*
    [root@localhost packages]#

    [root@localhost packages]# yum install unixODBC-2.2.11-7.1.x86_64.rpm
    Loaded plugins: product-id, security, subscription-manager
    Updating Red Hat repositories.
    Setting up Install Process
    Examining unixODBC-2.2.11-7.1.x86_64.rpm: unixODBC-2.2.11-7.1.x86_64
    unixODBC-2.2.11-7.1.x86_64.rpm: does not update installed package.
    Nothing to do

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    Where did you get this file (unixODBC-devel-2.2.11-7.1.x86_64.rpm) from? Do you have a link?

    also, what does this show:

    Code:
    rpm -ivh ./unixODBC-devel-2.2.11-7.1.x86_64.rpm
    and what is the package name:
    Code:
    rpm -qp ./unixODBC-devel-2.2.11-7.1.x86_64.rpm --queryformat='%{NAME}\n'

  5. #5
    Just Joined!
    Join Date
    Aug 2012
    Posts
    7
    Adding the dot in front of the package worked. Thanks.

    rpm -ivh ./package_name

  6. #6
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    If using yum, you should use
    Code:
    yum localinstall somepackage.rpm
    It has the same effect as
    Code:
    rpm -Uvh somepackage.rpm
    The difference is that yum will automatically resolve and install any missing dependencies.

  7. #7
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    Quote Originally Posted by jinster75 View Post
    Adding the dot in front of the package worked. Thanks.

    rpm -ivh ./package_name
    aha. just so you know, the ./ prepended to the filename means that the command (rpm, yum, etc.) will look for the file in the current working directory.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •