Find the answer to your Linux question:
Results 1 to 7 of 7
I have an old laptop ( HP Compaq 6510b ) that i am trying to install Linux on but it seems to be very picky about what distros it will ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    2

    Laptop will not load certain live Cd's / install discs


    I have an old laptop ( HP Compaq 6510b ) that i am trying to install Linux on but it seems to be very picky about what distros it will let me install. So far I have had no problem with Debian , Fedora , and Crunchbang , but just about everything else I have tried I am greeted with a blank screen when I try to load the live CD / install disc . I have checked the discs themselves by loading them in a different system and they all work fine. I have even tried burning the discs on a different system , still no change. Also , this may be a separate issue but but when my laptop boots and says " press f12 for boot menu " it will not load the boot menu no matter how quickly , repeatedly , or firmly I press f12.

  2. #2
    Linux User
    Join Date
    Nov 2008
    Location
    Tokyo, Japan
    Posts
    260
    I can think of several reasons why this may happen, so we need more information.
    1. the CD-ROM in your laptop may have difficulty reading burned discs, not always but sometimes. Have you had problems like this before?
    2. this might be a stupid question, but are you sure you got the Intel X86 live CD, and not for some other architecture like AMD-X86, ARM, or PowerPC?
    3. are you burning a copy of an ISO image file? what software are you using to burn discs?

    Also, try pressing F12 with the function key down? On my Dell, you can set the F-keys to execute functions like volume-up, volume-down, and you need to hold down the "Fn" key to send a F12 key event to the computer, and this feature is configured in the BIOS menu, so it is "built-in" to the keyboard, not part of the operating system.

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    2
    Well I have not had this laptop for very long so this is the only time i have run into this problem. I have been using Brasero to burn the install / live cds and I have tried making new copies of all the discs on another computer (using gnomebaker) . The ones that work now still work and the ones that didn't work still don't work . Like I said before I have only had luck with Debian , crunchbang , and fedora ( what i am running now . ) About a dozen others I have tried ( of the correct architecture) , but nothing but a black screen . As for the boot menu , when I press f9 ( f12 is for network boot , which also doesnt work ) it says "loading boot menu " , but than I just get the same black screen as with so many of the install discs , which is why I thought they may be related .

  4. #4
    Just Joined!
    Join Date
    Mar 2009
    Location
    Santa Cruz, California
    Posts
    76
    It's quite probable that your problem is that the screen driver that is setup when you boot the live CD is unable to determine an appropriate resolution for your monitor, and gives up trying to do so. Most such problems have been fixed in the drivers provided with Debian and RedHat and related distros, but haven't gotten updated in other distros you've tried.

    Sometimes a resolution that works is arrived at, but it's too high for your monitor, and the screen image is cropped, so a crucial control or panel is off-screen. Other times the chosen resolution is too low. Usually what I do in this case is to create an /etc/X11/xorg.conf file and edit it to set the screen modes.

  5. #5
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,042
    Code:
    HP Compaq 6510b
    https://wiki.archlinux.org/index.php/HP_Compaq_6510b

    HP-Compaq 6510B [LinLap - Linux Laptop Wiki]

    Summary

    There are absolutely no problems at all in using Linux on the HP-Compaq 6510B. Most up to date Linux distributions should be able to handle this laptop just fine.
    But sometimes it can be hit or miss. I would be using live usb on that instead of cd/dvd to save on bucks. Heck. I even use live usb on usb 1.1 with no usb bios boot support when I can.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  6. #6
    Linux Newbie mactruck's Avatar
    Join Date
    Apr 2012
    Location
    City of Salt
    Posts
    185
    When I had this problem on an old PC is was because my computer did not have enough RAM. Tried distro's that required less RAM and it worked fine.

  7. #7
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    934
    I have had this problem on some older laptops due to the manufacturers display's being proprietary in nature. Using an alternate install, Vesa driver, or just trying different distro's to find out which ones it liked did the trick. You have found three distro's, explore them to see if you can live with them, or look for an alternate install ISO of the one you want.
    Registered Linux user #526930

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •