Find the answer to your Linux question:
Results 1 to 4 of 4
I have an Allied Data Copperjet 800 USB ADSL modem. I'm in the UK, and I'm trying to get it to work with Freeserve Broadband. I found some drivers for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2002
    Posts
    2

    USB ADSL modem troubles


    I have an Allied Data Copperjet 800 USB ADSL modem. I'm in the UK, and I'm trying to get it to work with Freeserve Broadband. I found some drivers for the modem (ppoe won't work because it's not connected to an Ethernet card), and they're in beta (co800.sourceforge.net). I come up with a problem when I compile the drivers - about the stage when the kernel modules are being built (the errors from make are below). It could just be that the drivers aren't working because they're in beta, but I don't want to have to wait until they develop further. It's a little disappointing, so I'm hoping somebody can help. Any ideas?

    [root@localhost co800_static_IP_v1.0.0_beta]# make
    make -C fwload
    make[1]: Entering directory `/root/co800_static_IP_v1.0.0_beta/fwload'
    cc -I../lib/libusb -c common.c
    cc -I../lib/libusb -lusb 5160.c common.o -o 5160
    cc -I../lib/libusb -c 5200pfw.c
    cc -I../lib/libusb -lusb -lm 5200.c common.o 5200pfw.o -o 5200
    5200.c:308:32: warning: multi-line string literals are deprecated
    cc -I../lib/libusb -lusb co800ioctl.c -o co800ioctl
    make[1]: Leaving directory `/root/co800_static_IP_v1.0.0_beta/fwload'
    make -C module
    make[1]: Entering directory `/root/co800_static_IP_v1.0.0_beta/module'
    cc -DMODULE -I../lib/sarlib -I/usr/src/linux/drivers/usb -I/usr/src/linux/include -include /usr/src/linux/include/linux/config.h -O3 -Wall -Wstrict-prototypes -fomit-frame-pointer -pipe -D__KERNEL__ -c co800.c
    <command line>:137971655:18384: /usr/src/linux/include/linux/config.h: No such file or directory
    In file included from /usr/include/linux/prefetch.h:13,
    from /usr/include/linux/list.h:6,
    from /usr/include/linux/module.h:11,
    from co800.c:12:
    /usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/asm/processor.h:55: requested alignment is not a constant
    In file included from /usr/include/linux/module.h:297,
    from co800.c:12:
    /usr/include/linux/version.h:2:2: #error "================================================= ======"
    /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
    /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
    /usr/include/linux/version.h:5:2: #error ""
    /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
    /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
    /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
    /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
    /usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
    /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
    /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
    /usr/include/linux/version.h:13:2: #error ""
    /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
    /usr/include/linux/version.h:15:2: #error ""
    /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
    /usr/include/linux/version.h:17:2: #error ""
    /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
    /usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
    /usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
    /usr/include/linux/version.h:21:2: #error ""
    /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
    /usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
    /usr/include/linux/version.h:24:2: #error ""
    /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
    /usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
    /usr/include/linux/version.h:27:2: #error ""
    /usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
    /usr/include/linux/version.h:29:2: #error ""
    /usr/include/linux/version.h:30:2: #error " instead of"
    /usr/include/linux/version.h:31:2: #error ""
    /usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
    /usr/include/linux/version.h:33:2: #error ""
    /usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
    /usr/include/linux/version.h:35:2: #error "================================================= ======"
    In file included from co800.c:12:
    /usr/include/linux/module.h:299: parse error before "UTS_RELEASE"
    /usr/include/linux/module.h: In function `print_symbol':
    /usr/include/linux/module.h:433: `ESRCH' undeclared (first use in this function)
    /usr/include/linux/module.h:433: (Each undeclared identifier is reported only once
    /usr/include/linux/module.h:433: for each function it appears in.)
    In file included from /usr/include/linux/usb.h:136,
    from co800.c:22:
    /usr/include/linux/version.h:2:2: #error "================================================= ======"
    /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
    /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
    /usr/include/linux/version.h:5:2: #error ""
    /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
    /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
    /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
    /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
    /usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
    /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
    /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
    /usr/include/linux/version.h:13:2: #error ""
    /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
    /usr/include/linux/version.h:15:2: #error ""
    /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
    /usr/include/linux/version.h:17:2: #error ""
    /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
    /usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
    /usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
    /usr/include/linux/version.h:21:2: #error ""
    /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
    /usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
    /usr/include/linux/version.h:24:2: #error ""
    /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
    /usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
    /usr/include/linux/version.h:27:2: #error ""
    /usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
    /usr/include/linux/version.h:29:2: #error ""
    /usr/include/linux/version.h:30:2: #error " instead of"
    /usr/include/linux/version.h:31:2: #error ""
    /usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
    /usr/include/linux/version.h:33:2: #error ""
    /usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
    /usr/include/linux/version.h:35:2: #error "================================================= ======"
    In file included from /usr/include/asm/hardirq.h:6,
    from /usr/include/linux/interrupt.h:46,
    from /usr/include/linux/usb.h:139,
    from co800.c:22:
    /usr/include/linux/irq.h: At top level:
    /usr/include/linux/irq.h:65: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/linux/irq.h:65: requested alignment is not a constant
    In file included from /usr/include/linux/interrupt.h:46,
    from /usr/include/linux/usb.h:139,
    from co800.c:22:
    /usr/include/asm/hardirq.h:16: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/asm/hardirq.h:16: requested alignment is not a constant
    In file included from /usr/include/linux/usb.h:139,
    from co800.c:22:
    /usr/include/linux/interrupt.h:129: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
    /usr/include/linux/interrupt.h:129: requested alignment is not a constant
    In file included from co800.c:26:
    /usr/include/linux/atmdev.h:214:22: net/sock.h: No such file or directory
    In file included from co800.c:26:
    /usr/include/linux/atmdev.h: In function `atm_may_send':
    /usr/include/linux/atmdev.h:450: dereferencing pointer to incomplete type
    In file included from ../lib/sarlib/sarlib.h:16,
    from co800.c:28:
    /usr/include/linux/version.h:2:2: #error "================================================= ======"
    /usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
    /usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
    /usr/include/linux/version.h:5:2: #error ""
    /usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
    /usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
    /usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
    /usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
    /usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
    /usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
    /usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
    /usr/include/linux/version.h:13:2: #error ""
    /usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
    /usr/include/linux/version.h:15:2: #error ""
    /usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
    /usr/include/linux/version.h:17:2: #error ""
    /usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
    /usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
    /usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
    /usr/include/linux/version.h:21:2: #error ""
    /usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
    /usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
    /usr/include/linux/version.h:24:2: #error ""
    /usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
    /usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
    /usr/include/linux/version.h:27:2: #error ""
    /usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
    /usr/include/linux/version.h:29:2: #error ""
    /usr/include/linux/version.h:30:2: #error " instead of"
    /usr/include/linux/version.h:31:2: #error ""
    /usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
    /usr/include/linux/version.h:33:2: #error ""
    /usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
    /usr/include/linux/version.h:35:2: #error "================================================= ======"
    In file included from co800.c:28:
    ../lib/sarlib/sarlib.h:17:41: missing binary operator before '('
    In file included from ../lib/sarlib/sarlib.h:20,
    from co800.c:28:
    /usr/include/linux/malloc.h:4:2: warning: #warning linux/malloc.h is deprecated, use linux/slab.h instead.
    co800.c:183:16: warning: multi-line string literals are deprecated
    make[1]: *** [co800.o] Error 1
    make[1]: Leaving directory `/root/co800_static_IP_v1.0.0_beta/module'
    make: *** [all] Error 2

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It seems to me that you don't have your kernel source code installed. You will need that to compile kernel drivers.

  3. #3
    Just Joined!
    Join Date
    Oct 2002
    Posts
    2
    I worked that out myself in the end anyway - the kernel source is hidden in the depths of the Mandrake internationalization CD (what a strange place to put it!). However, I've hit another problem - the drivers ask for my static I.P. address and I have a dynamic one. What should I do?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Quote Originally Posted by o0zi
    make[1]: Entering directory `/root/co800_static_IP_v1.0.0_beta/fwload'
    It seems to me (by looking at the name) that you downloaded a driver that only is for static IP addresses. See if there is one for dynamic ones instead.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •