Find the answer to your Linux question:
Results 1 to 2 of 2
I've been trying to install Mint for two days now. I used unetbootin to create a bootable USB disk. It boots fine, and installs fine. But when it comes to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3

    Linux Mint 14 MacBook Pro - GRUB issues


    I've been trying to install Mint for two days now. I used unetbootin to create a bootable USB disk. It boots fine, and installs fine. But when it comes to installing GRUB I would get a message saying that grub-efi failed to installed to "//target//" I don't know what that means exactly. Manually installing GRUB didn't work, it said "installation impossible." I've tried using boot-repair as well, but that didn't work. I've tried a manual install after mounting my installation and binding dev, sys, and proc, that kind of gave my something, but I can't remember what it was exactly. It said that it could install block sectors but it was highly recommended that it wasn't done.

    When I try to boot the installation after doing all that I get a grub rescue prompt. I tried using that to boot, but I get a bunch of errors about missing symbols ('grub_reaidt' when trying to load linux module and 'grub_disk_dev_list' when trying to load normal module). I can't even load the linux module. The only thing I can think of that's affecting it is that, with rEFIt installed, it's trying to boot the installation that's setup for EFI in an MBR manner. If that makes any sense. It doesn't show up in the Apple EFI list of bootable media, so I don't think it's actually EFI bootable, which could explain why rEFIt would want to boot it as MBR, right?

    Anyways, I'm at my wit's end here. I'd really love to give Mint a go.


    This is my partition layout:

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 583817207 Mac OS X HFS+
    3 584079360 968914943 Basic Data
    4 968916879 976773118 Linux Swap

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 409639 ee EFI Protective
    2 409640 583817207 af Mac OS X HFS+
    3 * 584079360 968914943 83 Linux
    4 968916879 976773118 82 Linux swap / Solaris

    MBR contents:
    Boot Code: GRUB

    Partition at LBA 40:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 1, type EFI System (FAT)

    Partition at LBA 409640:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 2, type Mac OS X HFS+
    Listed in MBR as partition 2, type af Mac OS X HFS+

    Partition at LBA 584079360:
    Boot Code: GRUB
    File System: ext4
    Listed in GPT as partition 3, type Basic Data
    Listed in MBR as partition 3, type 83 Linux, active

    Partition at LBA 968916879:
    Boot Code: None
    File System: Unknown
    Listed in GPT as partition 4, type Linux Swap
    Listed in MBR as partition 4, type 82 Linux swap /


    Thanks.

    EDIT: I have since moved from rEFIt to rEFInd, but that hasn't helped.

  2. #2
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    I found the solution. Before installing, you have to update the grub, grub2, and grub-efi packages. There are missing dependencies for the grub-efi package and the package itself is broken I think. I didn't look so much into what caused the problem as fixing it, but this works. The only issue I have is that grub takes precedence over my rEFInd installation, but that's probably due to my selecting "something else" as opposed to "Alongside Mac OS X" when I chose the partitioning scheme. This might be a matter of simply installing rEFInd again. All works well, I can get to rEFInd by holding the 'option' key at boot and selecting the HDD labeled "EFI Boot."

    I hope this helps someone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •