Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I'm trying my first attept at PXE booting and having the following problem. I'm using an net-boot installation image to iSCSI-backed storage (for Calxeda's highbank ARM architecture), and the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    12

    network-install PXE boot question


    Hi,
    I'm trying my first attept at PXE booting and having the following problem. I'm using an net-boot installation image to iSCSI-backed storage (for Calxeda's highbank ARM architecture), and the installation appears to go fine, i.e. I go through a normal installation process, the iSCSI storage is found and written to, so here's the output of the "file" command for the storage file:

    test.img: x86 boot sector; partition 1: ID=0x83, active, starthead 1, startsector 63, 497952 sectors; partition 2: ID=0x83, starthead 0, startsector 498015, 14699475 sectors; partition 3: ID=0x5, starthead 0, startsector 15197490, 787185 sectors, code offset 0xb8

    To my eye this seems fine, but I'm not sure how to get it to reboot into this installed image. If this was an install using a physical media like a CD or a USB stick then one just removes it at the end of installation and the system would boot into the new image. How do I achieve the same via PXE booting after an install? My default.cfg install file on my TFTP server for the initial install is:

    LABEL ubuntu1204-armhf
    kernel /vmlinuz
    MENU LABEL ubuntu1204-armhf
    append initrd=/initrd.gz console=ttyAMA0 locale=en_US priority=critical text

    What must this become to now boot into the installed image?

    TIA

  2. #2
    Linux Enthusiast
    Join Date
    Jan 2005
    Location
    Saint Paul, MN
    Posts
    649
    Are you attempting to run the image that resides on the iSCSI like a liveDVD or are you doing an install to the hard drive?

    If it is like a liveDVD, then you will need to have the initramfs's init script to mount the iSCSI image on the needed layout, and then "switchroot" to that mount point.

    If you are installing onto the PXE client machine, then the machine will need to reboot to use the new image off the local drive. Usually that is done within the install script that is run to do the local imaging.

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    12
    Quote Originally Posted by alf55 View Post
    Are you attempting to run the image that resides on the iSCSI like a liveDVD or are you doing an install to the hard drive?
    The first option, in that the booting processor's image resides on another machine's (the iSCSI server's) hard drive. Unlike a liveDVD though, this storage is meant to be a persistent. Are there any specific HowTo's out there that you'd recommend?

    Thx.

  4. #4
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    896
    You need to enable your network card to boot from iSCSI:
    iscsiboot - Etherboot/gPXE Wiki
    ...or...

    You might be able to modify the PXE boot menu to support booting from iSCSI if you wish:
    PXE Booting NFS or iSCSI Roots for a Diskless Environment | Novell User Communities

    I have never attempted to boot a bare-metal system from iscsi, so I have no idea if the above method will work or not.

    Update: Another guide you can try: PXE Booting Ubuntu from an iSCSI drive Tinkering with Linux and Electronics

  5. #5
    Just Joined!
    Join Date
    Dec 2009
    Posts
    12
    Thanks for the pointers guys. In the end I got it to work by creating an image from an existing install, made sure it had all the iscsi tools installed in it together with a relevant init file, generated an initrd file and used correspong vmlinuz file, and then passed the correct iscsi-related boot options via the default PXE file that's pulled from the TFTP server. A software engineer shouldn't have to be doing this!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •