Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have installed webmin, when I click on MON Service Monitor under System meny i get this error : The MON configuration file /etc/mon/mon.cf was not found on your ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    Sydney, Australia
    Posts
    42

    Webmin - Mon service monitor not working ?


    Hello,

    I have installed webmin, when I click on MON Service Monitor under System meny i get this error :

    The MON configuration file /etc/mon/mon.cf was not found on your system. Maybe MON is not installed, or your module configuration is incorrect.

    I tried downloading and installing the RPM from rpmfind.net : I get so much of dependencies ...

    rpm -ivh mon-0.99.2-1.1.fc2.dag.i386.rpm
    warning: mon-0.99.2-1.1.fc2.dag.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
    error: Failed dependencies:
    perl(AOL::TOC) is needed by mon-0.99.2-1.1.fc2.dag
    perl(Math::TrulyRandom) is needed by mon-0.99.2-1.1.fc2.dag
    perl(Mon::Client) is needed by mon-0.99.2-1.1.fc2.dag
    perl(Mon::SNMP) is needed by mon-0.99.2-1.1.fc2.dag
    perl(Net::SNPP) is needed by mon-0.99.2-1.1.fc2.dag
    perl(Time::HiRes) is needed by mon-0.99.2-1.1.fc2.dag
    perl(Time::Period) is needed by mon-0.99.2-1.1.fc2.dag

    I tried installing the perl mdoule
    perl -MCPAN -e 'install AOL::TOC'

    I also tried installing from 'Webmin Modules' options but no luck.

    still i get the same error. any ideas to resolve the issue ? any help would be appricated ?

  2. #2
    Just Joined!
    Join Date
    Jan 2004
    Location
    Indiana
    Posts
    19

    Mon

    RPM is your best bet for installation and management of software. If you get dependencies then you need to go to CPAN and download everything it will need. Wether you install via rpm or tarball you will still have dependency problems.

    Go to CPAN and download all the Perl pm's you need. You can do this from within webmin. Nice little function and you can install it from webmin also.

    Gary Manigault

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •