Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
I have a PC with 2 drives, disk0 (hda) is 160GB, disk1 (hdb) is 40GB. My goal was to install Win XP and RH on hda and Mint on hdb. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Posts
    13

    Question Booting Mystery


    I have a PC with 2 drives, disk0 (hda) is 160GB, disk1 (hdb) is 40GB. My goal was to install Win XP and RH on hda and Mint on hdb.
    Furthermore, I wanted to be able to have all three show up in the boot list at boot time for me to choose which one.
    All 3 are installed and working, BUT -- if I boot from hda, I get choices of Win XP & RH from Grub 0.91 -- both work!
    However, if I boot from hdb, I get 3 choices; Mint, MS XP and RH, BUT -- only Mint and MS XP actually boot! If I select RH, it reboots the PC instead of booting RH.
    Right now the only way to see all 3 choices is to boot from hdb, but RH won't boot. If I boot from hda, I don't see Mint so booting from hda doesn't seem to be an option unless I can modify the bootloader to know about Mint on hdb. The alternative seems to be boot from hdb and figure out some way to modify the boot loader on hdb to successfully boot RH on hda.
    I was hoping to avoid a re-install of 1 or more OSs.
    What do you think?
    Ray

  2. #2
    Linux Newbie
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    120
    Hello Ray, welcome to the forums. My first recommendation would be to get inside Debian Pastezone and show us both grub files (both should be under /boot/grub/grub.cfg). To modify them, you should go to /etc/default/grub.cfg (I don't recall correct path since I'm having lunch at work.

    I'm thinking about including somehow an hdb line inside RH's boot menu. Even though I've never done that with 2 physical drives grub's manual (if any) or some information found online might be able to help you out. Maybe this one. There was another link, but page wouldn't load.

  3. #3
    Just Joined!
    Join Date
    Mar 2013
    Posts
    13
    ivotkl;
    Thanks for your reply -- I'm going to reply again but that reply will contain the grub files you requested.
    I'm not familiar with Debian Pastezone but if all it does is allow a convenient way to paste text into a post, then this time, I'll forgo the new learning excursion in favor of getting to my goal quicker.
    This reply was just to say 'thanks' and I'll work on the problem as you request.
    Ray

  4. #4
    Just Joined!
    Join Date
    Mar 2013
    Posts
    13
    ivotkl;
    Here are the 2 grub files you asked for:
    RH Grub
    Code:
         all kernel and initrd paths are relative to /boot/, eg.
    #          root (hd0,1)
    #          kernel /vmlinuz-version ro root=/dev/hda3
    #          initrd /initrd-version.img
    #boot=/dev/hda
    default=1
    timeout=10
    splashimage=(hd0,1)/grub/splash.xpm.gz
    title Red Hat Linux (2.4.18-3)
    	root (hd0,1)
    	kernel /vmlinuz-2.4.18-3 ro root=/dev/hda3 hdc=ide-scsi
    	initrd /initrd-2.4.18-3.img
    title Win-XP-Pro-SP3
    	rootnoverify (hd0,0)
    	chainloade================
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE:  You have a /boot partition.  This means that
    #     r +1
    ================
    Mint Grub
    ================
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    ================
    I hope you can see a way to allow me to both any of the 3 OSs (preferably by booting from only one of the 2 drives (hda or hdb)).
    Just to refresh; as of now, I can boot Win XP or RH, IF I boot from hda -- OR I can boot Win XP or Mint IF I boot from hdb.
    Thanks again for any help you can provide -- perhaps we'll hear from others as well!
    Ray
    Last edited by MikeTbob; 03-23-2013 at 04:19 AM. Reason: added code tags

  5. #5
    Linux Newbie
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    120
    rayl,
    I believe you've pasted Mint's /etc/default/grub file instead of /boot/grub/grub.cfg file. It might be exactly the same, but just to make sure.

    Besides that, could you paste the output of the below command as well? Both under RH and Mint.
    Code:
    sudo df -h
    One more thing, if you do not want to use Debian Pastezone, could you place the output between code? It makes reading easier.

    It's like this (without spaces):
    [ code ]Something here[ /code ]

    Example without the spaces on code looks like this:
    Code:
    Something here

  6. #6
    Just Joined!
    Join Date
    Mar 2013
    Posts
    13
    ivotkl;
    I did give you Mint's /etc/default/grub instead of /boot/grub/grub.cfg.

    Here is Mint's .cfg file you asked for and the output of df -h for both RH and Mint (RH is ver. 7.3, Mint is ver. 13).

    Code:
    RH
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/hda3              68G  1.7G   62G   3% /
    /dev/hda2              46M  8.8M   34M  21% /boot
    none                  977M     0  977M   0% /dev/shm
    Mint
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/sdb1        36G  3.8G   30G  12% /
    udev            969M  4.0K  969M   1% /dev
    tmpfs           391M  920K  390M   1% /run
    none            5.0M     0  5.0M   0% /run/lock
    none            976M   76K  976M   1% /run/shm
    /dev/sdc1       3.8G  1.3G  2.6G  32% /media/USB20FD
    Mint .cfg
    #
    # DO NOT EDIT THIS FILE
    #
    # It is automatically generated by grub-mkconfig using templates
    # from /etc/grub.d and settings from /etc/default/grub
    #
    
    ### BEGIN /etc/grub.d/00_header ###
    if [ -s $prefix/grubenv ]; then
      set have_grubenv=true
      load_env
    fi
    set default="0"
    if [ "${prev_saved_entry}" ]; then
      set saved_entry="${prev_saved_entry}"
      save_env saved_entry
      set prev_saved_entry=
      save_env prev_saved_entry
      set boot_once=true
    fi
    
    function savedefault {
      if [ -z "${boot_once}" ]; then
        saved_entry="${chosen}"
        save_env saved_entry
      fi
    }
    
    function recordfail {
      set recordfail=1
      if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
    }
    
    function load_video {
      insmod vbe
      insmod vga
      insmod video_bochs
      insmod video_cirrus
    }
    
    insmod part_msdos
    insmod ext2
    set root='(hd1,msdos1)'
    search --no-floppy --fs-uuid --set=root 57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79
    if loadfont /usr/share/grub/unicode.pf2 ; then
      set gfxmode=auto
      load_video
      insmod gfxterm
      insmod part_msdos
      insmod ext2
      set root='(hd1,msdos1)'
      search --no-floppy --fs-uuid --set=root 57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79
      set locale_dir=($root)/boot/grub/locale
      set lang=en_US
      insmod gettext
    fi
    terminal_output gfxterm
    if [ "${recordfail}" = 1 ]; then
      set timeout=-1
    else
      set timeout=10
    fi
    ### END /etc/grub.d/00_header ###
    
    ### BEGIN /etc/grub.d/05_debian_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=black/light-gray
    ### END /etc/grub.d/05_debian_theme ###
    
    ### BEGIN /etc/grub.d/06_mint_theme ###
    set menu_color_normal=white/black
    set menu_color_highlight=white/light-gray
    ### END /etc/grub.d/06_mint_theme ###
    
    ### BEGIN /etc/grub.d/10_linux ###
    function gfxmode {
    	set gfxpayload="$1"
    	if [ "$1" = "keep" ]; then
    		set vt_handoff=vt.handoff=7
    	else
    		set vt_handoff=
    	fi
    }
    if [ ${recordfail} != 1 ]; then
      if [ -e ${prefix}/gfxblacklist.txt ]; then
        if hwmatch ${prefix}/gfxblacklist.txt 3; then
          if [ ${match} = 0 ]; then
            set linux_gfx_mode=keep
          else
            set linux_gfx_mode=text
          fi
        else
          set linux_gfx_mode=text
        fi
      else
        set linux_gfx_mode=keep
      fi
    else
      set linux_gfx_mode=text
    fi
    export linux_gfx_mode
    if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
    menuentry 'Linux Mint 13 MATE 32-bit, 3.2.0-23-generic (/dev/sdb1)' --class linuxmint --class gnu-linux --class gnu --class os {
    	recordfail
    	gfxmode $linux_gfx_mode
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd1,msdos1)'
    	search --no-floppy --fs-uuid --set=root 57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79
    	linux	/boot/vmlinuz-3.2.0-23-generic root=UUID=57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79 ro   quiet splash $vt_handoff
    	initrd	/boot/initrd.img-3.2.0-23-generic
    }
    menuentry 'Linux Mint 13 MATE 32-bit, 3.2.0-23-generic (/dev/sdb1) -- recovery mode' --class linuxmint --class gnu-linux --class gnu --class os {
    	recordfail
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(hd1,msdos1)'
    	search --no-floppy --fs-uuid --set=root 57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79
    	echo	'Loading Linux 3.2.0-23-generic ...'
    	linux	/boot/vmlinuz-3.2.0-23-generic root=UUID=57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79 ro recovery nomodeset 
    	echo	'Loading initial ramdisk ...'
    	initrd	/boot/initrd.img-3.2.0-23-generic
    }
    ### END /etc/grub.d/10_linux ###
    
    ### BEGIN /etc/grub.d/10_lupin ###
    ### END /etc/grub.d/10_lupin ###
    
    ### BEGIN /etc/grub.d/20_linux_xen ###
    ### END /etc/grub.d/20_linux_xen ###
    
    ### BEGIN /etc/grub.d/20_memtest86+ ###
    menuentry "Memory test (memtest86+)" {
    	insmod part_msdos
    	insmod ext2
    	set root='(hd1,msdos1)'
    	search --no-floppy --fs-uuid --set=root 57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79
    	linux16	/boot/memtest86+.bin
    }
    menuentry "Memory test (memtest86+, serial console 115200)" {
    	insmod part_msdos
    	insmod ext2
    	set root='(hd1,msdos1)'
    	search --no-floppy --fs-uuid --set=root 57cd46d9-7a3a-4a75-a2a7-da6a8e8dbc79
    	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
    }
    ### END /etc/grub.d/20_memtest86+ ###
    
    ### BEGIN /etc/grub.d/30_os-prober ###
    menuentry "Microsoft Windows XP Professional (on /dev/sda1)" --class windows --class os {
    	insmod part_msdos
    	insmod ntfs
    	set root='(hd0,msdos1)'
    	search --no-floppy --fs-uuid --set=root F8FCDDF8FCDDB0DC
    	drivemap -s (hd0) ${root}
    	chainloader +1
    }
    menuentry "Red Hat Linux (2.4.18-3) (on /dev/sda3)" --class gnu-linux --class gnu --class os {
    	insmod part_msdos
    	insmod ext2
    	set root='(hd0,msdos2)'
    	search --no-floppy --fs-uuid --set=root 990142e6-8e42-11e2-921f-80f6f1dc4f99
    	linux /vmlinuz-2.4.18-3 ro root=/dev/hda3 hdc=ide-scsi
    	initrd /initrd-2.4.18-3.img
    }
    ### END /etc/grub.d/30_os-prober ###
    
    ### BEGIN /etc/grub.d/40_custom ###
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    ### END /etc/grub.d/40_custom ###
    
    ### BEGIN /etc/grub.d/41_custom ###
    if [ -f  $prefix/custom.cfg ]; then
      source $prefix/custom.cfg;
    fi
    ### END /etc/grub.d/41_custom ###

  7. #7
    Linux Newbie
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    120
    rayl,
    I believe you've pasted Mint's /etc/default/grub file instead of /boot/grub/grub.cfg file. It might be exactly the same, but just to make sure.

    Besides that, could you paste the output of the below command as well? Both under RH and Mint.
    Code:
    sudo df -h
    One more thing, if you do not want to use Debian Pastezone, could you place the output between code? It makes reading easier.

    It's like this (without spaces):
    [ code ]Something here[ /code ]

    Example without the spaces on code looks like this:
    Code:
    Something here

  8. #8
    Just Joined!
    Join Date
    Mar 2013
    Posts
    13
    Did you see my latest reply?

    I'm having some difficulty using this app.

    Sometimes when I click on the button to reply, I get a non-editable text area for the reply!

    I'll just keep slogging along!
    Ray

  9. #9
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    881
    Mint is using GRUB 2, and RH is using GRUB legacy.
    GRUB legacy cannot detect GRUB 2, so that's why you don't see it in the GRUB menu on the first hard drive. You can chain load GRUB 2 from GRUB Legacy.

    This article is long but should cover each scenario:
    GRUB 2 bootloader - Full tutorial

  10. #10
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The Red Hat version you have is incredibly old, the 2.4.18-3) kernel is over 11 years old.
    If you posted the entire Red Hat grub.conf file it should be obvious why you can't boot Mint. There is no entry for it. Either of the entries below in the grub.conf should boot Mint as it is on sdb1. Grub Legacy counts drives and partitions from zero, Grub2 counts drives from zero and partitions from one.

    title Mint
    root (hd1,0)
    kernel /boot/grub/core.img

    title Mint
    root (hd1,0)
    chainloader +1
    Your Red Hat entry in the Mint grub.cfg file points to the right drive and partition (set root='(hd0,msdos2)' but the following line (root=/dev/hda3) might be the problem. Do you have a separate /boot partition on sda2. Xp on sda1, Red Hat root partition is sda3 so...? You might try changing the root =/ to sda3 instead of hda3 in grub.cfg.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •