Find the answer to your Linux question:
Results 1 to 2 of 2
First, I installed Windows 8 in my desktop PC. (Not pre-installed... I did it by myself). Then I booted the Ubuntu dvd in UEFI mode (Did the same with Windows ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    18

    No Grub and Can't Boot into Windows 8 After installing Ubuntu 12.10


    First, I installed Windows 8 in my desktop PC. (Not pre-installed... I did it by myself). Then I booted the Ubuntu dvd in UEFI mode (Did the same with Windows and installed Ubuntu 12.10 64bit. Everything went perfectly. After rebooting, there's no grub! The system took me directly to Ubuntu! I can't log into Windows 8. Please help! Earlier, I used Boot Repair and it messd up with my Windows EFI files. So I was unable to boot Windows even after removing Ubuntu. I can't use boot repair. Now this is a new fresh install, Please tell me how to boot into both Windows 8 and Ubuntu!

    Here is my /etc/defaults/grub :

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=1024768
    #GRUB_GFXPAYLOAD_LINUX=1024768

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    Last edited by THpubs; 03-20-2013 at 02:18 AM.

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    910
    This article should cover all the details:
    https://help.ubuntu.com/community/UEFI

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •