Find the answer to your Linux question:
Results 1 to 5 of 5
Hey, Windows 7 won't boot anymore... really need some expert help. I recently installed Mint 15 MATE (alongside pre-installed windows 7) in my ASUS G75VW. I followed this post since ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2013
    Posts
    2

    Problem with Dual Boot: windows 7 on /sda and Mint 15 /sdb


    Hey,

    Windows 7 won't boot anymore... really need some expert help.

    I recently installed Mint 15 MATE (alongside pre-installed windows 7) in my ASUS G75VW. I followed this post since he also had a G75VW computer:
    rog.asus.com/forum/showthread.php?31112-G75vw-Linux-Mint-Installation-from-Hell-(very-long-post)

    However, although Mint boots and run normally, I can no longer boot to Windows 7. I researched a lot in the internet and tried rEFind, Boot-repair and some command lines (update grub). My problem may rely on the partition I chose (which now I regret a lot).

    This is what GParted shows me:
    /dev/sda
    /dev/sda1 fat32 (File System) /boot/efi (Mount Point) SYSTEM (Label) boot (Flags)
    /dev/sda2 unknown (File System) Null (Mount Point) Null (Label) msftres (Flags)
    /dev/sda3 ntfs (File System) Null (Mount Point) OS (Label) Null (Flags)
    /dev/sda4 ntfs (File System) Null (Mount Point) DATA (Label) Null (Flags)
    /dev/sda5 ntfs (File System) Null (Mount Point) Recovery (Label) hidden, diag (Flags)

    /dev/sdb
    /dev/sdb1 ntfs (File System) Null (Mount Point) SDATA1 (Label) Null (Flags)
    /dev/sdb2 ntfs (File System) Null (Mount Point) SDATA2 (Label) Null (Flags)
    /dev/sdb3 extended (File System) Null (Mount Point) Null (Label) Null (Flags)
    /dev/sdb5 ext4 (File System) / (Mount Point) Null (Label) Null (Flags)
    /dev/sdb6 linux-swap (File System) Null (Mount Point) Null (Label) Null (Flags)

    So... Windows 7 is on /dev/sda and Mint on /dev/sdb (which is another HD). There is a warning flag in the partition /dev/sda2 that says:
    Warning:
    Unable to detect file system! Possible reasons are:
    - The file system is damaged
    - The file system is unknown to GParted
    - There is no file system available (unformatted)
    - The device entry /dev/sda2 is missing

    This is what Boot-repair gave me:
    paste2.org/2U1zj556

    You can now reboot your computer.
    Please do not forget to make your BIOS boot on sdb (750GB) disk!
    The boot files of [The OS now in use - Linux Mint 15 Olivia] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair].
    A broken Wubi has been detected. Please fix it this way:


    ----------------
    When I try to choose Windows options (Windows UEFI bkpbootmgfw.efi; Windows Boot UEFI loader; Windows 7 (loader) (on /dev/sda3/)) in Grub, I receive an error message which is either:
    error: no such device: A2E4-0F9E
    error: /EFI/Microsoft/Boot/bxpbootmgfw.efi not found
    or
    error: invalid EFI file path

    Could anyone help me or point me to a link with a solution?
    Thanks!

  2. #2
    Just Joined!
    Join Date
    Aug 2012
    Posts
    1
    Hey,

    If the recovery partition /dev/sda5 is still intact, mark it active. You may be able to boot straight to it.
    After setting the recovery partition active, reboot the computer and press F11 when the machine is booting. This takes you to the recovery tools.
    Cheers,
    Yrjo

  3. #3
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Go to the site below and read the instructions, download and run the bootinfoscript on Mint and post the output here. It will contain more detailed info on boot files:

    Boot Info Script | Free System Administration software downloads at SourceForge.net

    error: no such device: A2E4-0F9E
    That's part of the problem, the letter/number combination is the uuid for the partition and it can't be found. It may not exist or may be the wrong one. sda2 may be the wrong partition to be pointing to.

  4. #4
    Just Joined!
    Join Date
    Jul 2013
    Posts
    2
    Thank you, guys... I tried what you said but still no success.
    I ended up installing mint in the whole computer.
    I will now try to use my recovery disks to install windows back as dual boot and see if it is easier.

  5. #5
    Just Joined! m5ernel's Avatar
    Join Date
    Mar 2011
    Posts
    4
    Try this: go to BIOS and change HD to boot from. Then reboot and see if it works. It did for me when I had the same issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •