Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have really messed up my PC I used to have a dual boot with Windows and Centos and everything worked fine. But after I upgraded to Centos 6 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    11

    Dual boot/GRUB mess


    Hi,

    I have really messed up my PC I used to have a dual boot with Windows and Centos and everything worked fine. But after I upgraded to Centos 6 the dual boot didn't work anymore. So I tried to fix it with some grub commands. It has gone horribly wrong and now I can't boot Centos at all. So I have been looking for solutions on the Internet but not been able to solve it. So hopefully there are some smart people here that can help me

    I now use a KNOPPIX 6.2 cd to boot. When I type fdisk -l I get the following:
    Device Boot ..... System
    /dev/sda1 ..... W95 FAT32
    /dev/sda2 * ...... HPFS/NTFS
    /dev/sda3 ...... Linux
    /dev/sda4 ...... Extended
    /dev/sda5 ...... Linux LVM

    My first question is: Why are there 5 disks? Does this mean I have created 5 partitions? I though I only had 2 partitions on the disk?

    Also, I can't remember where I installed Centos but is it most likely it is installed in sda3?

    Why is sda2 marked as boot? What determines what is marked as boot? Is this something I can change using GRUB?

    Any tips on how I can solve my problem?

    I would appreciate any help. Thanks in advance!

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    You have 5 partitions on your disk. /dev/sda1 appears to be the Windows recovery partition, ./dev/sda2 is the actual Windows installation and the other 3 are your Linux partitions. In terms of sorting out your boot issues, try the instructions at TipsAndTricks/ReinstallGRUB - CentOS Wiki . Post back if you need further assistance.

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    11
    Thank you so much for clarifying regarding partitions!

    I tried to follow the instructions:
    First I typed : mount /dev/sda3 /mnt
    Then I typed : chroot /mnt/sysimage
    I got the following error mesage: chroot : cannot change root directory to /mnt/sysimage: No such file or directory

  4. $spacer_open
    $spacer_close
  5. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    I don't think you have to manually mount /dev/sda3. When you run the installation disk and choose the Rescue Installed System option, the root partition will be automatically mounted, so all you would need to do is chroot to /mnt/sysimage and run the appropriate commands to reinstall grub.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •