Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I am a Windows 8 user who decided to try linux and completely messed my notebook. Few days ago I installed in dualboot OpenSuse 12.3 and it worked fine ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    2

    grub rescue (file normal.mod not found) + BIOS problem


    Hi,

    I am a Windows 8 user who decided to try linux and completely messed my notebook. Few days ago I installed in dualboot OpenSuse 12.3 and it worked fine but I wanted to try something else so I deleted all OpenSuse partitions (I know it was a mistake) and installed Linux Mint. The installation worked without any problem but I could boot into it only via its installation live DVD because BIOS didn't have Linux Mint in its boot options and Windows 8 didn't give me any choice to boot Mint (but boot to W8 was ok). And then I made two big mistakes. First I ran boot-repair and then accidentally restored defaults in BIOS so my situation is this:

    1) When I try to boot Windows Boot Manager appears a GRUB screen saying:

    error: file `/boot/grub2/x86_64-efi/normal.mod' not found.

    2) BIOS restoration deleted other boot options. Before there were 4 - Windows Boot Manager, OpenSuse and 2x DVD ROM (once as P2 and once as UEFI). Now there is only Windows Boot Manager and sometimes UEFI DVD ROM - only if there is a linux DVD (so if I try to boot Windows or UBCD BIOS doesn't detect it).

    Could you please help me? I've spent 2 days trying to solve this problem and now I am really desperate.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Do you have a Secure Boot option in your BIOS? You need to disable that and boot the Mint CD/DVD to install. You might post some drive/partition information from the Linux Mint CD. When you boot it, open a terminal and run this command: sudo fdisk -l(Lower Case Letter L in the command) and post the output here.

  3. #3
    Just Joined!
    Join Date
    Oct 2013
    Posts
    2
    Secure Boot was the first thing I disabled.

    fdisk command says "Warning: GPT detected on '/dev/sda'! The util fdisk doesn't suppoert GPT. Use GNU Parted." and shows only /dev/sda1

    GParted shows this i39.tinypic.com/2vljl3p.jpg

    Thanks for your help.

    EDIT:
    And maybe this could help too.
    paste.ubuntu.com/6198348/
    Last edited by honzik; 10-05-2013 at 11:13 PM.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The link you posted with GParted image shows 9 partitions, 5 windows, two Linux and 2 unknown. Your Mint install would be on sda8. You have GPT partitioning and the message you got just indicates fdisk can't read that which is why you needed GParted.

    The boot repair page you linked to shows Lilo installed in the mbr of the drive?? Don't know how that happened since Mint AFAIK, has never used it. Mostly Slackware and derivatives still use it. At the bottom of the Boot Repair page, there are several messages that sda4 (the windows system partition) is in an unsafe state. Don't know what happened there or what that means. If you look at this link which shows the Mint grub.cfg file, there is an entry for windows system as well as windows recovery partitions so you should just need to install Grub to the mbr of the drive. The Boot Repair page seems to indicate that this was attempted so I don't know what went wrong with it.

    Are you able to boot anything? Can you boot a Mint CD/DVD? There is also information in the Boot Repair page relating to windows, Mint as well as Opensuse. I'm not sure why there would be a reference to Opensuse. You might be better off, if you can boot the Mint DVD, reinstalling it from scratch to sda8, the only current Linux partition and accepting the default for Device for bootloader installation as /dev/sda, the master boot record.

    error: file `/boot/grub2/x86_64-efi/normal.mod' not found.
    The above message just references that specific file (normal.mod) which is one of over 90 files in the /boot/grub directory. Not sure what its use is but I've seen that error reported before. Have you tried booting the Mint DVD and copying that file to the /boot/grub directory on sda8? I doubt that will resolve the problem but might be worth trying.

    A suggestion. After installing Opensuse successfully and deciding you wanted to try another Linux, your best option would have been to simply to format and install Mint to the same partition on which you had Opensuse rather than deleting partitions. That changes the partition sequence and can lead to problems.

    The installation worked without any problem but I could boot into it only via its installation live DVD
    The above would indicate to me that you did not install the Mint Grub bootloader to the master boot record.

    Windows 8 didn't give me any choice to boot Mint
    That is standard. You will not see windows ever giving you an option to boot Linux. It is possible but you or anyone installing Linux and using a windows bootloader will have to manually configure it by creating and entry. Mostly, this is done with third party software.

    If you want to try installing the Mint Grub bootloader to the master boot record, try the following commands in sequence, hit the Enter key after each command and watch the results. You need to do this from the Mint DVD, open a terminal/konsole in which to run the commands.

    sudo mkdir /mnt/sda8
    sudo mount -t ext4 /dev/sda8 /mnt/sda8
    sudo grub-install --root-directory=/mnt/sda8 /dev/sda

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •