Find the answer to your Linux question:
Results 1 to 4 of 4
Hello All How are u?? I hope you're fine I'm compiling from source for educational purpose I want to make mcrypt from source and mcrypt need libmcrypt but i have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2013
    Posts
    2

    Building Mcrypt from Libmcrypt version problem


    Hello All
    How are u??
    I hope you're fine

    I'm compiling from source for educational purpose
    I want to make mcrypt from source and mcrypt need libmcrypt but i have a problem with the version when it compiled
    I compiled libmcrypt seccefuly but when i want compile mcrypt it told me that my version of libmcrypt is under 2.5.0 !!!! Here the problem
    I downloaded the latest libmcrypt from the sourceforge its version is 2.5.8 but i fail in the configure script of mcrypt !!!!
    Here the last piece from the output of configure script of mcrypt
    Code:
    checking for libmcrypt-config... /usr/local/bin/libmcrypt-config
    checking for libmcrypt - version >= 2.5.0... no
    *** Could not run libmcrypt test program, checking why...
    *** The test program compiled, but did not run. This usually means
    *** that the run-time linker is not finding LIBMCRYPT or finding the wrong
    *** version of LIBMCRYPT. If it is not finding LIBMCRYPT, you'll need to set your
    *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
    *** to the installed location  Also, make sure you have run ldconfig if that
    *** is required on your system
    ***
    *** If you have an old version installed, it is best to remove it, although
    *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
    ***
    configure: error: *** libmcrypt was not found

    Can someone expert try to compile mcrypt + libmcrypt (Both from the source)

    i downloaded everything from ht tp://sour ceforge.n et/projects/mcrypt/ (mcrypt + libmcrypt) please remove the spaces in the link

    Does there a problem in the mcrypt configure script??!!!

    Thank you all

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    hi,

    i was able to get farther than you with these steps:

    Code:
    mkdir /opt/mcrypt
    mkdir ~/src/mcrypt
    cd ~/src/mcrypt
    wget http://downloads.sourceforge.net/project/mcrypt/MCrypt/2.6.8/mcrypt-2.6.8.tar.gz
    wget http://downloads.sourceforge.net/project/mcrypt/Libmcrypt/2.5.8/libmcrypt-2.5.8.tar.bz2
    tar jxf libmcrypt-2.5.8.tar.bz2
    cd libmcrypt-2.5.8
    ./configure --prefix=/opt/mcrypt
    make
    make install
    cd ..
    tar zxf mcrypt-2.6.8.tar.gz
    cd mcrypt-2.6.8
    ./configure --prefix=/opt/mcrypt --with-libmcrypt-prefix=/opt/mcrypt

  3. #3
    Just Joined!
    Join Date
    Oct 2013
    Posts
    2
    Thank you

    I found the problem and solved it
    I was having 2 libmcrypt installed in my linux
    One from the distribution and the second which i have installed it
    So for i solved this problem i would have to change some environnement variables
    Code:
    PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
    LD_LIBRARY_PATH=/usr/local/lib
    And everything works fine

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    great, glad you got it sorted.

    i'll mark this as Solved for you. Note that you can do this yourself using the Thread Tools link at the top of the page.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •