Find the answer to your Linux question:
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By rixtertrader
I've decided to come over to Linux and discover what it can do for me. I'm a Windows 7 user with tons of technical and programming experience but a total ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2014
    Posts
    4

    Linux Newbie Having Trouble Installing Linux (multiple distros)


    I've decided to come over to Linux and discover what it can do for me. I'm a Windows 7 user with tons of technical and programming experience but a total newbee when it comes to Linux and its commands, etc.

    Gotta start somewhere, right?

    Okay, here's the problem.

    I have a Sony Vaio desktop computer with 512mb ram (yeah, it's several years old). Figured Linux would liven it up some.

    I originally installed Bodhi Linux (which it still has) on this machine without any issues. Still boots into this distro. Tried to install Python 3 and had too much trouble so I decided I want to try other distros.

    So now I'm trying to install Ubuntu 13.10. After a few minutes it kicks out into a command line shell. This is what is shows:

    Busybox v1.20.2.... built-in shell.
    (initramfs)

    Funny thing is that Linux Mint 16 (cinnamon) installation does the exact same thing! (I did notice that it also referred to Ubuntu in the shell text, so clearly a common problem).

    Two different DVDs, two different Distros. So I know it is not my DVDs.

    Help?

  2. #2
    Just Joined!
    Join Date
    Mar 2014
    Posts
    4
    Well, I guess this was a tough one because I have to reply to my own question. LOL!

    No worries. I actually got it to work and am replying to my own post for the benefit of others.

    It seems that this was due to something wacky with one of my hard drives.

    My system is several years old, so it does not have RAID or SATA, nothing so obvious. Just two plain old 160g IDE drives and a BIOS with very little settings to deal with.

    What I did was to boot into GPARTED.

    I noticed that my secondary drive had an exclamation mark next to it.

    Without knowing what the problem is, I decided to delete the drives, then make the first one NTFS and the second one an EXTENDED drive.

    This seems to have worked as Ubuntu installed fine after this.

    Hmmmm.


  3. #3
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Bodhi is a light version of Linux based on Ubuntu so you should not have any problems. Did you try to install Python from the Bodhi/Ubuntu repositories? Which release of Bodhi do you have?

    You might have problems with Ubuntu with only 512MB of RAM as that is the absolute minimum and 1GB is recommended. Mint Cinammon might be a little better.

    I'm not really sure what your drive/partition setup looked like before the install since you didn't post any details. Maybe you didn't have anywhere to install? Just be aware that distributions like Ubuntu require more RAM and if you decide to keep it, you might want to put more RAM in it.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer TNFrank's Avatar
    Join Date
    Jul 2013
    Location
    Crossville, TN. USA
    Posts
    998
    I've said it in other threads and I'll say it again here. Give Point Linux 2.3 or SolydX a try. Both are Debian based, PL has a MATE DE and SolydX has an xfce DE and both run on limited amounts of RAM. I find that I like going to the source(i.e. Debian) rather then using Ubuntu which is derived from Debian. Hit Distro Watch and download both and give em' a test drive, I'm sure you'll like one or the other pretty well. I know I like both of em'.

  6. #5
    Just Joined!
    Join Date
    Mar 2014
    Posts
    4
    Oh cool. Thanks! I'll do that.

    Don't know what MATE DE and xfce DE means at this point of my education, but I'll 'Bing' it.

    My goal at the end of this is to not only learn Linux (finally), but Python programming within it (yes I know I can do this with Windows, but I thought I'd kill two birds..yada yada).

    Thanks.

  7. #6
    Linux Engineer TNFrank's Avatar
    Join Date
    Jul 2013
    Location
    Crossville, TN. USA
    Posts
    998
    Give this a read, maybe it'll clear some stuff up about DE's(i.e. Desktop Environments)
    Desktop Environments for Linux - Renewable PCs

  8. #7
    Just Joined!
    Join Date
    Mar 2014
    Posts
    4
    That was helpful TNFrank.

    Thank you.
    TNFrank likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •