Find the answer to your Linux question:
Results 1 to 4 of 4
Hi. I have accidentally installed syslinux on a windows 7 disk, on the first partition. It seems that, i don't know why, the sysnlinux installed on the "mbr" (the first ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    5

    Problem with syslinux loading Windows 7


    Hi. I have accidentally installed syslinux on a windows 7 disk, on the first partition.

    It seems that, i don't know why, the sysnlinux installed on the "mbr" (the first sector) of the first partition, not the first sector of the whole disk.

    Anyway: The syslinux got installed on the boot partition of windows 7, the one containing the bootmgr file.

    So, i simply configured it to use chain.c32 to boot using the bootmgr, i placed the needed files to run COM32, and then i configured the syslinux.cfg with this parameters:

    Code:
    LABEL win7
    MENU LABEL win7
    COM32 chain.c32
    APPEND ntldr=bootmgr
    But, when booting, it says: "Err: Couldn't read the first disk sector".
    So i tried specifying the disk: I started by hd0, nothing. hd 0 0, nothing. hd 0 2, nothing. But, when i chose hd0 1, it gave me the same message, but the system rebooted shortly after, and some random characters appeared on the screen, on a very, very short duration, something about 0,1 second or less before rebooting.

    So, anyone know what's happening?

    Just to remember: The Disk mbr is still the same, the only thing changed was the first sector (the "mbr") of the active partition, which is the first partition of the disk, the one containing the Windows 7 bootloader. The second partition is the main and biggest partition, and the third contains a backup of the system.

    Ps.: I used the latest syslinux version from kernel.org, and all the files i used (chain.c32 etc) came from the same package.

    Thanks!

  2. #2
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    238
    Use one of those tools that allow you to repair the mbr. I've used the "mini tool partition wizard" live cd to good effect.

  3. #3
    Just Joined!
    Join Date
    Nov 2009
    Posts
    5
    Quote Originally Posted by voidpointer69 View Post
    Use one of those tools that allow you to repair the mbr. I've used the "mini tool partition wizard" live cd to good effect.
    But as i've said, the actual mbr wasn't changed. Only the first sector of the active partition (which is also the first partition) was changed, so, recovering the mbr doesn't solve much thing. I need a way to make syslinux load windows

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Do you have the windows 7 boot code in the master boot record of the disk? Or something else? Have you mounted your windows partition with the boot files to see if all the needed files are there? I don't see how changing a syslinux menu is going to get your to boot windows. I guess I'm missing something here. I had syslinux booting several systems on a flash drive and used the menu entry below to boot windows 7 on the third drive, first partition:

    Code:
    LABEL Boot sda1
                          MENU LABEL Boot windows  
                          COM32 chain.c32
                          APPEND hd2 1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •