Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
Like Tree1Likes
I have done a little with a "Win 8" style laptop. To eliminate problems, go into the BIOS and shut off Secure Boot; then switch from UEFI mode to Legacy ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Newbie
    Join Date
    May 2014
    Location
    Hinesville, GA USA
    Posts
    210

    I have done a little with a "Win 8" style laptop. To eliminate problems, go into the BIOS and shut off Secure Boot; then switch from UEFI mode to Legacy mode. Then I would test your USB stick by booting it on the computer you made it on. Booting it will not damage anything, it will just boot into live USB mode. If Mint boots into the live system your USB stick is operating correctly - if not you'll have to create it again. Creating a reliable bootable USB stick can be tricky as it depends on having a perfect ISO downloaded and written correctly to the USB stick. It would not hurt to download another distro as well. I'd recommend MX-14 as it just seems to work on anything.

    http://www.mepiscommunity.org/mx

    Be sure to boot your laptop with the USB stick in a USB2 port as USB3 ports can be iffy as not all of them work as a boot device. A previous poster was correct that USB3 ports have a blue "board" inside the port versus the black "board" inside a USB2 port.

    Before it died, I was able to boot a Mint 17 USB stick on an Acer I had with UEFI and secure boot disabled from a USB2 port. It had Radeon video and Mint saw it and worked fine. I was actually able to boot it into a live system with secure boot and UEFI enabled but it likely would have been a mess trying to install it.

    While UEFI, secure boot and USB3 are the "future" of computers, each can cause problems - especially trying to boot an OS. The Acer died and I returned it and got an HP and once I disabled secure boot and enabled legacy boot mode I have been able to boot every distro I've tried from the USB2 port. Here is a hardware dump of MX-14 running from live USB on my Win 8 type laptop:

    Code:
    demo@mx1:~
    $ inxi -F
    System:    Host: mx1 Kernel: 3.12-0.bpo.1-686-pae i686 (32 bit) Desktop: Xfce 4.10.2 
               Distro: MX-14.2 Symbiosis 30 June 2014 
    Machine:   System: Hewlett-Packard product: HP ENVY dv6 Notebook PC v: 088B110000305910000620100
               Mobo: Hewlett-Packard model: 182D v: 55.24 Bios: Insyde v: F.13 date: 09/04/2012
    CPU:       Quad core AMD A10-4600M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB 
               Clock Speeds: 1: 1400 MHz 2: 1800 MHz 3: 1400 MHz 4: 1600 MHz
    Graphics:  Card: Advanced Micro Devices [AMD] ATI Device 9900
               Display Server: X.Org 1.12.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz
               GLX Renderer: Gallium 0.4 on AMD ARUBA GLX Version: 2.1 Mesa 8.0.5
    Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel 
               Card-2 Advanced Micro Devices [AMD] ATI Trinity HDMI Audio Controller driver: snd_hda_intel 
               Sound: Advanced Linux Sound Architecture v: k3.12-0.bpo.1-686-pae
    Network:   Card-1: Ralink Device 3290 driver: rt2800pci
               IF: wlan0 state: up speed: N/A duplex: N/A mac: 9c:2a:70:23:8d:11
               Card-2: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
               IF: eth0 state: down mac: 08:2e:5f:7b:ef:3d
    Drives:    HDD Total Size: 754.2GB (1.3% used) ID-1: /dev/sda model: WDC_WD7500BPKX size: 750.2GB
               ID-2: USB /dev/sdb model: Patriot_Memory size: 4.0GB
    Partition: ID-1: / size: 6.0G used: 38M (1%) fs: rootfs dev: N/A 
               ID-2: swap-1 size: 9.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda4 
    Sensors:   System Temperatures: cpu: 50.2C mobo: 30.0C gpu: 49.0 
               Fan Speeds (in rpm): cpu: N/A 
    Info:      Processes: 143 Uptime: 5 min Memory: 263.8/7580.9MB Client: Shell (bash) inxi: 2.1.28 
    demo@mx1:~
    Last edited by NGIB; 07-24-2014 at 09:44 AM.
    TNFrank likes this.

  2. #22
    Linux Newbie
    Join Date
    Jun 2014
    Posts
    134
    some options you could try

    boot the live usb and at the timeout screen for mint press f6, a menu will pop up and you can select start mint in compatibility mode from the menu

    or hit tab here and under the menu a line of code will appear then type nomodeset at the end of the line and enter.

    it may be possible to install and boot in cli mode and then install the drivers. the system is booting you just do not have a graphical user interface.

    as mentioned you may try a couple other distros

    as a resort you may install win7 to make the unit functional

  3. #23
    Just Joined!
    Join Date
    Jul 2014
    Posts
    10
    Okay, I was on a vacation this weekend so I had not made any progress. Today I decided to try a different distro and chose Ubunto 14.04, I followed the exact same steps I used for the Linux Mint. So downloaded the iso for Ubunto and used unetbootin to put it onto my USB flash drive. I then booted my laptop and from there the Ubunto has installed itself problem free.

    I AM SO F'ING HAPPY!!!!!

    Thanks for all your help!!! Im happy to answer any questions or give more details about the process if anybody needs it.

    Thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  4. #24
    Linux Newbie
    Join Date
    Jun 2014
    Posts
    134
    say, that's great news..thanks for posting your success

  5. #25
    Linux Engineer TNFrank's Avatar
    Join Date
    Jul 2013
    Location
    Crossville, TN. USA
    Posts
    870
    Some Distros have moved to UEFI comparability and Ubuntu is one of them IIRC so it should "play nice" with your UEFI system. I think you can do a search on the interweb for all the Distros that will be UEFI compatible and make a list of em' so you can try different ones until you find one you can live with. For me the Unity desktop just didn't give me the functionality that I was looking for but GNOME, Xfce and MATE all did so those are my "go to" desktops with GNOME being #1 on my list.
    Any Ubuntu 14.04 based Distro should also work just as well so you could give Ubuntu/GNOME, Xubuntu or the new Ubuntu/MATE a try as long as they're all 14.04LTS and they'll work for you.
    I'm just glad to hear you got some Linux on your box to play with, now it's time to learn a bit about Terminal commands(very easy stuff so don't be afraid to give it a try) and find out about all the great packages you can download and use.
    "Now, what y'all wanna do?
    Wanna be hackers? Code crackers? Slackers
    Wastin' time with all the chatroom yakkers?
    9 to 5, chillin' at Hewlett Packard?"

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •