Find the answer to your Linux question:
Results 1 to 6 of 6
I'm trying to install Mandrake 10.1 on an HP Netserver LH 3r. The problem is it gives this error: 'An error occurred - no valid devices were found on which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5

    Mandrake 10.1 Installation Problem with RAID system


    I'm trying to install Mandrake 10.1 on an HP Netserver LH 3r. The problem is it gives this error:
    'An error occurred - no valid devices were found on which to create new filesystems. Please check your hardware for the cause of his problem.'

    The server has a RAID array with 3 drives installed as one logical drive (hot swappable), I think I have correctly configured this. Any ideas please?

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    A friend of mine had the same problem,
    disabling 'apic' was his solution during the installtion

    he ran the install in textMode
    Press F1 for advance option and type
    Code:
    text noapic
    Hope his helps
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Yeah...apic and sometimes some power management (apm, apci) sometimes bork your scsi controllers. As Ugo suggested, boot without apic first (this is the most common culprit).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    Thanks, I'll give that a go.

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    Canada
    Posts
    1

    Installing Mandrake Linux 10 on a Compaq Presario

    Hi, I'm having trouble installing Mandrake Linux 10 on my Compaq Presario SR1120NX. I know the installation discs work because it's installed on my IBM NetVista.

    When the installation boots up, I go into text mode to continue installation. I've tried using:
    Code:
    text noapic
    as well as other arguments (noapm, noapci) and am getting nowhere with it. After alt0 and alt1 get booted, I get as far as the message "Ok, booting the kernel", the screen goes blank, and then the system reboots.

    Any suggestions?

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    9
    I'm running into the same initial error on my HP NetServer LH 3r, when trying to install Mandriva 2005 LE (10.2) and have tried the installation as suggested "text noapic" with the same results.

    The error that I am getting is 'insmod'ing module megaraid ...'

    I believe I've tracked this down to needed to upgrade the megaraid controller's firmware.

    Any suggestions would be appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •