Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Booting Fedora 21 from external hard drive


    Ok, I used my desktop to install Fed 21 Workstation on my external hard drive. It booted fine when i restarted my computer.

    I tried it on my laptop, alienware m14x. I went to boot from hard drive like my desktop, didn't work. I went to boot from USB it sat at a blank screen with blinking cursor.

    I looked around and people said it may be because you didn't put grub on the drive as well. I went back and re-installed Fedora making sure I did this. Worked on my desktop again, did same thing on the laptop.

    I even tried using my laptop to do the installation. Same problems, worked fine on the desktop, not on my laptop, still got blinking cursor.

    Some said it might be because you are trying to use the 3.0 buses. That is not the issue.

    I even tried it on my computer at work, it worked fine, booted up and was able to use it just fine.

    I know it works on my laptop because last year i had actually dual booted fedora 20 on it with windows and it ran just fine with no issues.

    I have looked all over google and here for an answer that I may have missed or is just not there. Does anyone have any idea why it won't work on my laptop.

  2. #2
    OK, I've never used USB boot, but just from gut feeling - what filesystem is your USB disk? The BIOS must be able to read it in order to boot from it, right...? (just from common sense).
    Anybody else have the requisite knowledge.....?

  3. #3
    i'm not sure the file system is the problem though, if other computers can boot from it just fine.

  4. $spacer_open
    $spacer_close
  5. #4
    absolutely.


    is there only one standard for USB boot, guys?

  6. #5
    -->
    OK, if you mean what filesystem I used for installing it, i don't know off hand it was just the standard install nothing special. I understand what you mean by the BIOS being able to read it but it's read it before being dual booted so I don't see any reason it can't read it here. Other than reading from USB.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •