Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unhappy Frustration with Linux


    It seems that installing Linux is getting more difficult, not easier, at least on my current computer.
    My fist install was mandrake in 2000, I have installed various versions since then.
    But my recent experience is very frustrating.
    I cannot install puppy linux.
    The ubuntu version 4.xx does not recognize mouse or keyboard (both razer usb)
    The tahr version will not set two monitors and I cannot seem to install nvidia drivers
    The version that installs alongside Windows 7 will not find my network card.
    I really like puppy - very disappointed.

    I just tried to install mint (I have used mint since version7 but not recently)
    It complained about the alignment of my partition and would not proceed, I used the live cd to create a partition, then it failed to install grub on that partition (I multi-boot so did not want grub on mbr) then installation crashed.

    Last week I successfully installed lxle excellent.

    But have had similar problems with other distributions. I have tried too many to mention.

    I don't know if others are having similar problems. When vista was such a disaster for Microsoft, I thought Linux would increase in popularity, so I am surprised at all the problems I am having. About 4/5 years ago, Linux installation seemed easier. Perhaps computers have got more complicated.

    The grub failing to install seems to have been happening with ubuntu derivative for the last year or so (though again no problems with lxle)

    Sorry for the rant..

  2. #2
    Grub installation on puppy is manual. Puppy is one of my favorite distro. If you want some steps to install puppy linux( my version is lucid 5.2., just leave me a message!

  3. #3

    It seems that installing Linux is getting more difficult, not easier, at least on my current computer.
    Ok.

    Running as a program inside of Windows 7. Installer was a .exe file.

    Code:
    # inxi -zv7
    System:    Host: biker Kernel: 3.10.32 i686 (32 bit gcc: 4.7.1) Desktop: JWM git-905 dm: N/A 
               Distro: Slacko Puppy Linux Linux 3.10.32 [ arch] 
    Machine:   System: Hewlett-Packard (portable) product: Presario CQ57 Notebook PC v: 068C110003204910000620100
               Mobo: Hewlett-Packard model: 3577 v: 24.48 Bios: Hewlett-Packard v: F.42 date: 11/07/2011
               Chassis: type: 10
    CPU:       Dual core AMD C-50 (-MCP-) cache: 1024 KB flags: (lm nx pae sse sse2 sse3 sse4a ssse3 svm) bmips: 3992 
               Clock Speeds: 1: 1000 MHz 2: 1000 MHz
    Graphics:  Card: ATI Device 9804 bus-ID: 00:01.0 chip-ID: 1002:9804
               Display Server: X.org 1.12.4 drivers: ati,radeon (unloaded: vesa)
               tty size: 149x37 Advanced Data: N/A for root
    Audio:     Card ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383 
               Sound: Advanced Linux Sound Architecture v: k3.10.32
    Network:   Card-1: Ralink Device 5390 driver: rt2800pci v: 2.3.0 bus-ID: 07:00.0 chip-ID: 1814:5390
               IF: wlan0 state: up speed: N/A duplex: N/A mac: <filter>
               Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
               driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 06:00.0 chip-ID: 10ec:8136
               IF: eth0 state: down mac: <filter>
               WAN IP: <filter> IF: eth0 ip: N/A ip-v6: N/A 
               IF: wlan0 ip: <filter> ip-v6: N/A 
    Drives:    HDD Total Size: 250.1GB (20.6% used) ID-1: /dev/sda model: WDC_WD2500BEVT size: 250.1GB serial: N/A
               Optical-1: /dev/scd0 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
               Optical-2: /dev/scd1 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
               Optical-3: /dev/scd2 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
               Optical-4: /dev/scd3 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
               Optical-5: /dev/sr0 model: hp DVDRAM GT31L rev: MR52 dev-links: cdrom,dvd
               Features: speed: 24x multisession: yes
               audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
               Optical-6: /dev/sr1 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
               Optical-7: /dev/sr2 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
               Optical-8: /dev/sr3 model: N/A rev: N/A dev-links: N/A
               Features: speed: N/A multisession: N/A audio: N/A dvd: N/A rw: none state: N/A 
    Partition: ID-1: /initrd/mnt/dev_save size: 122G used: 48G (40%) fs: fuseblk dev: /dev/sda5 label: N/A uuid: N/A
               ID-2: /initrd/pup_rw size: 4.0G used: 1.7G (43%) fs: ext3 dev: /dev/loop1 label: N/A uuid: N/A
    RAID:      System: supported: raid0 
               No RAID devices: /proc/mdstat, md_mod kernel module present
               Unused Devices: none
    Unmounted: ID-1: /dev/sda1 size: 0.21G fs: NTFS label: N/A uuid: N/A 
               ID-2: /dev/sda3 size: 15.63G fs: NTFS label: N/A uuid: N/A 
               ID-3: /dev/sda4 size: 4.26G fs: FAT (32 bit) label: N/A uuid: N/A 
               ID-4: /dev/sda6 size: 99.69G fs: NTFS label: N/A uuid: N/A 
    Sensors:   System Temperatures: cpu: 58.0C mobo: N/A gpu: 57.0 
               Fan Speeds (in rpm): cpu: N/A 
    Info:      Processes: 96 Uptime: 3:40 Memory: 350.3/3651.5MB Init: SysVinit v: N/A runlevel: 5 Gcc sys: 4.7.1 
               Client: Shell (bash 4.1.01 running in sakura) inxi: 2.1.28 
    # cat /etc/DISTRO_SPECS
    #One or more words that identify this distribution:
    DISTRO_NAME='Slacko Puppy'
    #version number of this distribution:
    DISTRO_VERSION=5.7.0
    #The distro whose binary packages were used to build this distribution:
    DISTRO_BINARY_COMPAT='slackware'
    #Prefix for some filenames: exs: slackosave.2fs, slacko-5.7.0.sfs
    DISTRO_FILE_PREFIX='slacko'
    #The version of the distro whose binary packages were used to build this distro:
    DISTRO_COMPAT_VERSION='14.0'
    #the kernel pet package used:
    DISTRO_KERNEL_PET='linux_kernel-3.10.32-slacko_PAE.pet'
    DISTRO_TARGETARCH='x86'
    DISTRO_XORG_AUTO='yes'
    DISTRO_DB_SUBNAME='slacko14'
    #32-byte alpha-numeric ID-string appended to vmlinuz, puppy_slacko_5.7.0.sfs, zdrv_slacko_5.7.0.sfs and devx.sfs:
    DISTRO_IDSTRING='s140309082357ZZZZ5.7.0XXXXXXXXXX'
    #Puppy default filenames...
    #Note, the 'SFS' files below are what the 'init' script in initrd.gz searches for,
    #for the partition, path and actual files loaded, see PUPSFS and ZDRV in /etc/rc.d/PUPSTATE
    DISTRO_PUPPYSFS='puppy_slacko_5.7.0.sfs'
    DISTRO_ZDRVSFS='zdrv_slacko_5.7.0.sfs'
    DISTRO_PUPPYDATE='Mar 2014'
    #multiarch distros, such as Ubuntu, will have this. ex: /usr/lib/i386-linux-gnu, so DISTRO_ARCHDIR=i386-linux-gnu
    DISTRO_ARCHDIR=''
    #
    Windows Installer (EXE installer)

    Use EXE installer to install Puppy Linux in Windows PC. This involves downloading an exe installer and then clicking on it (the usual way of installing programs in Windows). Find the version you like through the links below. Note that the current release is Slacko at version 5.7, Lucid Puppy is at version 5.28, and the default PAE ISO in Slacko enables access to installed RAM in machines with more than 4 GB.

    EXE downloads at Mediafire - see the author's discussion;
    EXE downloads at Shinobar's Sourceforge repository - see the author's discussion of Lucid Puppy and Precise Puppy versions.

    The installer will add to your boot menu (1) Linux in the first boot dialogue and (2) Grub menu for choosing how to use Puppy Linux in the second boot dialogue. The file menu.lst and a "puppy" folder containing the Puppy Linux files will be added to your hard drive.
    I can't think of anything more easier than that.


    or

    Downloads - Microsoft Windows

    My install was free. I can't speak for the leased operating system in the above link though. YMMV from mine.

  4. $spacer_open
    $spacer_close
  5. #4
    I 'installed' Slacko Puppy.exe, as I said above, it refused to detect my network card.

    Each version I tried had a different problem, which is surprising, you would think that once a hardware detection problem had been fixed it would propagate to all installations, but that does not seem to be the case. Yes it was easy to install, it just didn't work.

  6. #5
    KRISHNAZ I just installed Puppy Linux 528.exe, and when the screen came up after rebooting, I have no mouse or keyboard access. As I said in my earlier post, both are razer.

    I have ordered a Logitech wireless mouse and keyboard (550) and that might be ok... But is there a way to get ths to work with my current mouse and keyboard?

  7. #6
    hey brother, firstly i hope you tried all usb ports, maybe a problem in one of them. secondly maybe you have usb 3 port and a usb 2 mouse that was one of my cases on windows only though. But if you could give me the brand of your razer mouse maybe i would be able to help you out!!

  8. #7
    Btw can you give me also the details of how your pc os's are. how many os do you have. dual-boot etc.
    and if you wanted to install puppy, why didnt you use an iso instead of using .exe's that might be the problem.

    i can help you make a bootable usb puppy linux

  9. #8
    The point I was making was that I cannot understand why the different versions of linux, not just puppy Linux, all have different problems. So other versions of puppy, slacko, fatdog, etc. detect the mouse and keyboard withour problems, so why does lucid have a problem.

    I downloaded lupuplu528 and made a CD, when I booted it detected keyboard and mouse ok, however it did not detect my network card! Again other version found the card and had no problems connecting to the internet. I tried to find a driver from the list provided in the puppy application, but none of the ones I tried worked. In Windows 7, the driver was listed as killer e2200 NDIS 620

    Fatdog puppy doesn't seem to have a means of using dual monitors, I guess this is experimental.

    I have maybe 5 or 6 partitions for Windows 7, a few for XP, one for LXLE and another free for a Linux as yet not installed, where I tried to install mint. I use one version of Win 7 for working, one for games, one for audio/video stuff and another where I might load software I am not sure about - so I can delete the partition of necessary.

    On my earlier PC I had many Linux distributions including Centos, Arch, Ubuntu, Mint 12,14 and others I experimented with.

  10. #9
    Sorry Brother, but recently i had an error with a program where i wanted to use this command in the terminal : source .bashrc
    and had an error. This is why i upgraded to the latest puppy version which tahr, this is what i downloaded from here:
    i really loved lupu 528, and all was working well as well as my network card(integrated to the motherboard) without any network tweaking but due to this issue i upgraded. Tahr 6.0 CE is one of the latest and updated versions. I just checked your mail, and right now am really tired. Give me one more day and i will try to search for your driver for linux version.
    FOR AN ALTERNATIVE TRY THE TAHR 6.0 CE. maybe a miracle!!

  11. #10
    -->
    Thank you for still trying.
    I have tried tahr 6.0 CE which works perfectly apart from dual monitor. I cannot get it to use dual monitor. There is a dual monitor app which allows both monitors to work, but they show the identical screen.
    In LXLE the same app allows you to slide one monitor to the right of the other, but not in tahr.
    I tried quite a few times to install the nvidia driver, thinking this would solve the dual monitor problem (there is a thread on the puppy forum) but never succeeded.
    I think tahr is the way to go, seems more complete for my hardware.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •