Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Booting a GPT disk with UEFI


    I'm having trouble booting a new SSD with a new UEFI motherboard.

    I'm trying to keep my existing Arch install if possible, and have been messing about with it since last night.

    I used gdisk to manually partition the SSD with the required 512 Mb FAT32 UEFI system partition, and the remainder is set as an ext4 partition.

    The ext4 partition contains my old Arch installation copied over with rsync.

    Using an Arch install USB, I've chrooted into the system on the SSD and installed Grub. To do this I mounted the UEFI system partition at /boot and ran:

    Code:
    # grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub_uefi --recheck
    # grub-mkconfig -o /boot/grub/grub.cfg
    Now when I boot on the SSD, I get dumped straight into the Grub command line. So I think the SSD is at least booting, but Grub isn't configured correctly. Trying to run Grub from here doesn't do anything (besides clearing the screen):

    Code:
    grub> configfile (hd1,gpt1)/grub/grub.cfg
    I'm completely at a loss now, it's the first time I've tried UEFI and Googling is only confusing me more!

  2. #2
    -->
    So I solved the problem - because I'd manually created the boot partition, there were no kernel images in it, so grub didn't detect any OS and didn't add entries to the boot menu.

    Solving it was as easy as chrooting into the SSD from my live USB stick, and re-installing linux:

    Code:
    pacman -S linux

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •