Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unable to boot from USB on Samsung Chromebook

    I have been searching for a few days now (on and off) to find a solution to my problem.

    I would like to install Linux on my Samsung XE303C12 Chromebook. It has an ARM processor. Ultimately I would like to replace ChromeOS with Linux. I have been using Linux Mint for a few years but started on Linux Mandrake and used Fedora for a while after that.

    I have found many sites that describe how to install Linux on a Chromebook but I seem to be missing something important.

    I have downloaded the latest (at the time of this writing is 27) Fedora. I use the dd command to write the .raw image to my USB drive. The image writes successfully and I am able to see the drive on a separate computer. After the dd command the drive contains a "/", "/boot" and "/USB" partition. All partitions are mountable and contain information.

    My problem is the chromebook refuses to boot from the drive. I can use this drive to boot from my Asus chromebook and from a regular laptop so I don't think the drive is the problem.

    I'm in developer mode and hit "CTL U" at the scary boot screen but usually I am rewarded with a beep and a return to the scary boot screen.

    I tried an older version of Fedora and it actually tried to boot from the USB drive but failed because some file was missing or something. I didn't write down the exact message but I am unable to reproduce that now anyway.

    I am assuming my boot drive is missing some information that the Samsung chromebook needs or the info is in the wrong location?

    I'm not sure where to ask for help so I thought I'd try here.

    I've been using Linux for a few years but still consider myself a newbie.

  2. #2
    Linux Guru
    Join Date
    Dec 2013
    Quote Originally Posted by jeeper View Post
    It has an ARM processor.
    i have an arm-based laptop and it cannot boot from usb.
    does yours have an sd card slot?
    are you trying to install a distribution for ARM architecture?

    have you searched? e.g. "samsung XYZ install linux"?

  3. #3
    Thank you for taking the time to reply.

    Yes I am trying to install the image for ARM architecture. I have tried Fedora and Arch Linux so far. The version 17 did indeed boot from USB but does not complete the boot because something is missing. I am not allowed to post links because I don't have enough posts yet but I tried several sets of instructions at Fedora and Arch.

    My Samsung does seem to support USB boot. At least that is an assumption made since it did (at least once) boot from the USB device when I got the error that some particular file could not be found. Also the ChromeOS firmware restoration utility gives the option to write the image to USB or SD. In fact I tried using that utility (in one of my many attempts) to create the boot drive.

    The drive seems to come out the same no matter the method used to create the drive. This leads me to think the images (image) on the Fedora site do (does) not contain the information my Samsung needs to boot it. I have tried two separate "latest" images and one older image.

    I only have a 1 gig SD card so I have not tried creating a boot image on that. I suppose I can try that with a small enough image.

  4. $spacer_open
  5. #4
    Linux Guru
    Join Date
    Dec 2013
    Quote Originally Posted by jeeper View Post
    I have tried Fedora and Arch Linux so far.
    are you sure?
    archlinux does not support ARM architecture:
    are you sure this is an ARM laptop???

    actually you know what, f*ck it, it's easier to just make a one minute web search for you:
    yes, it's an arm device, and the top result gives a fairly detailed installation howto.

  6. #5
    Thanks for taking more time to try to help.

    I tried the installation instructions here:

    My problem is even if I copy and paste the commands on that page I get errors so I cannot succeed. I gave up.

    I ended up trading that Chromebook for a newer Acer with an Intel processor and have Fedora installed already. I won't be needing any more assistance on that Samsung.

    Thanks again for trying to help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts