Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, After I installed redhat 8.0 on my dell workstation and started using gnome, I can read from the cdrw drive, but when I tried to use gtoaster to scan ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2003
    Posts
    12

    how to enable CDRW drive?


    Hi,

    After I installed redhat 8.0 on my dell workstation and started using gnome, I can read from the cdrw drive, but when I tried to use gtoaster to scan bus for detect for any cdrw drive, nothing happens. I take this to mean it can't detect any cdrw drive.

    My cdrom drive is mounted on /dev/scd0

    Is there any additional stuff to do to enable the cdrw drive?

    Thanks!
    Yee Seng.

  2. #2
    Linux Engineer
    Join Date
    Nov 2002
    Location
    Queens, NY
    Posts
    1,319
    Try using cdrecord.
    The best things in life are free.

  3. #3
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    yes, you may need to enable scsi emulation for that drive

    also to double check run this in the terminal and post the results here:

    Code:
    cdrecord -scanbus
    are you using a bootloader or a floppy boot?
    have you tried k3b? I find it is far superior, you can get an rpm for it here:

    http://k3b.sourceforge.net/index.php?page=download.html

    *I know you will be tempted to get a later version, but try 0.75 - I know that to work with red hat 8 and know that the more recent versions have caused problems with red hat 8 in particular.

  4. #4
    Just Joined!
    Join Date
    Mar 2003
    Posts
    12

    cdrecord -scanbus

    Hey,.. thanks for the informative reply. The results of cdrecord -scanbus is as follows :

    [root@sparkle chanys]# cdrecord -scanbus
    Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
    Linux sg driver version: 3.1.24
    Using libscg version 'schily-0.5'
    scsibus0:
    0,0,0 0) 'FUJITSU ' 'MAP3147NP ' '5605' Disk
    0,1,0 1) *
    0,2,0 2) *
    0,3,0 3) *
    0,4,0 4) *
    0,5,0 5) *
    0,6,0 6) *
    0,7,0 7) *
    scsibus1:
    1,0,0 100) *
    1,1,0 101) *
    1,2,0 102) *
    1,3,0 103) *
    1,4,0 104) *
    1,5,0 105) *
    1,6,0 106) 'ARCHIVE ' 'Python 06408-XXX' '9050' Removable Tape
    1,7,0 107) *
    scsibus3:
    3,0,0 300) 'HL-DT-ST' 'CD-RW GCE-8481B ' 'C102' Removable CD-ROM
    3,1,0 301) *
    3,2,0 302) *
    3,3,0 303) *
    3,4,0 304) *
    3,5,0 305) *
    3,6,0 306) *
    3,7,0 307) *

    Does this mean that I don't need to enable scsi emulation? If so, then something must be wrong with gtoaster...?
    Will try that K3B you mentioned.

    Thanks,
    Yee Seng.

  5. #5
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    well, it shows your cd-rw fine, but you have a unique setup for one.

    here is my output for cdrecord -scanbus:

    Code:
     cdrecord -scanbus
    Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jrg Schilling
    Linux sg driver version: 3.1.24
    Using libscg version 'schily-0.7'
    cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c 1.75 02/10/21 Copyright 1997 J. Schilling').
    scsibus0:
            0,0,0     0) 'LITE-ON ' 'LTR-52246S      ' '6S0D' Removable CD-ROM
            0,1,0     1) *
            0,2,0     2) *
            0,3,0     3) *
            0,4,0     4) *
            0,5,0     5) *
            0,6,0     6) *
            0,7,0     7) *
    so your might be different, I think by default the cd recording software might be scd0, you might have to tell it to use scd3 instead due to your setup. Either way, k3b is still way better to use to burn data.
    Check your burning software to see if it recognizes your burner and see if you can change the bus to the appropriate scsi if it is set incorrectly.

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    No, not scd3. It will still be scd0. They are numbered in the order that they are registered for the SCSI CD driver.
    I've got no idea how gtoaster really works, though. It might actually be that it only scans the first bus. Yes, that would be stupid, but after all, most people only have the emulation bus. You can always burn directly with cdrecord, though. That's the method that I usually use.

  7. #7
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    ok, thanks for clearing that up Dolda
    I still say to use k3b though if he wants a gui recorder

  8. #8
    Just Joined!
    Join Date
    Mar 2003
    Posts
    12

    solved

    Hey guys,

    Thanks for the various feedbacks. I'm learning something new from you all everytime.

    I guess gtoaster only scans scsi bus 0 by default. There's a place where I can specify the scsi id for the cdrom drive. It was set to 0,0 initially. Thought it meant <bus#>,<device#>
    But no... I had to set to 1,0,0 to denote <bus-1>,<device-0>,<not-sure-wat-this-is>

    Thanks!
    Yee Seng.

  9. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The last number is the LUN (logical unit number), which is used to differentiate between different subfunctions of drives. Most drives only have one LUN, but those multi-disk SCSI CD-ROMS use a different LUN to refer to each disk, for example.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •