Find the answer to your Linux question:
Results 1 to 4 of 4
I'm trying to install Fedora 3 on my system, but I seem to be having a little bit of trouble with the installer. A week or two ago, I decided ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7

    Fedora Installation Hard Drive Error


    I'm trying to install Fedora 3 on my system, but I seem to be having a little bit of trouble with the installer. A week or two ago, I decided to try the free community version of Mandrake Linux. I didn't really like it because of all the hardware problems it had and I was told I was most likely getting these errors because the free version of mandrake was fairly crippled. In that case, I'm trying fedora 3. I'm told it's very stable and about as easy to install as mandrake. I burned all of the CD's ok, but I seem to be having a problem after I get into the install wizard. It prompts me for my language and I choose English. Then it asks me for my keyboard type and I select the appropriate. Right after selecting the keyboard type, the installer starts attempting to read off of the hard drive, and after freezing for about 60 seconds, I get two errors. The one that pops up first is "Input/Output error during read on /dev/hda" and the next is "Invalid partion table on /dev/hda - wrong signature b78c". I think this might have something to do with maybe me installing mandrake. I haven't yet uninstalled mandrake, but I wish to overwrite it with Fedora. Can someone instruct me on what to do in order to solve the hard drive problem. I have a strong feeling it envolves the Mandrake partions I already have, so I downloaded Knoppix if I need to use QTparted. I'm also defragmenting now so I should be fine if I have to actually change or add partions. You might want to note I've never actually had to use QTparted .

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Fedora does have some problems with certain partitions (have a look at my response here :-
    http://www.linuxforums.org/forum/top...tml&highlight=
    )

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7
    Ok, umm.., unfortunately I'm a total newb when it comes using linux, especially when you start throwing code at me, so I'm not really even following you at all. At the very least, can someone explain to me where I need to actually type this code in? I'm confused even more now.

  4. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Sorry Razorback, didn't mean to flood you there.

    Right, do you still have a Linux that works? ie. is Mandrake still bootable? If so, get yourself a terminal window open. Now type
    Code:
    su -
    and then type in the root/superuser password when asked (note, the "-" after the su is meant to be there, make sure it is entered as such). Your terminal window's command prompt should now end with a # rather than a $, this shows that you have root priveldges (is that how its spelt?).


    Now you can start on the commands that I showed, so enter
    Code:
    fdisk -l /dev/hda
    and make a note of the number of heads that it says your hard disk has. Now enter the second command -
    Code:
    sfdisk -l /dev/hda
    and again make a note of the number of heads that your hard disk has. If the two numbers are the same, then you do not have the problem that I thought, and so the rest of this post is of no use to you (sorry).

    If the two numbers (the number of heads that your hard disk has) are different, then you need to tell the kernel what it should be by entering :-
    Code:
    echo bios_head:255  >  /proc/ide/hda/settings
    where the 255 should be replaced by the number of heads that the fdisk (the first command) showed. In other words, if the first command showed 64, then you should replace the 255 with the 64 that you found out.

    Like I said, this may not be your problem, but by running the first two commands and looking at the number of heads that are shown, if they are different, then this is your problem, if they are the same, then you have a different problem.


    Nerderello

    bye the way, entering exit (twice) will get you out of your terminal window.

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •