Find the answer to your Linux question:
Results 1 to 6 of 6
I just did the full Slackware 10 install. What do I add to /etc/lilo.conf to be able to boot into Slackware? Slackware is installed to /dev/hda4 and I chose the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028

    n00b and LILO


    I just did the full Slackware 10 install. What do I add to /etc/lilo.conf to be able to boot into Slackware? Slackware is installed to /dev/hda4 and I chose the kernel /cdrom/kernels/bare.i/bzImage I put

    Code:
    image=/boot/vmlinuz
             root=/dev/hda4
            label=Slackware
    in /etc/lilo.conf but when I select that I get "Kernel panic: VFS: Unable to mount root fs on 03:02".

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    try something like:
    Code:
    #stanza for Slackware with root partition on /dev/hda4.
      image = /boot/vmlinuz                        #Location of kernal
      label = Slackware                               #Name of OS (for the boot menu)
      root = /dev/hda4                                #Location of root partition
    Has the /boot/vmlinuz got a number after it? or is it vmlinux and not vmlinuz, it is on some sytems IIRC.

    If these are correct, check that you do not need an initrd image also in lilo.conf such as
    Code:
     initrd=/boot/initrd-2.4.0-0.43.6.img
    you will find this file in slackwares /boot directory.

    hope this helps;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    /boot/vmlinuz doesn't have a number after it.

  4. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Is there a initrd file you can add to it? like :
    Code:
    #stanza for Slackware with root partition on /dev/hda4.
      image = /boot/vmlinuz                        #Location of kernal
      label = Slackware                               #Name of OS (for the boot menu)
      root = /dev/hda4                                #Location of root partition
      initrd=/boot/initrd-2.4.0-0.43.6.img
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    I am having almost exactly the same problem. The previous line complains about not locating a reiser fs on /dev/hda3. If i boot using the boot floppy created during install it works fine. After booting I can confirm the filesystem on /dev/hda3 is mounted on / and is a resierfs type. I tried to reconfigure lilo last night and it hung on the loading linux message. I'll give it another shot tonight when I have more time.

    What does the initrd image do? It is not in my lilo.conf file.

    Thanks,
    Matt

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    Ok, still getting the same thing tonight, so I booted from the floppy again. Then I started X so I could hit the forums again. While there I opened a terminal and ran liloconfig again, this time choosing the auto install and selected to install in MBR this time. Don't know which made the difference but this time it booted ok from the hard drive. Lilo was loading from the boot partition before so I assume moving it to the MBR isn't what fixed it, but obviously I could be wrong about that. I figure this 'expert' (read: noob) didn't select something correctly when I used the 'expert' option before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •